PowerEdge 1855 w Centos 6.2 No Controllers Found in OMSA - Systems Management Forum - Servers - Dell Community

PowerEdge 1855 w Centos 6.2 No Controllers Found in OMSA


Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

PowerEdge 1855 w Centos 6.2 No Controllers Found in OMSA

This question is not answered

We are attempting to install OMSA software on several Dell 1855 blades running 64 bit versions of Linux and have run into what is apparently a well documented issue with the 64 bit version of OMSA software being unable to see the Hard Drive raid controller.  We have tried two different versions of Linux - Scientific Linux version 6.1 and Centos version 6.2.  We have attempted to follow the instructions found on this page -


Which details the steps necessary to trick the machine into downloading and installing the 32 bit version of the OMSA software (which is apparently able to see the drive controller just fine).  Unfortunately these steps which were written for Centos 5 apparently are not effective with Centos 6 or Scientific Linux 6.  After following the instructions the command

yum install srvadmin-all

results in the following -

 Package           Arch        Version               Repository            Size
 srvadmin-all      x86_64      6.5.0-1.1.1.el6       dell-omsa-indep      2.5 k

Transaction Summary
Install       1 Package(s)

Total download size: 2.5 k
Installed size: 9
Is this ok [y/N]

We need some way to trick version 6 of Centos or Scientific Linux into installing the 32 bit version
of the OMSA software.  I have attempted to manually install the rpm that I was able to download from
the Dell website, but unfortunately the rpm brings up a list several screens long of dependencies
which have to be resolved, and attempts to resolve those dependencies via yum results in the 64 bit
versions of the software being installed.  Are there any other options available to get a workable
version of OMSA on these machines with these operating systems?

All Replies
  • same issue here, can't see a PERC 4 scsi controller on a 64-bit servadmin install.  Very frustrating.  I wonder if Dell knows that SCSI drives still A.) Do exist, and B.) are quite heavily used?

    I attempted the same sort of backdoor fix, from the same post your mentioned previously, and had the same kind of thing happen at the end, where all the dependencies are 64-bit, and srvadmin-all itself was 64-bit.

    I'm running a PE2950 with CentOS 5.7

    Hope this gets fixed!

  • It's been a few months since I worked on this, but I was able to get this setup working on some machines using the following steps.  Keep in mind this was done on an 1855 using CentOS 6.2 so I don't know if the same procedure will work for you or not.  It's kind of an amalgam of steps from other posts that I read.  The steps where I say "Insert" means to replace the existing mirrorlist entries with the ones listed.

    wget -q -O - http://linux.dell.com/repo/hardware/OMSA_6.4/bootstrap.cgi | bash

    yum erase yum-dellsysid-2.2.26-6.2.el5

    rpm -Uvh http://linux.dell.com/repo/hardware/OMSA_6.4/platform_independent/rh50/firmware-tools/yum-dellsysid-2.2.26-6.2.el5.i386.rpm

    vi /etc/yum.repos.d/dell-omsa-repository.repo





    yum install srvadmin-all

    log out, then log back in

    yum install libstdc++.so.5

    srvadmin-services.sh start

    omreport storage controller

    log into https://ipaddress:1311 to check

  • extraordinary!  it worked perfectly, even with the latest omsa 7.0, which says specifically that it isn't compatible with perc 4 controllers.  Thanks!!

  • Do you do this in live boot mode before trying to install?