How to get the DRAC IP address from the localhost

Servers

Servers
Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

How to get the DRAC IP address from the localhost

  • Hi,

    We have couple of PowerEdge 1850 servers running custom RedHat Linux images. Our goal is to get the information of Lights Out Management cards installed in the server. I am just wondering is there a way to get the IP address of the local DRAC, lets say using a simple command line utility.

    I know that if it was a remote host, we need the IP address to talk to the DRAC. However, for a local DRAC, we should be able to talk to the RAC directly and get the information out of it. I tried to use 'racadm', but it needs the RAC IP address to talk to. For example, in case of HP we can use hponcfg to talk to the local iLO, without giving the iLO IP address. Is there such a thing in Dell.

    I am kind of newbie to the Dell Open Manage software and not sure how to get this done. I installed OM software and there are several commands and I couldn't quite get it if I can use those commands for this task. I greatly appreciate if anyone has inputs on this.

    Thanks
    Tejo
  • I believe what you're looking for is this:

    [root]# racadm getniccfg
    NIC Enabled = 1
    DHCP Enabled = 0
    IP Address = 192.168.0.120
    Subnet Mask = 255.255.255.0
    Gateway = 192.168.0.1

    (Note, above settings are the defaults for DRAC)

    You'll need to install srvadmin from the Installation and Server Management CD. Quick way to do this is issue /mnt/srvadmin/linux/supportscripts/srvadmin-install -x as root, assuming the cd is mounted under /mnt.

    Sven
  • Hi Sven,

    Thanks for your response. Finally my question got answered, and my efforts to post in this forum did not go in vain :-)

    Yes, this is exactly what I am looking for.

    I installed srvadm on my RHEL from the CD.
    The 'racadm' still is not able to talk to the DRAC 4

    Following is the output of racadm command. All the required processes are also running.

    --------------------------------------------------------------------
    [root]# racadm getniccfg
    ERROR: RACADM is unable to process the requested subcommand because there is no
    local RAC configuration to communicate with.

    Local RACADM subcommand execution requires the following:

    1. A Remote Access Controller (RAC) must be present on the managed server
    2. Appropriate managed node software must be installed and running on the
    server


    [root]# srvadmin-services.sh status
    dell_rbu (module) is running
    ipmi driver is running
    dsm_sa_datamgr32d (pid 1555) is running
    dsm_sa_eventmgr32d (pid 1577) is running
    dsm_sa_snmp32d (pid 1588) is running
    dsm_om_shrsvc32d (pid 1623) is running
    dsm_om_connsvc32d (pid 1695 1694) is running
    -----------------------------------------------------------------------------------

    Are there any other processes which should be running for this to work? Do I need to configure any special settings in the DRAC to enable inband communication?

    Appreciate your inputs on this.

    -Tejo
  • I found it. I tried to install some other RPMS manually from the package and then restarted the services and now I am able to get the niccfg ...

    I got what I am looking for :-))
    -----------------------------------------------------------------
    [root]# racadm getniccfg
    NIC = Enabled
    DHCP = Disabled
    Static IP Settings: 192.188.10.99 255.255.255.0 192.188.10.1
    Current IP Settings: 192.188.10.99 255.255.255.0 192.188.10.1
    ------------------------------------------------------------------

    Other RPMs I installed are (apart from the ones which the script has installled)
    (Note: I have a DRAC 4)

    srvadmin-rac4-components-5.1.0-354.i386.rpm
    srvadmin-racsvc-5.1.0-354.i386.rpm


    Uninstalled mgmtst-racadm-5.1.0-302 and installed srvadmin-racadm4-5.1.0-354.i386.rpm
    (first one seems to be incompatible with the second one). The second rpm is the one which actually worked.

    Mentioning the exact steps, so that if it might help anyone.

    Another interesting thread here on the same lines:
    http://lists.us.dell.com/pipermail/linux-poweredge/2007-January/029322.html

    Thanks Sven again. It all worked !!

    -Tejo