Dell Server Deployment Pack v2.0 RAID Array configuration problems on PowerEdge T110 II - Systems Management Forum - Servers - Dell Community

Dell Server Deployment Pack v2.0 RAID Array configuration problems on PowerEdge T110 II


Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

Dell Server Deployment Pack v2.0 RAID Array configuration problems on PowerEdge T110 II

This question has suggested answer(s)


I am trying to use the Dell Server Deployment Pack v2.0 with SCCM 2007, to configure the RAID Array of a PowerEdge T110 II Server. The RAID controller is a PERC S300, which as far as I can tell is supported.

Unfortunately, the RAID Controller is not detected. If I break into a command prompt during the configuration and run raidcfg -ctrl the controller is not detected. If I run x:\windows\temp\smstslog\packageid\tools\amd64\cscript Dell_ArrayBuilder.vbs u:\config.xml again the error received is controller is not detected.

I have specified the slot that the controller is located in, any controller etc... All are unsuccessful.

Any guidance would be greatly appreciated, as this is the final piece to be configured before releasing the deployment to production.


All Replies

    Firstly, have you gone to the System BIOS (F2) on startup and verified that the raid is Enabled under SATA Settings?

    Also, have you attempted to configure the raid through the controller BIOS, instead of the DSDP?

    Let me know what you find.


    Chris Hawk

    Dell | Social Outreach Services - Enterprise
    Get Support on Twitter @DellCaresPro 
    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • Yes - if i preconfigure the RAID through the BIOS the server builds with no problems...

    Everything is working for the build, accept the RAID Controller configuration. It is not detected when trying to configure it using the RAID Array wizard..

    I would prefer not to have to preconfigure the RAID, and Disks however, and have it all work using the Deployment Task Sequence.


  • Hi Locits,

    PERC S300 controller configuration is not supported in 64 bit Windows PE environment hence you are not able to configure RAID.

    Please use 32 bit boot image for the configuring RAID.


    Sumanth BR

  • Hi

    That has resolved the problem thankyou, although the disks arent being created, (I am hoping this is a problem with how I have configured, rather than something in DSDP.. lol)

    A general question however, will ALL SCSI controllers for all of the supported models in DSDP be supported using an x86 boot disk? As I will be configuring this to support various model types...



    Good to hear the issue is resolved. The Virtual disk creation is based on the rule you have defined in the Array Builder. Please check the rule and let us know if you need any help on that.

    Yeah x86 boot image supports all the controllers.

    These are the controllers that are not supported on 64 bit boot image.

    PERC S110, PERC S100, PERC 310, and PERC S300 software controllers


    Sumanth BR

  • Hi

    The configuration is currently as follows:

    PERC S300 SCSI Controller.

    Connected to this is:

    1 x 120GB SSD Drive

    2x 2TB SATA Drives

    I want to confiugure this so the SSD is drive 0, as a single volume, to host the guest OS, (Windows Server 2008 R2 Enterprise SP1)

    The SATA drives will be Disk 1, configured as a single RAID 1 volume.

    I cannot successfully get the RAID Wizard to configure this, and when running the same via a command line, when trying to configure the single SSD drive, all i receive is a message that I need to specify an additional drive to create a RAID volume..

    I have created a rule that for the controller in slot 1 (This is the correct slot) to create as above. It applies but does not create the volumes, as required.

    The RAID Configuration Wizard is configured as:

    For Controller in slot 1:

    Create a disk/volume using disks 2 and 3 RAID 1

    Create an additional disk using disk 1

    None of which are created.

    I've tried to step back and say, create a single volume, using one disk, and it says it is successful, but the disk/volume does not exist after a reboot?!

    Any advice greatly received!



    DSDP RAID wizard will create only Virtual Disks and Unfortunately to create a RAID (RAID 0) you need minimum of 2 disks.

    For your problem what you can do is you can use the RAID configuration INI file option in the task sequence instead of the Wizard. Create a INI file in that you specify RAID 1 for the disk 2 and 3.

    For the Disk 1 (SSD Disk) you can directly create a volume using the SCCM Format and Partition Step. Hope this helps!


    Sumanth BR