Forums

Servers

Servers
Information and ideas on Dell PowerEdge rack, tower and blade server solutions.

Windows 2008 Server on a PE-1950

  • Is any one successfully running Windows 2008 (any edition, either 32-bit x86, or 64-bit x64)? 

     

    I’ve got 2 PE-1950s with identical configurations. Server 1 originally had Windows 2003-R2 x86 Standard edition. It contained Domain Controller, DNS, IAS roles. I attempted an upgrade to Windows 2008 x86 Standard edition. Before the upgrade, I updated the BIOS, ESM Firmware, Backplane with the latest available revisions on the Dell Website. After the upgrade/install, I installed the latest drivers that were available via the Dell Website for the PERC 5i SAS Raid controller, Video, and Broadcom Net Extreme (including the management app). The server would randomly lockup after the upgrade. I attributed this to the upgrade scenario. I then did a fresh install which included a complete format of the hard-disk system. The fresh install contains the Domain Controller, Wins, DNS, and NAP (IAS) roles. The server still exhibits the random lockup problem. I have tried 3 fresh installs with this system. This behavior is random – it may be two hours before it locks up or it may be 12. It locks up several times a day, which requires physically powering the system down and back-up. 

     

    Two days ago, I installed Windows 2008 x64 Standard Edition on another PE-1950 (which was running Windows 2003-R2 x64 Standard Edition) as a clean install, reformatting the hard-disk systems. (this install occurred while I was experiencing the problem with J0CQHC1). It contains the Application Server (IIS) roles, and is joined to the domain. It to exhibits the same problem, but seems to run for a longer time between lock up, but still locks up a couple of times a day.

     

    Last night, on Server 1, I downgraded the ESM and Bios to the levels listed at this link (Windows Server 2008 Early Adopters Resource Guide - The Dell TechCent...). The server exhibited the lockup behavior twice when downgrading the ESM, which required me to utilize the OpenManage Sever Update CD to re-flash the ESM and then perform the downgrade again.

     

    My guess, since I’ve got the same issue with similar servers, with both 32-bit and 64-bit operating systems is that this is a firmware/bios issue. Can someone provide me with the following that they are using in their successful configuration:

    1)      Can you provide the Backplane, Broadcom, Bios, and ESM, and PERC 5i Firmware versions that you are successfully using?

    2)      Can you provide the PERC 5i, Video, and Broadcom drivers versions that you are successfully using?

     

    Both servers are dual Intel Processors (dual core), 4GB ram, PERC 5i SAS Raid, and Broadcom integrated network cards.  

     

    Each lock-up leaves nothing in the event logs, and the install/upgrades all concluded without any problems (either during the actual install/upgrade), or as indicated by any event log entries. Dell Diagnostics on both systems pass without any problems. I have also run the Windows 2008 memory checker tool on both systems, which as passes.

     

    Any help is greatly appreciated!

  • I can confirm everything written above. I've 2 PE 1950 which show lockups under Windows Server 2008. I updated all Firmwares and Drivers today and installed all Microsoft Patches with no effect.

     

    To me it seems to be a problem with the Broadcom driver. I deactivated Teaming of the NICs and the server is running till now. But no guarantee for that.

     

    Hopefully Dell will soon fix this thing of give an workaround.

  • Did you ever get a solution for this problem? I’m planning to install Win 2008 Web server in one of our PE1950 and I want to know if you ever came out with a solution. Also, did you have any problem during the installation of Win 2008 and the Perc5i controller?

  • This may or may not be affecting your servers, I have posted else where on this forum about the following issue after going to 2008. The symptoms can be different from one server to another, one network to another. Sometimes servers just lockup, sometimes network browsing stops, varied symptoms.

    http://www.petri.co.il/forums/showthread.php?t=25791