Windows Media Center - Tuner not Available error

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

Windows Media Center - Tuner not Available error

This question has suggested answer(s)

I have a XPS 420 w/ Vista SP1 and have been using the ATi TV Wonder digital cable tuner with a cablecard to watch tv with window media center for more than 5 months and couldn't be happier. Then last week I could no longer get a signal and was getting an error message when I try to watch live tv of 'Tuner Not Available - The tuner is currently in use by another application or is not working. Please close all other applications, restart Windows Media Center, and then try again.' Also, when I try and set up my tv connection again it cannot find a tuner, and the little preview pane that is in the bottom left corner of the program says 'Disk Error'.

 

I contacted Dell XPS support and after 2 hours of the guy connected to my computer without being able to figure it out (removing and reinstalling drivers) he said I need to reinstall Windows Vista. I am wondering if anyone out there has encountered the same issue and if there is a less drastic solution. Thanks!

All Replies
  • I have the same problem. I would like to find a solution.

  • Same problem. I've spent many hours with tec support on the phone and have never got any real help from them. After about two hours they want to change hardware or re install Windows. I've reinstalled Windows (made me lose Digital Cable Key that they could not tell me how to reinstall). Also changed my mother board twice and my turner twice. Changing my mother board made me lose my digital cable settings too, which they never told me. After five months got real help from Dell Community and had my turner working this Jan. And now this happened.

    In the network window the ATI Turners is now on analog channel format. I think this is why it is not working. I tryed to reinstall my Digital Cable Key put the computer just hung up. I'll keep looking for something.

  • I uninstalled McAfee and the Media Center worked. There was an update on about the time I lost it. I reinstalled McAfee and so far it is still working. (about 12 hours)

  • I have similar setup.  TV tuner inop after windows or mcafee update 2/12/09.  Called dell xps support and ended up doing a system restore and turning off windows update.  That worked OK until yesterday and same thing tuner not working and cannot find tv signal--it appeared to caused by McAfee update?  Was working great for 7-8 months--really frustrating--no one appears to have Digital tv tuner knowledge. Have been doing system restore to keep working.  Cannot find any info on dell, mcaffe or ati support pages.

  • I have just uninstalled McAfee, set up Media Center again, installed McAfee again with the auto update off til I can get help from McAfee.

  • I had the same problem.  XPS 420 with Vista 64 bit, SP1.  Everything working fine for months, then over the last couple of weeks I got the "Disk Error" notice on Media Center and I can't watch TV anymore.  I called Dell support and he suggested basically doing a Windows restore, which worked for a couple of days then it happened again.

    From this thread I figured it was McAfee.  I did a couple of things:

    1. I disabled the McAfee firewall, using only Windows firewall (and NAT router).
    2. In McAfee Security Center, Home > Manage Network, I said "trust this network."
    3. Reboot
    4. Watching Red Sox on my computer.

    McAfee still active with auto update.  Not sure if it was #1 or #2 that fixed it, but notice that Vista manages the TV tuner as a network device, which must make it (incorrectly) eligible for the McAfee network protections.

    Hope this helps your problem, I am also hooked on watching cable tv while working on my desktop.

  • Thank you for identifying the source of the error! :>) No thanks to Dell, McAfee or AMD :>(.

    I have XPS 420 with Vista 32 and am using analog cable input to the ATI but had the same symptoms you and the others reported. 

    Have you learned anything from McAfee about a longer term fix (than just disabling their firewall)?

  • I did the online chat with McAfee. He had change a few settings in McAfee. About three weeks now and still working.

  • Thanks for helping me solve a problem that was driving me nuts.  I was just about convinced that my tuner had bitten the dust.  I posted this issue on the McAfee support forum in hope that they will provide the settings necessary to make the fix permanent.  Here is a link to the thread:

    http://community.mcafee.com/showthread.php?p=559095#post559095

  • Another case of Cable Tuner not working on an XPS420, turning off McAfee firewall solved problem.  Please post on the McAfee thread so they will be motivated to come up with a solution.  The link to the forum is in a previous reply.  Thanks mee1467 for figuring this one out and sharing!

  • Great job mee1467! This has been driving me nuts for weeks. I was locked into the uninstall McAfee, have several good days, get a McAfee update and start the cycle again.

  • i have an XPS 420 and ati digital cable wonder tuner.  my cable stopped working some time back in february or march after having no issues since i got my computer last september.  i've gone through it all: contacted dell support, looked through forums, uninstalled windows updates, reverted back to system restore points, called my cable company, played around with mcafee security settings, etc, etc, all to no avail.

    i decided today to come back to the issue after letting it rest for about 2 months.  i had conceded to not watching tv on my computer any more.  i found this forum and revisited mcafee to see if disabling the firewall would work for me.  i took this one step further and wanted to share a solution to leave the mcafee firewall active:

    • open mcafee and click on the advanced menu
    • go to configure > internet & network and click on the advanced option for firewall protection
    • on the left hand menu, click 'networks'
    • add a new network, type the IP address of your device, ensure the IP address is checked to 'trusted', and then click ok
      • for the IP address.....go to startup, network, and then 'properties' of your tuner device to get the device's IP address
    • restart your computer.

    my cable works now, and the firewall is still up.  thanks for the posts and helping me figure this out!

  • After letting the same issue "lie" for a several months after my second bout of the problem (I was one who spent an hour will Dell earlier this year fixing it the first time), I checked the forum and found Italy00's solution.  So far . . . so good!  Thanks!