UP2715K, DUCCS 1.6.1 is not compatible - Monitors Forum - Peripherals - Dell Community

UP2715K, DUCCS 1.6.1 is not compatible

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

UP2715K, DUCCS 1.6.1 is not compatible

This question has been answered by DELL-Chris M

I downloaded and updated to latest version of Calibration software 1.6.1 and invariably got an error message when trying to calibrate with Xrite i1Display a Dell UP2715K.

While the Xrite software run the calibration w/o problem, this Dell specific showed this error message, I connected the i1Display to front and back PC USBs, and also to monitor USBs.

I have decided to remove it and download and install again BUT not update. I run 1.5.8.18202.

And it works!

The text in this earlier version though, is quite small and hard to read. I would thank the updated software finally runs on Dell UP2715K. Now it does not. Thanks

Verified Answer
All Replies
  • The version 1.6.0.2151 under "Compatible Systems" only list the Dell UP3218K. Also the header title states, "Dell UP3218K 31.5" 8K4K XRITE WINDOWS".

    The latest version for the UP2715K, 1.5.8 specifically list your monitor under "Compatible Systems".

  • Thanks for answering.

    Had I searched for an update of the software I could have seen the Compatible Systems list.

    But I got the update when I open the earlier version and a message stated there is an update for it.

    And I assumed, and maybe most users, that it is valid or compatible for several models, like e.g. video drivers. (It's just an adaptation of Xrite Profiler).

    Even more, the earlier version despite it uses an enlarged interface (I remember the one available in 2016 where you need to lower resolution or use a loupe) the text size is still minuscule! It's hard to believe it requires a lot of effort to mend or upgrade it for a high res. monitor display.