S2417DG, No signal on display port, solved - Monitors Forum - Peripherals - Dell Community

S2417DG, No signal on display port, solved

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

S2417DG, No signal on display port, solved

This question has suggested answer(s)

On my newly purchased Dell S2417DG, the display port does not work. When I switch to it, the monitor says "No signal" and then goes into sleep mode.

(The monitor works when connected via HDMI, but it is a high-Hz Gsync monitor and both features are only available when connected via DisplayPort, so running it via HDMI is completely pointless.)

I already tried the obvious (reboot, reset monitor to factory settings and then set the input to display part again, pull and check power cable, check display port cable on both ends).

Any suggestions on what more to try next?

If I can't get it to work soon, I'll have to return it, which would be a shame.

 

Here is the data which should be included in posts:

 

Monitor purchased: 13 october 2017 from amazon.de (So I can still return it)

Attached Computer: 64bit PC

Video Card: Nvidia Gefore GTX 970

Ports on the GFX card: 1x DP, 1x HDMI, 2x DVI

Connection GFX card to Monitor: DisplayPort on the Gefore 970 connected directly via the original DP cable that came with the Dell Monitor to the DisplayPort on the Monitor

O/S of Computer: Windows 7 Professional

Resolution in Windows: not applicable (Monitor does not work)

Factory reset: Done via HDMI cable. With the DP cable, the monitor does not work on the OSD only has one option: the input port (that can be switched between HDMI and DP).

All Replies
  • Using HDMI, do you have the ability to open the Nvidia Control Panel and see/disable G-SYNC? If you could, the S2417DG should operate at 60Hz when switching over to DP. Then if it comes up, enable G-SYNC and enable the S2417DG Overclock to set higher Hz.

  • Actually neither higher Hz nor gsync are enabled. It is not even possible to set them when running HDMI  and DP does not work.

    When using HDMI, the NVidia control panel simply hides the gsync menu, you cannot set anything in there. For the Hz dropdown, the only option available is 60Hz for me when running HDMI.

    (My old monitor also supported neither).

  • I could not ignore this and read everything I could find on the internet. The following may sound really strange, but: I found a blog post (see here) that suggest to:

    0) Connect both the HDMI and DP cables, then start Windows using HDMI mode

    1) switch to display port using the OSD (will give no signal message, followed by sleep mode and black screen)

    2) then remove the power cable from the monitor (switching the monitor off using the button will NOT do it)

    3) wait for at least one minute

    4) put the power cable back in

    And actually this works for me: the monitor comes back up with a signal from the display port and I can set higher Hz and activate gsync in the Nvidia control panel!

    This is really strange. Note that just unplugging the power and immediately plugging it back in does not help at all. You really have to wait for quite some time. When I read it, I thought it was internet voodoo that would never work, but there were dozens of comments underneath that post thanking the guy. So I tried it. And it worked.

    BUT: The problem is, that the effect does not persist. So when I start the computer the next time with the DP cable on, the screen reports no signal and goes black again. I have to get the HDMI cable, put it back in, start Windows, then put the DisplayPort cable in, switch to DisplayPort. Cut the power, wait 1 minute.There is no way I could do this every time I start the computer!

    So what could cause this issue?! And how can I fix it? Is it a problem of the monitor, the cable (doubt that), or the video card? Some combination of them (Nvidia Geforce GTX 970, as mentioned before)?

  • We know that the S2417DG is hardware capable of doing g-sync and the higher Hz settings. My guess is that your version of the GTX 970 does not really support them. Nvidia has stated that the video card must have a 586MHz or higher pixel clock. Once G-sync is enabled using your workaround,
    * Open the Nvidia Control Panel
    * Go to Display- Change Resolution- Customize- Create Custom Resolution
    * Look on the bottom right for the pixel clock for your video card

  • I checked what you suggested, and it says exactly 586MHz for my card.

    Anyways, I tried it with the graphics card of a friend (GTX 980), and it works with his card. So this was not related the monitor or cable. Maybe my card is weird.

    @Chris M: Thanks for your efforts and suggestions.

    This is solved and can be closed.

  • Return the monitor and buy it in the store, but first check.

    <no spam links allowed>

  • Hello.

    I think this is related to DisplayPort issues after soft boot I dedcribe at my post en.community.dell.com/.../20022537

    I believe if you set "Power Saving" to off from monitor osd, your problems will be avoided. Did you try it?

    Could you specify your monitor revision (last 3 chars in serial number) and manufacturing date?

  • The last 3 character of the S/N are 'A00', manufacture date is June 2017.

    I already read about power issues, so I recently tried turning "power saving" off. And currently the monitor IS WORKING and the effect is persistent with my GTX 970. I gotta say I'm not 100% sure that this is the only thing that made it work since I did lots of things (BIOS update, switch video card and then put my one back in, update drivers, ...), but it may be the case!

  • Glad to head it's working for you. If you're curious to know if that was it, you can follow the simple steps I describe in my last post in the other thread I mentioned.

  • Had similar issue. Updated the BIOS of my GPU (GTX 970), not the Nvidia driver. Seem to have resolved the issue for me.