S2418HN, Radeon MSI RX 480, how to set 75Hz? - Monitors Forum - Peripherals - Dell Community

S2418HN, Radeon MSI RX 480, how to set 75Hz?

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

S2418HN, Radeon MSI RX 480, how to set 75Hz?

This question is not answered

Hello!

Just received new S2418HN monitor. My goal is configure it to run in 1920x1080 75Hz mode with AMD Freesync enabled (for gaming purposes). 

According to user guide, it can perform in this mode. But i can not set 75Hz frequency in windows, cannot set it in AMD Crimson Drivers, cannot set it in monitor settings menu (frequency is not editable and grayed out). All i get is 59Hz, windows and AMD drivers shows 59Hz.

My GPU is MSI RX 480 Gaming X 8GB (latest drivers 17.9.3)

OS Windows 10 x64

Monitor drivers and DDM are installed and updated to latest version.

Monitor is connected via HDMI cable (which came with monitor). Ports on both sides are HDMI 2.0.

So the question is - how to switch to 75Hz?

All Replies
  • Hi Purple_Rain,

    Thanks for posting.

    You can see from the E2418HN User's Guide page 11 the factory set resolutions and refresh rates:

    Image

    It may be possible (but outside the monitor warranty) to use the laptop video control panel to choose a "custom" resolution/refresh rate. See this and this.

  • Hi Robert! Thanks for reply!

    After all I’v managed to get my new monitor work normally at 75 Hz with freesync.

    It turned out that my TV caused this mess. TV is connected in duplicate screen mode to my GPU. I think AMD drivers and Windows somehow did not let me go over 60Hz cause TV max support frequency is 60 Hz.

    I plugged of TV, plugged monitor into TV’s port, reset settings and voila – it allowed me to set 75Hz in Windows!

    After that there was pretty buggy story with plugging TV back to GPU and configuring it as secondary duplicate screen, but I’ve managed to solve this quest.

    Now Dell monitor works with freesync at 1920x1080 75Hz Full RGB and TV duplicates it with 1920x1080 60Hz Ybrr 4:4:4.

    So everything came to normal, problem solved)

  • Congratulations!  Glad you were able to resolve it!  Thanks for posting back your resolution, so that others can follow your example if they need to.

    Regards,
    Robert