Dell P2414H Monitor DisplayPort Not Displaying - Monitors Forum - Peripherals - Dell Community

Dell P2414H Monitor DisplayPort Not Displaying

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

Dell P2414H Monitor DisplayPort Not Displaying

This question is not answered

Hello,

I'm having issues setting up multiple displays. I have two Dell P2414H monitors at my workstation - one connected via VGA that works with no issues, and another connected with a DisplayPort cable. My setup worked fine without issues until an inter-office move, and now, after the move, the monitor connected via DisplayPort no longer recognizes my computer signal. It powers on without issue, but shows the "there is no signal coming from your computer" message. When I try to switch the input source from "Auto Select" to "DisplayPort", it says it's entering "Power Save mode", and shuts off. Please advise.

All Replies
  • Thank you for your message.



    This seems to be an issue with the ports on the computer, the monitor works fine as the self-test works.



    What is the model of the computer you have? Have you tried updating driver for the video card?



    Try to swap the monitor connections.  



    Check in device manager to see if there are any exclamation or driver errors.



    Check in the graphic control panel & change the display settings.

    Dell-Sreejith R
    Social Media Support
    Drivers & Downloads
    Dell instructional videos
    Alienware instructional videos