P2412H in "entering power save mode" loop

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

P2412H in "entering power save mode" loop

This question has suggested answer(s)

Hi,

I have a Latitude E6420, hooked up to a P2412H monitor via a port replicator and DVI cable.

Whenever the Windows 7 power management "turns the display off", the monitor enters into power saving mode. However, it gets stuck in a loop, alternately turning the backlight off, then displaying "entering power save mode". The monitor power LED stays blue the whole time, and any presses to the monitor buttons displays a message about no input signal.

If the Latitude is actually put to sleep or hibernation, the display goes into power save mode properly, without the loop.

Any ideas for how to make it work properly? Right now I have to physically hit the display power button every time I walk away from my computer.

All Replies
  • Hi tsanga,

    Welcome to the Dell Community

    I understand that when the Windows 7 power management turns off the display, the monitor shows the message “Entering power save mode” in a loop. I would request to try these steps.

    1. Click “Start”>> Type “Device Manager” in Search Programs and Files text box>> Go the Device Manager>> Locate the Port Replicator Device >>Right Click and select “Properties”. In the Properties dialog, look for “Power Management” tab >> there are two options: - Allow this computer to turn off this device to save power. Allow this device to wake the computer.  Please ensure both of the options are not selected.

    2. If this does not help, please connect the monitor to the VGA port on the laptop without the port replicator and then observe it for some time.

    Please try these steps and let me know of the outcome.

    Glad to be of assistance

    Thanks,

    Manpreet

    Dell |Social Outreach Professional | Global Social Media Community

    You can reach us at http://en.community.dell.com/

    Thanks and Regards,
    Manpreet C
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to http://dell.to/YBlak6
  • Hi,

    Thank you for the response.

    1. I cannot find a port replicator device in Device Manager. What should I be looking for? I'm using the Dell E-Port Replicator.

    2. I'm not sure what you mean by item 2. I'm making a connection to the monitor with DVI, not USB. I don't have a DVI port on the laptop.

  • Hi  tsanga,

    Thank you for the response.

    I would request to remove the  port replicator and connect the monitor to the VGA port on the laptop  or  use an HDMI  to DVI adapter  and connect the monitor to the DVI adapter port and then observe the  Sleep behavior.

    Please try these steps and let me know of the outcome.

    Glad to be of assistance

    Thanks,

    Manpreet

    Dell |Social Outreach Professional | Global Social Media Community

    You can reach us at http://en.community.dell.com/

    Thanks and Regards,
    Manpreet C
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to http://dell.to/YBlak6
  • I am having the exact same issue. I am using the monitor on a Macbook Pro with a DisplayPort to DVI adapter. I was using a E2311H before and everything was fine. I just received my P2412H and power save mode never worked since. Any ideas?

  • I have now tried using the VGA port on the monitor.

    When plugged into the Dell E-Port Replicator VGA port, the monitor resolution is incorrectly reported as 1600x1200 (max) or 1366x768 (recommended). The monitor's native resolution of 1920x1080 is not even available as a choice. Although now the display goes into standby properly when the display blanks, the resolution issue is totally unacceptable.

    I don't know if the issue lies with the port replicator or the monitor (both Dell devices), but this is total <profanity removed> from Dell. Neither DVI nor VGA offers a workable solution for enterprise class products.

  • @tsanga I'm using the monitor with DVI and to me the resolution works just fine. However, I agree with you that it's total <profanity removed> from Dell ;) Also, I found this video :

    According to it, we're mostly. I just received my monitor, last week, and I think I will send it back. However, I'm pretty sure the new one will do the same thing, and I will have to send it back also and whine to get a refund. All in all, it's surely going to be a waste of time, energy and money. From this video the issue should be known from Dell, I don't know why they still sell this model without a solution to this problem. Thanks Dell!

  • @JohnnyCage1

    Thanks for finding this video. That's exactly how mine behaves over DVI. At least you and the video-maker have an excuse - you're using Apple hardware. :p

    I, OTOH, am using a Dell Latitude, Dell E port replicator, and Dell monitor.

    At least I know which monitor NOT to buy for my Mac at home.

  • OK, I think I found a workaround. If I use the DisplayPort output on my port replicator, and connect to the P2412H monitor DVI input via a DisplayPort-DVI adapter, the monitor will go to sleep immediately when Windows blanks the display.

    Costing me an extra $10, but annoyance solved.

  • Please post a link to the adapter.

    (Liaison for Desktops, Alienware, Monitors)
    Drivers
    Order Status

  • Hi Chris,

    The adapter I bought is listed in this pdf: h20331.www2.hp.com/.../DisplayPort-component-version-information.pdf

    Specifically, it's the Bizlink DP->DVI, HP p/n 481409-001, Bizlink 09 11 Rev 01, listed in the table in the bottom right. It's sold as an HP branded cable.

    Thanks,

    Alan

  • Thanks!

    (Liaison for Desktops, Alienware, Monitors)
    Drivers
    Order Status

  • anyone found a real fix for this yet? I have the exact same issue as the macbook pro video except I'm running Win7Pro x64, Latitude e6520, e-port plus docking station and 2 x 2412H monitors connected over DVI.

  • It is annoying that they never resolved this issue. The P2412H is a solid monitor with a sweet stand, otherwise. I use mine with a MBP, but have several in place with Dell port replicators. Guess I need to check into those other units and see if they are having the looping issue.

  • I have a Dell E6410, Dell E-Port Replicator, and 2 Dell P2212H monitors running on Windows 8 x64.

    The monitor connected to VGA goes to sleep fine. The monitor connected to the DVI goes into the sleep mode loop.

    Intel HD graphic drivers that are installed are the most up to date from Dell. There are newer ones from Intel, but they wont install because I get an error of them "Not meeting the minimum requirement" I heard you can modify the inf file to install them, but not sure what to add to the inf.

    Not even sure if the new drivers would resolve. I was using an older Dell Dock and older Dell Pro monitors without problem. Not sure if its the new dock or the new monitors that are the problem. I've tried manually setting the DVI monitor input to DVI in the settings, installing drivers from Dell for the monitors. No Luck. I gave up and ordered the adapter off eBay for the display port to DVI.

     

     

  • I have a Dell E6530 connected to a dual DVI E-Port replicator.  Both monitors are the P2412H and are connected via DVI cables.  One monitor goes into power save mode correctly, while the other one stays in the "loop"  It would be interesting to know what the fix is.