U2410 USB storage device/volume *always* present (even when no media card inserted)

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

U2410 USB storage device/volume *always* present (even when no media card inserted)

This question is not answered

Hello folks,

When my U2410 is connected to any one of my Windows XP computers via USB, I see:

a) A safely remove hardware tooltray icon

b) A removable disk volume listed under My Computer, which when accessed prompts "Please insert a disk"

c) Other signs of the system seeing a USB storage device connected.

This appears related to the media card reader and Ultra HS-SD/MMC USB Device.  What takes me by surprise is that I see this when there is NO media card inserted.  I don't use such cards and I haven't yet purchased one for testing.

Other U2410 owners... do you see similar signs of a USB storage device being present even when there is NO media card inserted?

Thanks

All Replies
  • That is all normal. The OS has to be prepared for when/if you were to insert a card.

    (Liaison for Desktops, Alienware, Monitors)
    Would you like to be a Dell Community Rockstar?

  • Hello Chris M

    Thanks for the reply, I feel a little better about seeing this although I am curious about something.

    Is this behavior specific to the U2410 or Dell media card reader equipped monitors?  The reason I ask is two-fold: 1) I don't recall running into this when using an older, non-Dell monitor that was equipped with USB ports and a media card reader, 2) USB devices can be hot-swapped and as seen with a USB flash drive the storage device can be "visible" only when the storage device and media is actually connected.

    My thought is that an internal USB media card reader can mimic USB insertion/removal (switchable pullup resistor?) when a media card is inserted/removed and that may be why the one monitor I used didn't report a USB storage device when no media card was inserted.  My other thought is that in order to simplify design such behavior is dispensed with in some (many?) internal USB media card reader designs and that is why the U2410 (and other Dell monitors?) exhibits the behavior.  Have any experience and/or thoughts on to share on that?

    FWIW, disabling the U2410 media card reader's associated USB storage device in Device Manager has eliminated the "ghost Windows volume" and more importantly to me it prevents an empty media card reader from triggering a safely remove hardware tooltray icon.  That icon is my reminder that I accidentally left a storage device connected and need to grab it before I leave :)