P190S USB Plug-n-Play Error

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

P190S USB Plug-n-Play Error

This question is not answered

Whenever we connect a P190S to one of our Windows 7 Enterprise 32 bit computers (desktop or notebook, tried different cables, monitors, etc.) the plug and play process for the USB connection fails and indicates "Device Driver software not successfully installed - Unidentified device/Device unplugged."  The USB ports work on the monitor in spite of this error and there is nothing listed in device manager.  I have installed the P190s Windows Update item that appears after it is connected but cannot figure out how to correct this issue. Is there some kind of patch or manual driver install that can be done?

All Replies
  • This appears to be an issue within the OS as Win7 will not install ANY device that includes any kind of USB Hub, so the issue is not specific to the P190S. Mods feel free to move as needed to more appropriate category.

  • We are having the same problem. Where I work we ordered over 50 laptops along with an external P190S for each laptop. Since September, we have experienced this same issue with the monitors. However,  I think the issue is with the monitor. We have had Dell replace a few of the monitors under warranty and then the error goes away.

    I don't think the OS is the issue because 75% of our laptops are working fine, and other types of devices with internal hubs work fine... i.e keyboards.

    Latitude e6410

    Win7 Ultimate x32

    Have also tried updating all drivers. As well as uninstalling/reinstalling all USB hub drivers.