Alienware AW2310, 3-day old and half screen problems

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

Alienware AW2310, 3-day old and half screen problems

This question is not answered

G'day to you all. I was excited to receive this Alienware monitor a few days ago from Dell online store. I hooked it up with my Xbox 360 and PS3, played a few games and watched a few movies using HDMI cable at first and then switched to DVI cable with DVI-to-HDMI adapter. The first 2 days were fantastic. The third day, when turning the monitor on, half of the screen has gone bad, there are lines jumping and bad colors in the right half, while the other half is perfectly ok. I've tried the built-in diagnostic function and reset to factory settings, turning on and off a few times, disconnecting all video cables, but the problem persists. I have not connected the monitor to my PC (Alienware M17x-R2) yet since I don't have nVidia cards to use 3D Vision. Could someone please help? Here are some photos of the problem

 

All Replies
  • If you have retested both HDMI and DVI and still no go, get it replaced. If you only have a monitor order number, you should contact Order Support. If your monitor was purchased tied to a Dell PC, contact Technical Support. They will need the following data -
    Email Address:
    Name:
    Shipping Address:
    Phone Number:
    Monitor Order number or PC Service Tag number:
    Monitor 20 digit PPID number:
    Reason: Monitor fails the STFC (Self Test Feature Check)
    Troubleshooting Done:
    Post a picture of the issue here and provide the link:
    http://imageshack.us/

    (Liaison for Desktops, Alienware, Monitors)
    Drivers
    Order Status