Dell 2709w and U2711 Odyssey

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

Dell 2709w and U2711 Odyssey

This question is not answered

I'm simply writing this post to express my current frustration.

1. Monitor:

I bought a Dell 2709 in April 2009. After 3 weeks there were several colored line of pixel from top to bottom. So I got it replaced. The Replacement was no Problem so I got a new Monitor.

2. Monitor:

The replaced wDell2709w was the best Monitor so far. It lasted over a year. This September it started to flicker on all setting. There was no way to get it to stop. So I called the Support. The service Tag of the Monitor could not be found but with use of the order number of the first one I was able to get a replacement.

3. Monitor:

The Monitor got replaced on Sep. 24 2010. So last Friday I got a new 2709w. After installing it I saw 4 bright pixel errors on the screen, 2 in the middle of the Screen (3 cm away from each other) and 1 at each side. Since it is a premium panel I got it replace again.

4. Monitor:

So after replacing the above Monitor it was replaced again. By now I think Dell support must hate me and think I’m a jerk because of all the replacements. On Tuesday 28.09.2010 I got a new Monitor. It is a U2711. In the beginning I could not get it to work properly. After I found out that I need a Dvi-D dual link cable I was able to use the native resolution without problem. Everything seemed fine but know there is a problem again. The right side of the screen starts flicker to the left side. This means that for about 1 second the right side of the screens is located 2 cm more on the left side than before. Seems like a pretty strange problem but it makes working with the Monitor impossible. I’m sure it is a fault of the monitor since this can be seen even if only the power cord is used and no devices are plugged in. Then the small box which states that there is no connection to the device will show the same problem as soon as it is on the right side of the screen. From a lot of videos of the u2711 it seems like the IPS panel consist of a right and a left part since there are a lot of videos showing a red or yellow right of left monitor part whereas the other side looks fine. So this morning I will call customer support again.

This will be my 5th Monitor. Considering my luck so far the odds are that it will not work properly too. So is there any advice you can give me. All I want is a perfect functioning DISPLAY since I need it for work. I would not care if the USB ports at the side or the sound would not work since I don’t use them. But is it too much to ask for a perfectly usable Display? On my Laptop there is also a pixel error, but it is only one so I can live with it without a problem. I really don’t know what to do anymore since nothing seems to be working.

Ps: I’m living in Germany

All Replies