sp2008WFP shows no picture with HDMI to DVI cable

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

sp2008WFP shows no picture with HDMI to DVI cable

This question is not answered

My old computer, which had a VGA-out, went kaput. As my monitor only supports VGA or DVI in, I decided that a HDMI to DVI cable was the best option to connect my new computer to the monitor, as my new computer offers HDMI out but no DVI or VGA ports.

Unfortunately, my monitor won't recognize the signal from my computer. The computer has no trouble seeing the monitor-- it registered it as the correct monitor type once I installed the driver, and I can change all of its settings in both Window's Display Properties and the ATI Catalyst control center. The mouse also falls off screen as though switching to the other monitor. However, the monitor itself will either attempt to auto-detect and switch into its red-green-blue color test screensaver or, if I switch it to digital input, it will immediately fall into power save mode.

Here's what I've tried:

  • Changing the monitor's resolution. No dice.
  • Downloading the latest driver: the one on the Dell website, dated 9/18/07 claims to be 32 bit vista compatible. I downloaded it, and the computer promptly changed the monitor's name from a PnP device to sp2008 wfp, but still no picture.
  • Restarting monitor/PC. No go.

Help?

 

All Replies
  • CaptainCarrot,

    Since your using a HDMI to DVI cable, the monitor must be set to DVI. Then, reboot the PC into safemode. Does the windows desktop appear?

    (Liaison for Desktops, Alienware, Monitors)
    Drivers
    Order Status

  • If you mean, "does the desktop appear on the external monitor in safe mode," then no. It appears just fine on my main monitor, but I don't believe windows detects the external monitor in safe mode anyway since it doesn't load the driver for my ATI graphics card in that mode.

    The monitor is already set for DVI input. Actually, this monitor only comes with 3 options: Auto-Detect, Analog and Digital inputs. Auto detect on the monitor itself keeps switching to analog despite DVI being what's connected. Manually setting it to Digital Input (what I have now) just makes the monitor switch into power save mode.

  • * Turn off the monitor
    * Unplug the monitor from the computer (ALL cables)
    * Plug the monitor power cord directly into the wall socket
    * Turn on the monitor
    * The floating red/green/blue/white dialog box should appear on screen against a black background. If you see this, the monitor is good and the issue is with either the video card cable, the video card driver or the video card itself

    (Liaison for Desktops, Alienware, Monitors)
    Drivers
    Order Status

  • Solved it! The problem was with my video card; more accurately, ATI cards apparently ship with a service called ATI External Event Utility that was somehow keeping the picture from getting from my PC to the monitor. It's not an essential service, and once I disabled it in the Window's services panel, the monitor instantly came to life. It's all good now.

    Thanks!