A920 won"t scan or copy - Printers Forum - Peripherals - Dell Community

A920 won"t scan or copy


Dell Monitors, Printers, Projectors, Hardware and Software discussion

A920 won"t scan or copy

  • I purchased a Dell A920 in August. The machine printed great, but refused to scan or copy. All connections were checked, and a couple of fruitless hours were spent on the phone with the Dell 'techies', who finally recommended a replacement. I received the new A920, and dutifully returned the old one. Guess what? The replacement performed in the same manner, printed great, no scan or copy. In frustation I let the problem lie dormant for two months, hoping for Devine inspiration as to a problem solution. Evidently my faith was not strong enough. So, in desperation, I phoned technical assistance again. Their brilliant solution was to replace the replacement, so I now have my 3rd A920, which prints great, but will not scan or copy. Does anyone out there have a suggested solution?
  • You could help us out by telling us what operating system you're running, and what happens when you TRY to scan or copy.  Does absolutely nothing happen?  Do you get an error message of some kind?  If you do, what does it say?  Does the machine hum and seem to try to scan, but you don't get any file on your system containing the scan?  Are there any problems in your devices when you go to Control Panel/System/Hardware/Device Manager?  Did you go through the installation of the All in One Center (the software that runs the printer and scanner)?  Did everything seem to go okay during the installation?  Have you tried uninstalling the All in One Center, rebooting, and reinstalling it?  (Given that three different printers have "failed" on you, and they can't ALL be defective, it's clearly a software problem).

    If nothing above rings a bell, try this:

    1)  Undo everything you've done so far by (in this order): (a) go into Start/Printers and delete the printer.  Say "yes" if it asks you whether you want to delete the files, too.  Then (b)  go into Start/Settings/Control Panel/Add/Remove Programs and remove "Dell AIO Printer A920".  Do BOTH (a) and (b).

    2)  Unplug the printer's USB port connection to the computer.

    3)  Turn the printer off.  Turn the computer OFF

    4) While the computer is OFF, reconnect the USB port connector to the computer. and turn the printer ON.

    5) Turn the computer ON

    6) Insert the CDROM I mentioned above

    7) Follow the instructions on the screen

    All of this will comprehensively uninstall and reinstall the software associated with the printer; it'll probably work.

    If not, let us know, providing more details about your symptoms, and then maybe someone will be better able to help you!

    (Incidentally, if the All in One software is not running, then the scan and copy buttons on the printer are disabled...)



    Message Edited by akahan on 12-07-2003 10:28 AM

  • To akahan:

    Operating system is Windows XP on a Dell Inspiron 5100.

    When I try to scan or copy, absolutely nothing happens, no noise, no lights, nothing.

    Error message is 'Scan was not successful'

    Going into Device Manager/Imaging Devices/Dell AIO Printer A920, it shows: 'The device is working properly'

    The All In One software was uninstalled and then installed again with each of the A920 replacements.

    I shall pour myself a stiff drink and try the rest of the suggestions, and let you know

  • To akahan

    I have tried all of your suggestions, with no change in the non-performance of the A920.

    Under Device Manager, I have

    Imaging devices - Dell AIO Printer A920

    Universal Serial Bus Controllers - There are 7 items,

         with "USB Root Hub" 3 times

                 "Generic USB Hub" 1 time,and  3 others

    Is this a problem?

    Should I reload Windows XP?

    I switch between two different printers, depending on where I am, the Dell AIO A920,

    and a HP Officejet. Is this a problem source?

    I have run out of things to try.

    Guy Allen

  • The multiple appearances of USB root hub and other entries in the USB section sounds like a problem to me.  It suggests that your print/fax software is confused by the multiple entries, and may be looking for the scanner in the wrong place.

    I would suggest not reinstalling XP (that's pretty extreme), but merely deleting ALL the entries in device manager for the USB devices, and then reboot, and let the system rediscover them.  Hopefully, it'll only rediscover one of each.

    Good luck.



  • To akahan

    Re: The next episode in the scanner/copier that won't scan/copy.

    I deleted all the entries in the device manager for the USB devices, and uninstalled the printer. I then rebooted with the AIO920 hooked to the computer. It loaded a few files and then I got an error message

    "Microsoft Visual C++ Runtime Library

    Runtime Error

    Program: C:\Windows\System32\spool\DRIVERS\W32X86\3\DLBKPSWX.EXE

    abnormal program termination"

    So I clicked OK, and nothing more happened

    When I tried to go to the Dell AIO center, I got another error message

    'Program: C;\Program Files\Dell AIO Printer A920\dlbkaiox.exe'

    abnormal program termination'

    Any ideas on where I go from here.

    Guy Allen

  • I'm thinking that what you would want to do is, again, uninstall the printer, and delete the USB devices.

    Then reboot WITHOUT the printer attached.  Let the machine reinstlal the USB controllers, etc., without being confused by havng a printer hooked up to these not-yet-installed USB ports.

    Then, after the USB ports seem to be installed and ok, you'd attach the printer and install its software.

    If that doesn't work, I'm out of ideas.


  • It doesn't work.

    I'm using it strictly as a printer until I reinstall Windows XP

    Thanks for trying

    Guy Allen

  • I have the same problem with my A920.  Prints but no scan or copy.  Exact same symptoms that you are having.  Dell's software for this thing needs some work i guess.