Dell 1250c Sleep Problem - Printers Forum - Peripherals - Dell Community

Dell 1250c Sleep Problem


Dell Monitors, Printers, Projectors, Hardware and Software discussion

Dell 1250c Sleep Problem

This question has been answered by ronnieh1


I have a problem with my printer where I cannot print to it once it has gone to sleep mode (amber light).

To print I need to turn the printer off then on. Is there anything I can do to fix this? The power management settings have only 1-6 for deep sleep, and 5-60 for sleep.


Verified Answer
  • I downloaded and installed a Firmware Update from that fixed this problem.

    The printer now wakes itself up when needed - even from my Mac - after installing the update.

All Replies
  • I have the same problem - no response after sleep starts.

    On my Mac, I can't even find the Status Monitor to extend the sleep time. However, extending the time would just delay the problem.

    There must be a way to wake the thing up other than powering down and then back up!

  • By trial-and-error, I found that pressing the CANCEL button will wake the printer up.

  • I've tried that, didn't work for me.

    Is there a way to disable the feature? as even if the cancel button did work it would mean having to press it to print something.

  • I downloaded and installed a Firmware Update from that fixed this problem.

    The printer now wakes itself up when needed - even from my Mac - after installing the update.

  • Is the firmware version 0.49? I have that version installed but it won't wake up.

    I forgot to mention that I was trying to wake up using a PS310U usb sharing device which wasn't waking the printer.

    I've now tried connecting it directly to a Dell/Win 7 PC and it's still not waking up.

  • I installed firmware update 0.49 - the latest from the Dell website.

    My 1250c was purchased from Dell in January 2012 and did NOT ship with the firmware update installed. Nor was there any hint of an update in the package. I used the live chat to confirm that the printer was compatible with Mac OS-X before purchasing it.

    After the firmware update, Apple OS-X, Windows XP and the top buttons wake the printer from sleep.

    If your printer won't wake up from its Start or Cancel hardware buttons, it has more serious problems than firmware or drivers. I'd suggest a live chat with Dell support.

  • I changed to settings to Sleep: 5 mins, deep sleep 1 min and it now wakes when I press any button or try to print to it.

    At least I know that's what it should do, so if it doesn't wake again I can get a replacement.

    Thanks for your help Ronnieh1.

  • This post is a little old, but in case the OP or anyone else with a 1250 is having these issues I do have a few suggestions.  It is the only post that comes up regarding the 1250 sleep issue so rather than divide attention I will just attract Google searches to here.  If this post helps even a single person it will be worth the effort.

    We use a number of Dell 1250's at my workplace many of which are deployed remotely.  Many of them have this same deep sleep issue that is described above.  If you call Dell Tier 1 Technical Support they will tell you that this is a design feature (going to sleep might be, but being unable to wake-up is clearly not).  It took about 7 phone calls and several hours, but I eventually transferred to someone from the Dell Imaging Life Support Team and from there was given a couple of possibilities for less obvious solutions.  The first solution did not apply at all in our case, but I am posting everything for the sake of completion in the hopes it may assist someone with a slightly different configuration.

    Solution 1 for Networked 1250's.

    Check to see if SNMP Status is Enabled

    Printer Properties->Ports Tab->Configure Port->Uncheck SNMP Status Enabled

    Solution 2 for all 1250's.

    Go into Device Manager on the system that one of these printers are USB connected to and open up the USB controllers.

    Then right click on a USB root hub and select properties. Under Power Management, make sure “Allow the computer to turn off this device to save power” is UNCHECKED. You can also check “Allow this device to bring the computer out of standby” if you want to. This either needs to be done to ALL USB Root Hubs, or, look for a power tab ,and that should give information regarding if something is connected to that Root Hub.

    Please post if any of these things help.  Short of disconnecting the power nothing else has worked for us so far.  Firmware updates, power button, sending jobs to the printer, etc.  I was also told another "solution" would simply be to send a blank print job every hour before the printer goes into hibernate, but I am not going to suggest anyone actually do that unless they feel it is their best solution.

    I will followup when I have some results.  Good luck folks.

  • An update on my post from 09/02/2012, the printer is still going to deep sleep and can only be used by power cycling. Dell sent me a new replacement printer which does the same thing.

    Spectear - My printer is connected to a TP-LINK TL-PS310U printer server, with a Dymo Labelwriter 450. I've tried the two solutions you listed, but for the port I get a message saying it cannot be configured at this time. I'll try leaving it connected directly to a PC and see if that makes a difference.

  • My two 1250c's are configured as you suggested and will not wake from deep sleep. I've given up. Both are usually connected to Macs, and despite Dell's claims, settings and firmware updates are impossible. I occasionally connect to a PC for any adjustments or updates, but it's futile in the end.
  • Unfortunately, those were the only suggestions I was given.  They do not work for me either, I was just hoping someone else might get lucky.  We have gone ahead and switched to Samsung 325's instead.

    For the record our printers are usually connected to Acer netbooks and no amount of firmware or settings changes have helped at all.  The only thing we can do is power cycle the printer.

    Sorry guys, best of luck to you in the future.

  • I have just purchased one of these printers.

    First impressions were very good, a cracking little colour laser printer.

    But then I hit this sleep fault.

    I use my printer via a Belkin WiFi print server and once the printer goes in to sleep mode it will NOT wake up. Stupid firmware has no option to turn the sleep function off either.

    The previous Samsung laser worked perfectly on this setup as does the Brother inkjet.

    Dell, please fix the firmware!

    If you can't fix it give us an option to disable the sleep function.

  • Ok - I had eaxactly the same on my Dell 1250c Printer with sleep mode.

    I have just  contacted DELL technical support and they loaded F/W V 0.62.0 to the printer via remote connect to my laptop and it appears to cure the problem.

    Need to check it further but it looks as if it is fixed by v0.62.0 firmware.Big Smile

  • Is there a link to this firmware update somewhere?  The last time I contacted them they had no solution, and this was fairly recently.

  • I installed this v62 firmware a few weeks ago.

    It does allow the printer to 'wake up' when the Start button is pressed.

    However it doesn't solve my WiFi printing prolems because it still does not wake up via my WiFi print server. 

    I have to walk to the printer and press the button, which makes a mockery of wireless printing. Even then I also have to unplug the USB cable to wake up the port.

    The only solution for remote printing is to give us the option to turn off sleep mode totally. I suspect it's the Deep Sleep that causes the problem but without the option of disabling either/or/both I'm no better off.

    Come on Dell. Give us the option!