Dell All In One 944 Printer & Vista.

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

Dell All In One 944 Printer & Vista.

  • Whenever i try to print a image it says can not communicate with Printer. I checked the available drivers and downloaded the one available with Vista but i still recieve the error message. Can anyone help me?
     
    Also while i'm here i have Roxio DLA installed and Windows is reporting Sonic DLA has a Driver not supported. I tried unistalling all of the Roxio's it prepares then for uninstallation but hen just stops and does not uninstall.


    Message Edited by DanieL_Hatcher on 02-02-2007 02:48 PM
  • I am having the same issues with my 944. It's frustrating and you don't realize just how much you miss it. I hope that someone fixes this one soon.
  • Another attempt to making this work. I have tried all of the suggestions and none of them work as of yet. If I can figure this out I will and will post the work around since I guess that Dell does not monitor these boards in order to assist themselves in customer satisfaction.
  • Yeah. That would be helpful Thank you!
  • Actually I am the Liaison of this board and I do read all the messages; however, this is a user to user forum.
     
    Now you both said you tried all the steps. That does not help in trying to figure out what is going on. It would be helpful if you describe what all these steps are so that we don't have you repeat steps. One thing you should do is uninstall the previous software for the printer before loading the upgrade. Then unplug the printer, execute the upgrade and only plug in the printer when asked. Please try this and if it still does not work let us know.

  • Gina, I know that it is user 2 user and I was venting. Here is the deal, once you load the patch for Vista 32 bit and you try to print it shows a communications error, AIO does not recognize that a priter is attached and says to do the following. 1. make sure the power is on 2. check the USB cable, Three restart the computer, and 4. uplug the power source of the printer and then power back up the printer. After trying this several times, and installing and reinstalling the drivers the same situation comes back up.  Now AIO will scan from the 944 but it will not print. I hope this helps.
  • The same for me....


  • tczar119 wrote:
    1. make sure the power is on 2. check the USB cable, Three restart the computer, and 4. uplug the power source of the printer and then power back up the printer. After trying this several times, and installing and reinstalling the drivers the same situation comes back up.  Now AIO will scan from the 944 but it will not print. I hope this helps.


    You say above that you unplugged the printer power and checked the USB cable restarted the computer, plugged in the printer. You should not have the printer plugged in via USB when installing the driver.
    Can you please try the installation this way? Then let me know what happens. We'll get this figured out together. 
    1. Make sure all previous versions of the software are uninstall from Add/Remove programs.
    2. Unplug the USB cable that goes form the printer to the computer from the computer
    3. Install the driver.
    4. Plug in the printer when asked by the driver.

  • As soon as you do that then click install it tells you to plug the USB connection in. Then windows tries to find the driver installs some then stops then the program installs it. So you can't install the Drivers then plug in the USB connector.
  • Hummm.
     
    Thanks for replying so quickly. Okay try this.
    1. Go to Start > Run and type MSconfig
    2. Then go to the startup tab and click disable all (be sure you're not connected to the internet)
    3. When you click apply then close the system will ask you to reboot. You will get a window telling you that you've used the system configuration utility Put a check in the box and click okay.
    4. Now try to install the driver again and let me know.

  • ditto, I just retried it your way Gina, and I am still in the same boat. and it says I failed to load the drivers for the 944 in the new little driver icon in the task tray
  • Okay thanks for trying. I'll escalate this and see what we can find out.
     
    Oh, and by the way go back to the msconfig and change it back to a normal startup. There will be an options that says normal. Make sure the dot is next to this and click apply and okay, then reboot.


    Message Edited by DELL-Gina on 02-05-2007 01:41 PM

  • Having both problems with Photo 944 and Sonic DLA. Have tried every solution offered but still have a comatose printer and relentless message about Sonic's desire to update but with nothing ready.
     
    Help screens even offer to print their wisdom.
     
    Waiting for your wisdom while I am approaching a truly paperless society.
     
  • I am having exactly the same issue.  I've been talking to technical support in India who are being most unhelpful.  They keep asking me to make basic tests and reinstall etc.  I am an IT engineer myself so I am finding this frustrating.
    I thought that this might be caused by the Windows firewall blocking communication so I turned this off.  Same problem.
    I would mention that I have a Freecom DVB-T Usb stick.  This also installs correctly but the media centre can't see it and I am wondering if there may be a problem with communication through the USB ports.  The scanner of the printer can communicate through the USB port as can a Canon scanner and my digital camera.
    The lack of a TV tuner isn't major but the lack of a printer is.
    This upgrade to Vista is causing me grief.
  • So let's give this a shot to get the previous printers removed:
    1. Click Start, click Control Panel.
      The Control Panel window appears.
    2. In the left-hand pane of Control Panel click Classic View.
    3. Double-click Printers.
    4. Right click the desired printer and choose Uninstall.
      The Confirm Device Uninstall window appears.
    5. Check the box next to Delete the driver software for this device.
    6. Click OK to confirm removal of the device.
    7. Reboot
    8. Reinstall the printer using the printer driver for Vista