1320c printer networking problems - Printers Forum - Peripherals - Dell Community

1320c printer networking problems


Dell Monitors, Printers, Projectors, Hardware and Software discussion

1320c printer networking problems

This question is not answered

Help!!  I have a the following set up - ADSL modem connected to belkin wireless router with laptops connected wirelessly and desktop pc and 1320c printer connected by cables.  Printer has network upgrade thingy.  After some initial confusion at setup some months ago, everything was working fine with only occasional problems printing from the laptop seemingly after installing suggested updates.  Laptop would have documents in the print queue, would get to 64MB and stall, nothing would print, managed to fix those problems by deleting and reinstalling printer from the original CD it came with.  My current problem is with the desktop pc, it was doing a similar thing as described with the laptop but the documents stayed in the  queue and would only print when I re booted the pc but they would stay in the queue and print again if I rebooted.  Sent email to dell tech support more than a week ago but have had no direct contact from them with any suggestions.  Now after trying various things it remains unresolved and in fact worse - now wont print anything from the destop at all.  Still prints from the laptop, if I put the printers IP address in the desktop browser in shows up OK.  At one stage when I was rebooting the desktop, there was an error about the spooler and I have since run cleanspl.exe and reinstalled the printer but get  "Printer Installation operation failed" error messages even though the printer is showing in "Printers & Faxes".  Am going to try a system restore now if I can find one dated before the problems, with me luck.

All Replies
  • I've found that one of the best ways to resolve these seemingly "this makes no sense" problems is to assign your printers to a static IP address OUTside the default DHCP address assignment range of your router.

    Assuming you have a LinkSys WRT54G router (or equiv), it usually has the default DHCP range to assign IP addresses from through, or, an address range of 50 addresses to assign. However, the entire range of addresses available in this subnet is 253 addresses [ through .254 (.1 & .255 are reserved)]. (see note)

    I would recommend

    • uninstalling all the printer drivers from each of the computers
    • access the printer's web page and set the IP address to something above router assignment range. I might suggest The subnet mask and default gateway should be OK as is.
    • restart the printer and print a Printer Settings page to verify the address change.
    • Re-install the 1320c drivers on each of the computers that will use this printer.

    Good luck and let me know if you need more help.

    Note: I used the Linksys and these addresses as they are the most popular Out of Box settings. The base address and the address assignment range will vary between manufacturers

    "the Llynster"

    • CompTIA PDI+ Certified
    • all dell shop
    • internet connected via WildBlue satellite
  • Hey thanks for your reply to my printer problem, sorry to take so long to reply.  I manged to get things working using restore, then got distracted with Christmas etc.  The same problem reared its ugly head again about a week ago so I was having another read of your suggestion  but wasn't exactly sure how to go about it.  Didn't want to uninstall the printer drivers from all of the computers then find I couldn't change the IP address as suggested so I accessed the printer's web page first to see where to make the changes.  It looks like a password would be needed to change the IP address of the printer and I don't remember ever setting one so have come to a bit of a stand still with that.   Can't access the printer settings from the Tool Box as discribed in the manual. 

  • Yep, has been awhile.....

    The Username on the 1320c is: admin

    The Password should be: (blank)

    If that Password does not work, try: password

    "the Llynster"

    • CompTIA PDI+ Certified
    • all dell shop
    • internet connected via WildBlue satellite
  • Thanks for that.  I am now having problems removing the Dell Printer Software.   When I tried to remove it it seemed to get so far then stopped responding.  I reintalled it anyway but was no different to before so I tried to remove it and start again but Add/Remove Programs says "Another instance of this setup is already running.  Please wait for the other instance to finish and then try again."  Reboot didn't seem to help, still comes up with the same error but it sounds like the computer is busy doing something.   Windows Task Manager doesn't show anything else running but CPU Usage is around 50% when it is normally below 10% when not doing anything.  Is there another way to remove Dell Printer Software so that I can re-install it and try again?  Will try to reboot again and see what happenss.

  • Finally managed to uninstall printer drivers, changed IP address to (because I have a belkin router) etc, re-installed 1320c drivers from original CD but no different.  Could still print from laptop but not from desktop PC.

  • Sorry for the delay in getting back with you.

    Is it possible you can draw me a little diagram of your network layout?

    Were you able to access the printer's web page? (a.k.a., the EWS)

    You indicate you set the IP to ~.2.254. I assume this was for the printer?

    From your PC, can you PING the printer from the desktop PC?

    Are you running XP or Vista on the Desktop? Any firewall issues?

    "the Llynster"

    • CompTIA PDI+ Certified
    • all dell shop
    • internet connected via WildBlue satellite
  • Good to hear from you.  I put the IP address back to where I started.  So this is what I have: Home Office

    Phone line - ADSL Modem - Belkin Wireless G Router( - 

    • Master (Dimension 8400 Desktop PC running WindowsXP Professional)
    • Laptop1(Inspiron6400 running WindowsXP Media Centre Edition)
    • Abbies Laptop(Inspiron6400 running WindowsXP Home)daughters laptop only connected occasionally when home
    • 1320cn Colour Laser Printer

    The Modem is connected to the router with an ethernet cable.  Printer and desktop are also connected to the router by cable but the laptops are wireless. 

    Don't know what EWS means but if I type address in internet explorer I get the printers web page.

    Yes the 2.254 was for the printer but I have changed it back now.

    Not sure about the ping thing, I opened a command prompt and typed ping and it seemed OK.

    I tried restore yesterday but it doesn't go back far enough to when there wasn't a problem so I seem to be stuck.


  • Me again. May be getting somewhere.  I uninstalled Dell Printer from Master PC, rebooted everything, turned off Trend Micro Firewall (Windows Firewall was already off, as recommended in the printer manual) reinstalled Dell Printer, test page printed but when firewall turned back on same problem as before.  Not sure which firewall settings needed tweeking but seem to have achieved sucess by unblocking Spooler SubsSystem App.

  • You're getting close.... In fact, you did resolve the issue, but it came back when you re-enabled the Firewall.

    Sounds like you need to setup an exception in your firewall for the Spooler App.

    btw..... EWS means Embedded Web Server. This is the web page that opens when you enter the IP address of the printer into your browser URL line.

    Since the printer is now at IP address ~2.4, open a CMD screen and type "PING". You should get 4 replies.

    "the Llynster"

    • CompTIA PDI+ Certified
    • all dell shop
    • internet connected via WildBlue satellite
  • Llynster, you are a genius.  I was having problems with my printer "disappearing" on my ethernet network and your recommendation worked perfectly.  Up until that point, I loved the printer, but was getting tired of reinstalling the drivers every couple of days (probably when the network reset for various reasons and reallocated the I.P. address for the printer).  Thank you very much!

  • I have a similar problem with my 1320c printer.

    Must be missing something though...I can navigate and access the printers EWS page, but there appears to be no way to change the IP address!

    How can I do this?

  • This document explains how to reset a Dell 1320C Printer’s Manual IP Address after swapping out router and changing to new network segment.

    NOTE: The following sections are considered advanced functions and should only be carried out by a system administrator. These sections assume you have already installed the Dell Color Laser Software on your PC.


    1. 1.      Connect a network cable your PC and the printer. 
      1. a.      On your PC open up your Network Adapter Settings and configure the IP Address on the NIC that is connecting directly to the printer to be on the same subnet as the printer.  In this example I am using as the subnet.

                                                        i.     I set my PC to with the default subnet mask of

                                                       ii.     Next I pinged the old IP Address of my Dell printer, to make sure I could communicate with the printer.

                                                      iii.     Open up a browser and go to http://(Current IP Address of your Printer) in this example  

    1. 2.      Once the Main printer page appears select ‘Print Server Settings’ on the left hand side of the webpage.

    1. 3.       Next select the ‘Print Server Settings’ tab on Print Server Setup Page

    1. 4.      Select the ‘TCP/IP’ option from the subsequent page.

    1. 5.      Enter the correct IP Address, Subnet Mask and Default Gateway for the network segment now used by the printer.  In this example it is subnet with a default Subnet Mask of and Gateway of

    1. a.      After you enter the correct information for the new IP Address you must Apply and restart your printer for the new values to take effect.

    1. b.      You will be asked to enter authentication credentials to apply the changes.  Enter the correct credentials to authorize the change then click on Log In to authorize the change.

    1. c.      The Printer will now apply the changes and restart.  If you inadvertently selected apply changes only you will see a screen similar to the one below.  If this occurs just restart the printer after the changes have been applied.

    1. 6.      Once the printer reboots attempt to ping the printer on its old IP Address.  If you get a response you need to perform the steps above correctly.
      1. a.      If you get no response, reconfigure the directly attached NIC to be on the new subnet, then try and ping the printer on its new IP Address.  If successful, update your PCs to point to the new IP Address for the printer and perform a test print.
      2. b.      If the test print is good, then you are good to go.

    Alternative approach to avoid this issue

    In Step 5 above instead of using a Manually set IP Address select DHCP to work with your network environment. 

    Remember to assign a DHCP reservation for your Printer’s MAC address to ensure that it gets the same IP Address all of the time.  Otherwise it might change and you’ll be wondering why it stopped working.

    Apply and reboot the Printer to apply the change. Then update your PCs to point to the correct IP Address for this printer and print a test page.