Dell 946 Printer Loses Communication - Printers Forum - Peripherals - Dell Community

Dell 946 Printer Loses Communication


Dell Monitors, Printers, Projectors, Hardware and Software discussion

Dell 946 Printer Loses Communication

  • I have a two week old XPS 210 with a Dell 946 printer.  Every day or two, the printer stops working and the error msg says communication failure.  If I unplug the USB cord from the printer, then plug it back in, the printer starts working; but the problem recurs in a day or two.  The 946 is set as the default printer.  I checked services, and there is no listing for lexbce.  Any ideas?
  • I think you should start the Lexbce service.
    Try to run the services.msc and locate for the Lexbce server in the list of services. right-click the service and then click start. And as well as the print spooler. in case you don't have it enabled.
    Let us know if this resolved the problem.

    Message Edited by xytrielle on 11-14-200610:31 AM

  • There is no listing under services for the Lexbce Server, so I can't start it.  The Print Spooler is listed, and started.
  • what about the dlbx_device ? can you find it on the list?
  • Or maybe try to uninstall the printer driver. and reinstall it.
  • go to run type msconfig then under msconfig go to services check under the services tab if you have the lexcbe then check it if it not. then restart your pc. and try to uninstall and reinstall the driver for your printer.
  • I uninstalled and reinstalled the software.  There are still no services listings for Lexbce Server or dlbx_device.  I'll post back if the problem recurs.  Thanks for your help.
  • Ok. let us know if the problem's resolved or not. thanks!
  • did you already go to msconfig if you have the services lexcbe enabled there? if not try it uninstall and reinstall your printer after checking the msconfig. or you can go to command and run this command to go to command type cmd on the run box:  in the command window type net stop spooler then hit enter.. after that sc config spooler depend= RPCSS start= Auto  follow that exactly including the uppercase and lower casing of the letters, then enter.  last command is net start spooler then hit enter.
  • I already uninstalled and reinstalled the software for my 946 printer.  There is no Lexcbe Server listed in services.  I also ran the commands you requested - same result.
  • when you run the command did it say it was successful?
  • did you uninstall and reinstall the program after running the commands i told you? if not try to uninstall and reinstall it. if same issue try to download the updated driver from the internet or if you have an extra USB cable try to change it.
  • Hi,
    If you are using a 10ft usb cable, try changing to 6ft USB cable.
    Keep updating.
  • I cannot print again, so did the following:
    1.  Checked device manager which said the printer was working properly.
    2.  Checked the driver - was dated 7/2/2001, version
    3.  Checked for new drivers online - none available for the 946.
    4.  Unplugged the USB cable from both ends and reconnected.  Unplugged the printer power supply and reconnected.  Rebooted.  There is still no listing for Lexbce Server or dlbx_device in services, but the printer works again (sure for a short time only).
    5.  Ran Command, then net stop spooler, then sc config spooler depend= RPCSS start= Auto, (message said SUCCESS), then net spooler restart (message said started successfully).  Still no Lexbce Server listed.
    6.  Uninstalled and reinstalled the software.  Still no Lexbce Server listed.
    Since this is a new printer, I'll probalby call printer support and see about an exchange.
    Thanks for your help.
  • Yeah... try to call Dell.