Routing between Vlans for internal traffic and over GW for internet (6024)

Network Switches

Network Switches
Information and ideas on Dell PowerConnect network switch solutions.

Routing between Vlans for internal traffic and over GW for internet (6024)

This question is not answered

HI All,

I have a setup with a several of vlans that are like the following:

Vlan 1: 172.16.0.0
ip: 172.16.0.251

Vlan 4: 172.16.4.0
ip: 172.16.4.254

Vlan 8: 172.16.8.0
ip: 172.16.8.254

Vlan 12: 172.16.12.0
ip: 172.16.12.254

I have a router that is connected to Vlan 1 and had the IP 172.16.0.252 (Linksys WRT54G), just for Internet connection.

My hosts in each Vlan have the IP of their Vlan as their Gateway and DNS, this seems to be right. On Switch config level I have a route like:

ip route 0.0.0.0 0.0.0.0 172.16.0.252 

I also have RIP enabled on switch level.

When I want to ping something like google.com I see that the IP is resolved but I don't get any reply back. On the 6024 I get replies back.

On my WRT54G the routes to the vlan subnets are known and use the IP of the WRT54G as their GW, which also seems right to me.

What I see is that when I do a traceroute using a host on the 172.16.0.0 subnet, I always the the Linksys in the traceroute, which means all traffic goes in and out of the 6024, which is not nice at all.

I'm also not able to ping from other Vlans to other Vlans and I wonder why.

My config is kinda simple and I have seen them here a lot, but what can go wrong in such setup ? 

All Replies
  • In order for the different VLANs to be able to communicate with each other, VLAN routing needs to be configured on the router. If you can post the running config of the switch, we can look through it and see if we can offer any advice on changes.

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • Hi Daniel,

    Thanks for your reply. I have removed the configuration on my switch and want to start over.

    Do you have any example of how to enable the Vlan Routing ? Maybe an example config so I can compare things ?

  • I am not sure if the wrt54g supports VLAN routing. If it does, then you can configure it to route between the different VLANs. If it does not then you would need to setup some static routes on the 6024, to direct traffic between the VLANS. Here is a white paper that describes setting up static routes on the 6024.

    www.dell.com/.../app_note_38.pdf

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • Hi Daniel,

    Wasn't it the idea that the 6024 does recognize the Vlan Headers itself and use this to route from vlan to vlan ?

    I have indeed read about the static routes, the WRT54G with DDwrt supports Static routes, I'm not sure about vlan routing but because this device is connected using a 100Mbps port against a 1Gbps I would like to avoid any travic between the vlans over this WRT54G.

    Do you understand what I mean ?

  • The 6024 does not have the capability to route between VLANs. Regardless of the packet header information the capability is just not present on the device.

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • OK, thanks. I have read on a lot of sites, and also the forum here, that this should be possible on the 6024. I also saw that the router function was not in the Vlan interface as a command.

    You would say to add a static route for each vlan for my solution ? If this works, it would be great.

  • Adding the static routes should work fine for your situation. Reading through that White page it has a great scenario and examples of the commands that it takes to get those static routes to work.

    Keep us updated and let us know what config you end up going with.

    Thanks

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • Hi,

    Indeed, this document is the way I should do it.

    What I wonder is what I shall do with the route and the vlan IP. My Vlan IP's are known and should be the gateway for the subnet as far as I know. The issue is that I get the following error in that case:

    console(config)# ip route 172.16.4.0 255.255.255.0 172.16.4.254
    Gateway cannot be one of the addresses configured on this device.

    The document sets a gateway where the IP, .2 is not known in the config. I have seen this question a lot of times with no clear answer.

    What do I need to use as an IP to use my Vlan as GW for my subnet ?




  • Alright, did some more looking at this, and it turns  out that the static routes we put in place cannot point to the switch itself. That is why in the white page the 6024 has the static routes going from VLAN to VLAN on other network devices.

    We may be in a position where we would need a router on the network to perform the routing between VLANs. But I would like to see the running config you have on the 6024, we can look it over and see if there are any suggestions we can try.

    Thanks

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • OK, thanks so far, this makes it more clear!

    Here is my simple config so far:

    console# sh running-config


    Router Configuration
    -----------------------------

    interface port-channel 1
    switchport mode general
    exit
    interface port-channel 2
    switchport mode general
    exit
    interface range ethernet g(1,7)
    switchport mode general
    exit
    vlan database
    vlan 4,8,12
    exit
    interface ethernet g7
    switchport general pvid 8
    exit
    interface port-channel 1
    switchport general pvid 12
    exit                                        
    interface port-channel 2                    
    switchport general pvid 12
    exit
    interface range ethernet g(1,7)
    switchport general allowed vlan add 8
    exit
    interface range port-channel (1-2)
    switchport general allowed vlan add 12
    exit
    interface vlan 4
    name MANAGEMENT
    exit
    interface vlan 8
    name HOSTS
    exit
    interface vlan 12
    name STORAGE
    exit
    interface port-channel 1
    switchport general acceptable-frame-type tagged-only
    exit
    interface port-channel 2
    exit
    interface ethernet g7
    switchport general acceptable-frame-type tagged-only
    exit
    interface range ethernet g(19-21)
    channel-group 1 mode on
    exit
    interface range ethernet g(22-24)
    channel-group 2 mode on
    exit
    interface vlan 1
    ip address 172.16.0.251 255.255.255.0
    exit
    interface vlan 4
    ip address 172.16.4.254 255.255.255.0
    exit
    interface vlan 8
    ip address 172.16.8.254 255.255.255.0
    exit
    interface vlan 12
    ip address 172.16.12.254 255.255.255.0      
    exit
    username
    crypted
    snmp-server community Dell_Network_Manager rw view DefaultSuper


    OOB host Configuration
    -----------------------------

    Empty configuration







     
    _____________________________
    >> Default settings:
    >> Default settings:
    _____________________________
                                                
    >> Router Configuration
    -----------------------------
    >> Service tag:

    >> SW version 2.0.0.19 (date  05-May-2008 time  16:33:30)
     
    >> Gigabit Ethernet Ports
    =============================
    >> no shutdown
    >> speed 1000
    >> duplex full
    >> negotiation
    >> flow-control off
    >> mdix auto
    >> no back-pressure
     
    >> interface vlan 1
    >> interface port-channel 1 - 7
     
    >> no router RIP
     
    >> no router OSPF enable                    
     
    >> spanning-tree
    >> spanning-tree mode STP
     
    >> qos basic
     
    >> OOB host Configuration
    -------------------------
     
    >> interface out-of-band-eth
    >> no shutdown
    >> speed 100
    >> duplex full
    >> negotiation
    >> flow-control off
    >> no back-pressure
    >> exit

    Let's hope I don't need a Vlan router as this would cause some issues with outbound/inbound speed with such a setup that routes storage too.

  • Thanks for the config, it looks like all the VLANs are assigned to ports except for VLAN 4. But the switch should be routing between the 172.16.0.0 /24, and the 172.16.8.0 /24 and the 172.16.12.0 /24 networks though. As long as all the ports are up and running.

    We should be able to do a # show interfaces detail , to see the status of the ports and make sure they are up.

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • It's true, this config is not 100% designed, but is more an idea how my previous setup was.

    The issue is that the routing between the VLans is not happening also not when ports are connected and the "direct connected" routes are show when I do a "show ip route".

    What could be wrong in that case ?

  • Here an output of my routes:

    # show ip route

    Maximum Parallel Paths: 4 (4 after reset)

    Codes: C - connected, S - static, R - RIP, O - OSPF, E - OSPF external

    C  172.16.0.0/24      is directly connected                        vlan 1    

    C  172.16.8.0/24      is directly connected                        vlan 8    

    C  172.16.12.0/24     is directly connected                        vlan 12  

  • I am still actively researching ways to try and get this to work without using the router to route between the Vlans. I will post up any new information i find. Can we get the output of the following command.

    # show interfaces status

    Thanks

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • Hi Daniel, Nice you are helping out here.

    This is my connection status at the moment. Because I'm also testing and remote at the moment this is the setup for now, I can change this later on.

    # show interfaces status
                                                 Flow Link          Back   Mdix
    Port     Type         Duplex  Speed Neg      ctrl State       Pressure Mode
    ........ ............ ......  ..... ........ .... ........... ........ .......
    g1       1G-Copper    Full    100   Enabled  Off  Up          Disabled Off    
    g2       1G-Copper    Full    1000  Enabled  Off  Up          Disabled On     
    g3       1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off    
    g4       1G-Copper      --      --     --     --  Down           --     --    
    g5       1G-Copper    Full    1000  Enabled  Off  Up          Disabled On     
    g6       1G-Copper      --      --     --     --  Down           --     --    
    g7       1G-Copper    Full    1000  Enabled  Off  Up          Disabled On     
    g8       1G-Copper      --      --     --     --  Down           --     --    
    g9       1G-Copper      --      --     --     --  Down           --     --    
    g10      1G-Copper      --      --     --     --  Down           --     --    
    g11      1G-Copper      --      --     --     --  Down           --     --    
    g12      1G-Copper      --      --     --     --  Down           --     --    
    g13      1G-Copper      --      --     --     --  Down           --     --    
    g14      1G-Copper      --      --     --     --  Down           --     --    
    g15      1G-Copper      --      --     --     --  Down           --     --    
    g16      1G-Copper      --      --     --     --  Down           --     --    
    g17      1G-Combo-C   Full    1000  Enabled  Off  Up          Disabled On     
    g18      1G-Combo-C     --      --     --     --  Down           --     --    
    g19      1G-Combo-C     --      --     --     --  Down           --     --    
    g20      1G-Combo-C     --      --     --     --  Down           --     --    
    g21      1G-Combo-C     --      --     --     --  Down           --     --    
    g22      1G-Combo-C   Full    1000  Enabled  Off  Up          Disabled On     
    g23      1G-Combo-C   Full    1000  Enabled  Off  Up          Disabled Off    
    g24      1G-Combo-C   Full    1000  Enabled  Off  Up          Disabled On     

                                              Flow    Link          Back
    Ch       Type    Duplex  Speed  Neg      control  State       Pressure
    ........ ....... ......  .....  ........ .......  ........... ........
    ch1      1G        --      --      --       --    Down           --   
    ch2      1G      Full    1000   Enabled  Off      Up          Disabled
    ch3         --     --      --      --       --    Not Present    --   
    ch4         --     --      --      --       --    Not Present    --   
    ch5         --     --      --      --       --    Not Present    --   
    ch6         --     --      --      --       --    Not Present    --   
    ch7         --     --      --      --       --    Not Present    --   

                                                  Link
    Oob-eth   Type         Duplex  Speed Neg      State
    ........  ............ ......  ..... ........ ...........
    Oob-eth 1 100M-Copper    --      --     --    Down