7048 Routing/DHCP relay with 5548

Network Switches

Network Switches
Information and ideas on Dell PowerConnect network switch solutions.

7048 Routing/DHCP relay with 5548

This question is answered

Hi, 

I am having issue with the 5548 not relaying the DHCP request for PXE (SCCM), 5548 is connected to 7048 (Trunk). We are Cisco shop, this is the first time I am using DELL. Any help is appreciated.

--------
7048
--------

!Current Configuration:
!System Description "PowerConnect 7048, 4.2.2.3, VxWorks 6.6"
!System Software Version 4.2.2.3
!System Operational Mode "Normal"
!
configure
gvrp enable
vlan database
vlan 2,10-11,21,50-52,156
vlan routing 1 1
vlan routing 10 2
vlan routing 21 3
vlan routing 50 4
vlan routing 51 5
vlan routing 52 6
vlan routing 156 7
vlan routing 2 8
vlan routing 11 9
vlan association subnet 10.112.0.0 255.255.252.0 10
vlan association subnet 10.112.4.0 255.255.255.0 11
vlan association subnet 10.116.4.0 255.255.252.0 21
slot 1/0 5 ! PowerConnect 7048
slot 1/1 11 ! SFP+ Card
slot 1/2 9 ! CX4 Card
slot 2/0 6 ! PowerConnect 7048P
slot 2/1 11 ! SFP+ Card
slot 2/2 9 ! CX4 Card
stack
member 1 5 ! PCT7048
member 2 6 ! PCT7048P
ip routing
ip route 0.0.0.0 0.0.0.0 192.168.1.58
ip route 10.0.0.0 255.0.0.0 192.168.1.58
interface vlan 1
exit
interface vlan 2
ip address 192.168.1.57 255.255.255.252
ip local-proxy-arp
no ip redirects
exit
interface vlan 10
ip address 10.112.0.1 255.255.252.0
no ip redirects
exit
interface vlan 11
ip address 10.112.4.1 255.255.255.0
ip helper-address 10.112.1.50
ip local-proxy-arp
no ip redirects
exit
interface vlan 21
ip address 10.116.4.1 255.255.252.0
ip helper-address 10.112.1.50
ip helper-address 10.112.1.51
exit
interface Te1/1/2
description 'F2_NTR_4'
gvrp enable
spanning-tree portfast
switchport mode trunk
dot1x port-control force-authorized
exit



------
5548
------

vlan database
vlan 10-11,21
exit

gvrp enable

ip dhcp relay enable

stack master unit 1
!
interface vlan 1
ip address dhcp
!
interface vlan 10
ip address 10.112.0.4 255.255.252.0
ip dhcp relay enable
ip proxy-arp

interface gigabitethernet1/0/18
spanning-tree portfast
switchport access vlan 21

ip route 0.0.0.0 0.0.0.0 10.112.0.1

interface tengigabitethernet1/0/1
description F2_NTM
gvrp enable
spanning-tree portfast auto
switchport mode trunk
SW version 4.1.0.1 (date 05-Apr-2012 time 15:03:04)

Gigabit Ethernet Ports
=============================
no shutdown
speed 1000
duplex full
negotiation
flow-control on
mdix auto
no back-pressure
spanning-tree
spanning-tree mode RSTP

qos basic
qos trust cos
eee enable
SCCM PXE server is fine, tested on Cisco gear. 
Verified Answer
  • This is weird, PXE start working when I hard code the fiber link between switches to full duplex, even though they are showing the full duplex in auto. Thanks for your help.

All Replies
  • Do you have an IP helper address set up on the 55xx switch?  Page 617 of the CLI Guide.

    support.dell.com/.../en_ug.pdf

    ip helper-address

    Use the ip helper-address Global Configuration mode command to enable

    the forwarding of User Datagram Protocol (UDP) broadcast packets received

    on an interface to a specific (helper) address. Use the no form of this

    command to disable the forwarding of broadcast packets to a specific (helper)

    address.

    Syntax

    ip helper-address {ip-interface | all} address [udp-port-list]

    no ip helper-address {ip-interface | all} address

    Parameters

    • ip-interface—Specifies the IP interface.

    • all—Specifies all IP interfaces.

    • address—Specifies the destination broadcast or host address to which to

    forward UDP broadcast packets. A value of 0.0.0.0 specifies that UDP

    broadcast packets are not forwarded to any host.

    • udp-port-list—Specifies the destination UDP port number to which to

    forward broadcast packets. (Range: 1–65535)

    Default Configuration

    Forwarding of User Datagram Protocol (UDP) broadcast packets received on

    an interface to a specific (helper) address is disabled.

    If udp-port-list is not specified, packets for the default services are forwarded

    to the helper address.

    Get Support on Twitter @DellCaresPro

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • Device connected to access port does get dhcp ip from the server without defining the ip helper address on 5548, IP dhcp relay enable is functioning, problem is with PXE, I already tried the above suggested with no luck. :(

  • Do you have portfast set up on the interface trying to PXE?

    Console(config)# interface gigabitethernet 1/0/15

    Console(config-if)# spanning-tree portfast

    In PortFast mode, the interface is immediately put into the forwarding state upon linkup, without waiting for the standard forward time delay.

    Get Support on Twitter @DellCaresPro

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • This is weird, PXE start working when I hard code the fiber link between switches to full duplex, even though they are showing the full duplex in auto. Thanks for your help.

  • I'm glad you figured it out.  Thanks for your contribution to the community.

    Get Support on Twitter @DellCaresPro

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)