Channel-group Question

Network Switches

Network Switches
Information and ideas on Dell PowerConnect network switch solutions.

Channel-group Question

This question is not answered

Hi

I do have a live network connected to a Cisco switch through 6200 series powerconnect switches, the switch is connected to the router at interface 1/xg3. The thing is the following I have the network

10.10.147.0/24 which can ping the router at 10.10.147.1

now I did add a new vlan 10.10.146.0/24 I can ping the switch I did setup trunks for the  interfaces as needed. Devices can ping each other and the switch on this network, but they can NOT ping the router at 10.10.146.1

10.10.146.1 and 10.10.147.1 on the Cisco router are on the same physical interface with the former being a secondary IP.

I did replicate all147 settings on the switch until I got to the below :

interface port-channel 47
description 'to-Cisco-ASR'
switchport access vlan 147

here I added

interface port-channel 46
description 'to-Cisco-ASR'
switchport access vlan 146

The last part is as follows :

interface ethernet 1/xg3
channel-group 47 mode on
exit

here I need to add the port channel 46 to the channel-group 47, I do not want to mess things up so I need help here, if I execute  in configure mode :

interface ethernet 1/xg3

what should I add here

channel-group 46 mode on <--- will this overwrite channel-group 47 mode on

is there something like

channel-group rabge 46,47 mode on

Please advice and thanks a million.

All Replies
  • If I understand you correctly you are wanting to add another interface to the Port Channel?  On the PowerConnect switch you use the channel-group to create a port-channel.  It can get confusing.

    console# configure

    console(config)# interface gi1/0/1

    console(config-if-Gi1/0/01)# channel-group xx mode on

     

    then the show command

     

    console# show interfaces port-channel

    Channel    Ports

    .......           .....

    ch1             Active: gi1/0/1

     

    You can only have one port channel on a specific interface.

     

    what should I add here

    channel-group 46 mode on <--- will this overwrite channel-group 47 mode on

    This would overwrite channel-group 46 mode on.  The 46 is just a name that you choose. 

    If you are wanting to add more than one interface to the channel-group you can use a range command.

    console# configure

    console(config)# interface range ethernet g1-2

    console(config-if)# channel-group 1 mode auto

    Get Support on Twitter @DellCaresPro

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • Hi

    I am sorry for the confusion but what I need is not to add another interface to the port channel. I have one interface 1/xg3 that talks to the Cisco router as it stands only VLAN 147 is allowed to talk to the Cisco router I want VLAN 146 to talk to the Cisco router as well. I did duplicate all 147 settings for 146 apart from

    interface ethernet 1/xg3

    channel-group 47 mode on

    exit

    I did create a channel-port for 46 "for vlan 146"..this might all be wrong though ..not sure, but what I want to achieve is to have VLAN 146 talk to the Cisco router over the interface 1/xg3

  • First, let’s get some definitions.

     

    You create a port-channel using the channel-group command – this is used to group multiple physical interfaces together to gain

     

    • Increased Availability — If a link within a LAG fails or is replaced, the traffic is not disrupted and communication is maintained (even though the available capacity is reduced).
    • Load Sharing — Traffic is distributed across multiple links, minimizing the probability that a single link be overwhelmed.
    • Use of Existing Hardware — Firmware replaces the need to upgrade the hardware to higher bandwidth capacity.

    Once created you enter that port-channel and configure it as a single interface.

     

    Trunking/General Mode – Takes a single physical interface or a single port-channel and allows multiple VLANS/Subnets to traverse.

     -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Based on what you are describing it sounds like you have a port channel set up but you need a trunk/general connection on the single physical interface 1/xg3.  If this is the case then the port-channel you have created is not necessary at this point.

     

    Here is an example of setting up General Mode which is a trunking feature on the 6200 switches.

     

    console# configure

    console(config)# interface ethernet 1/xg3

    console(config-if)# switchport mode general

    console(config-if)# switchport general allowed vlan add 146 tagged

    console(config-if)# switchport general allowed vlan add 147 tagged

    console(config-if)# end

    Get Support on Twitter @DellCaresPro

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)