Switch doesn't work properly with spanning tree enabled

Network Switches

Network Switches
Information and ideas on Dell PowerConnect network switch solutions.

Switch doesn't work properly with spanning tree enabled

This question has suggested answer(s)

Hello all,

We recently acquired a Dell PowerConnect 5548, but it seems it is not working properly. It learns the MAC addresses, but does not seem to be able to use them to forward the packets correctly, i.e. all ports receive the all the traffic (like in a network hub). The switch only works correctly after disabling spanning tree.

We are using default configuration and the firmware version is 4.0.0.3. This behavior happens even if we test with only 3 workstations connected to the switch. 

Is that a known bug in this switch? Or maybe we are missing something? I believe that is not a expected behavior for Ethernet switches... 

Thanks in advance,

Marcelo

All Replies
  • On the 55xx switch Rapid STP (RSTP) is enabled by default.  If you have STP on other switches in the network you will want to disable RSTP on the 5548.

    Console (config) # spanning-tree mode stp

    Also you can look at setting your ports that are connected to clients that portfast is enabled

    console(config)# interface gi1/0/1

    console(config-if)# spanning-tree portfast

    Here is  the User Guide for reference on configuring Spanning tree starting page 426.

    support.dell.com/.../en_ug.pdf

    Get Support on Twitter @DellCaresPro

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)