PowerConnect 5548 and 6248 : How to config a general mode on 5548 switch ?

Network Switches

Network Switches
Information and ideas on Dell PowerConnect network switch solutions.

PowerConnect 5548 and 6248 : How to config a general mode on 5548 switch ?

This question is answered

Dear All,

I buyed a PowerConnect 5548 and 6248 switch, I config these two switch as below config, and the PC1 on 5548 can not ping from 5548 vlan100 to 6248 vlan100,

Event though, PC1 can't ping the vlan 100 interface on 5548.

I set the 5548 1/0/2 port to General mode, could you help me to check what is the problem?

Here is the topology about my test:

---------------------------------------------------------------------------------------

6248 Switch (Vlan100 , Vlan101)

       |1/g1

       |   (Trunk mode , allow vlan 100-101)

       |

       |1/0/1

5548 Switch (Vlan100 , Vlan 101)

       |1/0/2

       | General Mode, allow vlan 100-101 tagged

       |

PC1 on vlan 100

------------------------------------------------------------------------------------------------

PowerConnect5548 running config :

vlan database
vlan 100-102
exit
mac address-table static 00:19:b9:75:32:c3 vlan 102 interface gigabitethernet
1/0/3
mac address-table static 00:1a:a0:36:29:10 vlan 102 interface gigabitethernet
1/0/2
voice vlan oui-table add 000181 Nortel__________________
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 001049 Shoretel________________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00907a Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0
iscsi target port 3260 address 0.0.0.0
iscsi target port 9876 address 0.0.0.0
iscsi target port 20002 address 0.0.0.0
iscsi target port 20003 address 0.0.0.0
iscsi target port 25555 address 0.0.0.0
PC5548-1#
PC5548-1>
PC5548-1>
PC5548-1> en
PC5548-1# show run
vlan database
vlan 100-102
exit
mac address-table static 00:19:b9:75:32:c3 vlan 102 interface gigabitethernet
1/0/3
mac address-table static 00:1a:a0:36:29:10 vlan 102 interface gigabitethernet
1/0/2
voice vlan oui-table add 000181 Nortel__________________
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 001049 Shoretel________________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00907a Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0
iscsi target port 3260 address 0.0.0.0
iscsi target port 9876 address 0.0.0.0
iscsi target port 20002 address 0.0.0.0
iscsi target port 20003 address 0.0.0.0
iscsi target port 25555 address 0.0.0.0
hostname PC5548-1
username admin password encrypted d033e22ae348aeb5660fc2140aec35850c4da997 pr
ivilege 15
snmp-server community Dell_Network_Manager rw view DefaultSuper
!
interface vlan 1
 ip address 192.168.0.10 255.255.255.0
!
interface vlan 100
 ip address 172.88.88.2 255.255.255.0
!
interface vlan 101
 ip address 172.88.1.2 255.255.255.0
!
interface vlan 102
 ip address 172.88.2.2 255.255.255.0
!
interface gigabitethernet1/0/1
 switchport mode trunk
 switchport general allowed vlan add 100-102 tagged
 switchport general allowed vlan add 1 untagged
!
interface gigabitethernet1/0/2
 switchport mode general
 switchport general allowed vlan add 100-102 tagged
 switchport general allowed vlan add 1 untagged
!
interface gigabitethernet1/0/3
 switchport mode general
 switchport general allowed vlan add 100-102 tagged
 switchport general allowed vlan add 1 untagged
!

Default settings:
Service tag: 8RL57M1

SW version 4.0.1.0 (date  12-Apr-2011 time  17:40:25)

Gigabit Ethernet Ports
=============================
no shutdown
speed 1000
duplex full
negotiation
flow-control on
mdix auto
no back-pressure

interface vlan 1
interface port-channel 1 - 32

spanning-tree
spanning-tree mode RSTP

qos basic
qos trust cos
eee enable

PowerConnect 6248 Running config:

!Current Configuration:

!System Description "Powerconnect 6248, 3.2.0.7, VxWorks 6.5"

!System Software Version 3.2.0.7

!Cut-through mode is configured as disabled

!

configure

vlan database

vlan 100-102

vlan routing 101 1

vlan routing 102 2

vlan routing 100 3

exit

hostname "PC6248_1"

stack

member 1 2

exit

ip address 172.88.13.1 255.255.255.0

ip routing

interface vlan 100

routing

ip address 172.88.88.192 255.255.255.0

                   


exit

interface vlan 101

routing

ip address 172.88.1.1 255.255.255.0

exit

interface vlan 102

routing

ip address 172.88.2.1 255.255.255.0

exit

username "admin" password 0466f4d9ae893ac580c59700a56234cd level 15 encrypted

!

interface ethernet 1/g1

switchport mode trunk

switchport trunk allowed vlan add 1,100-102

exit

exit

Verified Answer
  • Thanks for the info. Iv'e already noticed that the behavior was different configuring trunks between the pc55xx and the pc62xx but thanks for clarifying.

    I managed to solve my problem. It wasn't nothing wrong with the config, (I think). I noticed that the laptops I was using for testing had TrendMicro client installed and blocking the traffic. As soon I unloaded it, vlans started to flow through the trunk.

    Well actually I upgraded the PC55xx from 4.0.1.11 to 4.0.1.12 and changed the vlan configuration on the client ports from switchport general to switchport access aswell. The PC 62xx has fw 3.3.2.3 and that's the latest til today.

    But I still think my problem was the trend micro client all along.

    Hope this help anyone.

All Replies
  • I'll set up a config next week and send you an example.

  • how about this?

  • Hey dude please did you manage to fix the problem?? I have the exact same issue, I can't trunk between PC6224 and PC5524

    Please post your solution

  • You may want to confirm the firmware level on the switches and upgrade to the latest firmware.  I found this about the trunking options with the different firmware.

    Firmware 4.0 on both Marvell and Broadcom switches introduces a change in trunk mode behavior. In models that use earlier firmware such as the 54XX and 62XX, trunk mode defaults to no VLAN's and they are added individually to the port. In Version 4.0 and later when a port is placed in switchport mode trunk, the default is all and unwanted VLAN's need to be removed.

    Information regarding trunk mode on the 55xx switch starts on page 500 of this user guide:

    support.dell.com/.../en_cli.pdf

    and page 604 on the 62xx switch guide:

    support.dell.com/.../cli_en.pdf

    I hope you find this information useful.  Is there a specific problem that you are facing?

    Get Support on Twitter @DellCaresPro

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • Thanks for the info. Iv'e already noticed that the behavior was different configuring trunks between the pc55xx and the pc62xx but thanks for clarifying.

    I managed to solve my problem. It wasn't nothing wrong with the config, (I think). I noticed that the laptops I was using for testing had TrendMicro client installed and blocking the traffic. As soon I unloaded it, vlans started to flow through the trunk.

    Well actually I upgraded the PC55xx from 4.0.1.11 to 4.0.1.12 and changed the vlan configuration on the client ports from switchport general to switchport access aswell. The PC 62xx has fw 3.3.2.3 and that's the latest til today.

    But I still think my problem was the trend micro client all along.

    Hope this help anyone.