VLAN Trunking between 6248 and 2848 - PowerConnect Forum - Network Switches - Dell Community

VLAN Trunking between 6248 and 2848

Network Switches

Network Switches
Information and ideas on Dell PowerConnect network switch solutions.

VLAN Trunking between 6248 and 2848

This question has been answered by randymarsh

Hi,

I have a Powerconnect 6248 connected to a 2848 and I am trying to get VLANS working on the 2848.

VLANS work and receive DHCP addresses, traffic routes correctly and DNS works on the 6248.

The DHCP, DNS server is connected to port 1 on the 6248. 

When I create a Trunk port on Port 3 of the 6248, allow all VLANS through it, create a trunk on port 1 of the 2848 on VLAN10 and try plugging devices into it, they cannot see any other devices connected to the L3 switch.

 

Both switches are running the latest firmware and the L3 on its own works as expected. I cannot get any sort of trunking working to the L2 switch, tried with normal and crossover cables.

Here is the config of the 6248 L3. The 2848 L2 switch has a blank canvas with VLAN 10 created on ports 1,2,3,4 with port 1 setup as the trunk port.

 

Any ideas pleeease? Anyone? This is driving me crazy.

 

************************

 

!Current Configuration:
!System Description "Powerconnect 6248, 3.2.0.7, VxWorks 6.5"
!System Software Version 3.2.0.7
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 10,20,30
vlan routing 10 1
vlan routing 20 2
vlan routing 30 3

exit
stack
member 1 2
exit
ip address 192.168.0.1 255.255.255.0
ip domain-name domain
ip name-server 192.168.1.10
ip routing
interface vlan 10
routing
ip address 192.168.1.1 255.255.255.0
exit
interface vlan 20
routing
ip address 192.168.20.1 255.255.255.0
ip helper-address 192.168.1.10
exit
interface vlan 30
routing
ip address 192.168.30.1 255.255.255.0
ip helper-address 192.168.1.10
exit
username "administrator" password 5f4dcc3b5aa765d61d8327deb882cf99 level 15 encrypted
dhcp l2relay
dhcp l2relay vlan 10-90
!
interface ethernet 1/g1
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 10,20,30
exit
!
interface ethernet 1/g2
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 10
exit
!
interface ethernet 1/g3
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 1/g4
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 10
exit
!
interface ethernet 1/g5
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 10
exit
!
interface ethernet 1/g6
switchport mode general
switchport general pvid 20
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 20
exit
!
interface ethernet 1/g7
switchport mode general
switchport general pvid 20
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 20
exit
!
interface ethernet 1/g8
switchport mode general
switchport general pvid 20
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 20
exit
!
interface ethernet 1/g9
switchport mode general
switchport general pvid 30
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 30
exit
!
interface ethernet 1/g10
switchport mode general
switchport general pvid 30
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 30
exit

Verified Answer
  • After Turning off spanning-tree on the 2848, this all works now.

    VLANS, trunking everything else.

    Thanks for the help! :)

     

    I hope if someone else can use this as it took me ages to work out.I plugged into Netgear switches etc and they seemed to work.

    The issue was going between the dell 6248 and 2848, Spanning tree is enabled on the 2848 by default. If I was going to the Netgear via the 6248 and then to the 2848 the switches were working.

    My config on the l3 works fine too if someone would like to use it :)

All Replies
  • Not sure about the 28xx series, but I know with the 27xx series using the GUI you have to assign the VLANID's is two areas on the config

  • your 62xx config will allow vlans 10 and 20 to ingress and egress as tagged on port 1/g3.   untagged traffic will be dropped. 

    Make sure 2848 port 1 is a tagged member of vlan 10 and 20.  I do not have one here, but on the vlan configuration screen you will need to toggle the membership button to a 'T' (if I recall correctly).  Assuming you want the other ports to be untagged in vlan 10, as the other poster said, you have to change in 2 places.  The vlan 10  membership for those ports should be set to 'U' and the port vlan should be set to 10.

  • I have a Tagged port for port 1 on the 2848 L2..

     VLANs 10 + 20 are marked with port 1 as T. Ports 2,3,4 are marked as U on VLAN 10 with the PVIDs set to 10.

     I have changed the port settings to be part of the VLANS under the port settings page and then clicked show all and set them a second time.

    I cannot find another place to set these VLANS or ports in the documentation or the menus on the Web interface on the switch.

    Trunking is still not working between the switches. Do I need to add anything else like security settings or anything to get the VLANS to work between the L2 2848 and L3 6248?

    If I use the clients directly on the L3 switch all works as expected.

    Between the 2 switches this trunking setup does not seem to work for me.

    Any ideas at all are appreciated.

     

    In the first line of the Reply are you saying that unless the port is setup as a trunk the packets will not pass through?

    My understanding is, If I have Untagged ports in VLANs on the 2848, the packets go through the trunk port and back to the L3 as tagged since VLAN10 is to tagged by port 1 on the L2 Switch?

    If I plug in the client and run wireshark, I can see the client  looking for a DHCP server, after a few tries and a few spanning tree for broadcast packets it eventually just times out. Does not look like there is much happening over the Trunk.

     

     

  • Just to eliminate a few things.

     

    Try plugging in to the Layer 2 switch, and set a static ip that's within your IP range, with the correct subnet, gateway etc

     

    See if you can then see your network and ping across to other vlans.

  • Post the output of "show spanning-tree" from the 62xx.  

  • I have set 192.168.1.55/24 as a client IP.

     192.168.1.1 as a Default gateway manually and placed a client on the layer 2 switch. (port 2 Marked as U)  VLAN 10. PVID 10.

    I had no luck communicating to other VLANS with this setting manually entered.

  • Results of "show spanning-tree" on the 6248.

     

    console#show spanning-tree active
    Spanning tree Enabled (BPDU flooding : Disabled) Portfast BPDU filtering Disabled mode rstp
    CST Regional Root: 80:00:00:25:64:2E:D1:03
    Regional Root Path Cost: 0


    ###### MST 0 Vlan Mapped: 1, 10, 20, 30
    ROOT ID
    Address 80:00:00:25:64:2E:D1:03
    This Switch is the Root.
    Hello Time 2 Sec Max Age 20 sec Forward Delay 15 sec
    Interfaces

    Name State Prio.Nbr Cost Sts Role PortFast RestrictedPort
    ------ -------- --------- ---------- ---- ----- -------- -------
    1/g1 Enabled 128.1 20000 FWD Desg No No
    1/g3 Enabled 128.3 20000 DSC Desg No No

    console#show spanning-tree
    Spanning tree :Enabled - BPDU Flooding :Disabled - Portfast BPDU filtering :Disabled - mode :rstp
    CST Regional Root: 80:00:00:25:64:2E:D1:03
    Regional Root Path Cost: 0
    ROOT ID
    Address 80:00:00:25:64:2E:D1:03
    This Switch is the Root.
    Hello Time 2 Sec Max Age 20 sec Forward Delay 15 sec TxHoldCount 6 sec
    Interfaces

    Name State Prio.Nbr Cost Sts Role PortFast Restricted
    ------ -------- --------- ---------- ---- ----- -------- -------
    1/g1 Enabled 128.1 20000 FWD Desg No No
    1/g2 Enabled 128.2 0 DIS Disb No No
    1/g3 Enabled 128.3 20000 DSC Desg No No
    1/g4 Enabled 128.4 0 DIS Disb No No



    Name State Prio.Nbr Cost Sts Role PortFast Restricted
    ------ -------- --------- ---------- ---- ----- -------- -------
    1/g5 Enabled 128.5 0 DIS Disb No No
    1/g6 Enabled 128.6 0 DIS Disb No No
    1/g7 Enabled 128.7 0 DIS Disb No No
    1/g8 Enabled 128.8 0 DIS Disb No No
    1/g9 Enabled 128.9 0 DIS Disb No No
    1/g10 Enabled 128.10 0 DIS Disb No No
    1/g11 Enabled 128.11 0 DIS Disb No No
    1/g12 Enabled 128.12 0 DIS Disb No No
    1/g13 Enabled 128.13 0 DIS Disb No No
    1/g14 Enabled 128.14 0 DIS Disb No No
    1/g15 Enabled 128.15 0 DIS Disb No No
    1/g16 Enabled 128.16 0 DIS Disb No No
    1/g17 Enabled 128.17 0 DIS Disb No No
     

  • Similar issues in my head right now!!

    Having a real nightmare setting up my VLAN's across hardware that is completely Dell!

    Can't get the VLAN's to talk via the L3 fibre core switch (6024F) - have posted a new thread today!

  • On the 6248's port, use General instead of Trunk and set PVID to 1. On the 2848's port just set the PVID to 1. On both, set VLAN 1 to U (untagged) and every other VLAN you want sent between them to T (tagged).

  • I tried the config as suggested and had no luck either by changing the PVID's and using those settings.

    Also tried to make a VLAN 10 VLAN on the L2 swich after resetting the config and trying to go from the L3 to L2 (trunk port on port 1 set on the L2 for VLAN10) and the others set as U's for VLAN10 with the PVID's as 10 and still had no luck.

    The L3 still works fine, but no traffic seems to go to the L2 switch even when i plug strait into the VLAN without the trunk set from switch to switch.

    Is a crossover cable needed for trunks? Any security settings needed between the 2 switches for VLANS? I am getting pretty desperate now with these Dell Switches.

    Cannot get them to talk to each other. Does anyone have some sort of config they know works between 2 switches? If I plug  the PC into the L3 as its requests its DHCP address it gets one from the server instantly when I enable portfast on the L3 in General mode with the above config.

    Without the spanning-tree portfast enabled it looks as though it has a 15-20 second delay on all the packets.

    Could this Spanning-tree delay be causing timeout issues with the trunking on the switches?

  • My 6248 stack talks to 3 different 2848s this way, so I know it works. It sounds like you're trying to solve 3 different problems at once. Disable spanning tree until your VLAN trunking is working (if you even need spanning tree...for two switches you shouldn't). Don't do anything with L3/DHCP until all the L2 is working correctly.

    Unless you've messed with the MDI/MDIX settings on the ports you can use any cable you want.

  • Hi Brad,

    After comparing my running 6248 switch in the live environment, with the 6024F configuration, it looks to be something to do with Routing primarily.

    I setup the interfaces on the 6024F and assign them to their respective VLAN's.

    If I set the Laptop NIC to the correct settings for the subnet, with a gateway within its range - I can ping this gateway while connected to an untagged port in that vlan, but no gateways on other subnets!!

    Just annoying as my 6248 switch takes 2 seconds to setup and configure routing (the joys of new hardware) - however I really want to use the 6024F in the new infrastructure for doing all the interconnectivity between switches via fibre.

     

  • Going back to scratch, I cannot get anything to work on the layer 3 6248 Switches when leaving or coming back into the switch.

    I suspect this is a routing config or default gateway issue.

    Completely wipe the 6248, Run through the Basic setup.

    Assign IP, Default gateway and plug into my functioning work network and no routing seems to work out, nothing comes into the switch. Even when its a blank canvas.

    I can plug a 2848 into the network, works strait away.

    Other L3 Switches on the network, different brands work without issues.

    Is there something fundamental I am failing to see here?

    Thanks to everyone that has helped me so far.

    Regards,
    Randy

  • Hi Randy,

    Ignore your existing network for a moment, get the switch on the bench with a power lead and a laptop and leave it that way.

    Now, reset the box to Factory Defaults.

    Plug in the Console lead and access Hyper Terminal, run through the usual process of powering down and back up again to get to the wizard.

    The first IP that you set, is for VLAN1, which you really want to keep seperate as there are so many security issues with using this (hackers using VLAN1 to traverse around standard Access Control etc.).

    Set.... (for example)

    • IP: 192.168.1.1
    • Subnet: 255.255.255.0
    • Gateway: 0.0.0.0

    Don't bother with SNTP setup at this stage. Apply the settings - I think those are the main ones above.

    Now the entire switch is VLAN1 - with a single Accessible IP - 192.168.1.1

    Set your laptop NIC to 192.168.1.2 / 255.255.255.0 and Gateway - 192.168.1.1

    Plug the Laptop into the Switch on ANY port, go to your Web Browser and enter 192.168.1.1 and you should reach the configuration. Once you get to this stage, you can use the wonderful new VLAN Routing Wizards that have been provided in the 6200 series firmware.

    Please write back when you have gotten this far so I can continue Smile

     

  • Hi AviatorChris,

    I appreciate the help. I got so far as to create the above config that was working on the L3 switch only with a DHCP server etc.

    Thought I understood what needs to happen, but there could be something basic that I have completely not been getting.

    I have followed the above instructions and got the stage above.

    IP: 192.168.1.1
    Subnet: 255.255.255.0
    Gateway: 0.0.0.0

    For this one I have used the switch which I have upgraded to the latest 3.2.0.7 firmware.

     Just a laptop exactly how you have recommended.