Dell PowerConnect 6248P: Enable VLAN 1 in Trunk Mode - PowerConnect Forum - Network Switches - Dell Community

Dell PowerConnect 6248P: Enable VLAN 1 in Trunk Mode

Network Switches

Network Switches
Information and ideas on Dell PowerConnect network switch solutions.

Dell PowerConnect 6248P: Enable VLAN 1 in Trunk Mode

  • I just received a Dell PC 6248P and our environment is in the middle of transitioning to a vlan'd environment.  However, we still have a lot of devices in VLAN 1 and this works fine with our PC 3xxx models.


    However, if I attempt to make a trunk port on the 6248P, it automatically removes vlan 1 as being able to traverse the port:

    interface ethernet 1/g17
    switchport mode trunk
    switchport trunk allowed vlan add 100
    switchport trunk allowed vlan remove 1


    This is a new behavior with the 6248P as it works fine with our 3448P.  Is there any way to correct this?  I recognize that it's not ideal to have devices on the management vlan but until we complete the migration, it's necessary.


    The end picture should be:

    Port is set to trunk


    When you look at the port it should show:

    VLAN 1: U

    VLAN 100: T


    Instead mine currently shows:

    VLAN 1: <BLANK>

    VLAN 100: T



  • Same exact problem.  Did you ever find a solution?

  • on 62xx switches, use "general mode" when you need vlan 1 to be untagged on a trunk.  For example:


    interface ethernet 1/g1

    switchport mode general

    switchport general allowed vlan add 2,3,4,5 tagged

    switchport general allowed vlan add 1 untagged                 <<<<<<<<not really necessary since vlan 1 is an untagged member by default

    switchport general pvid 1        <<<<<<<<<<<<<not really necessary since port vlan is 1 by default





  • Thank you.  Will try this and post results. 

  • Worked perfectly.   Thank you!

  • I have run into another problem similar to this thread that I have been unable to solve.

    First, we have two buildings with a singlemode fiber run between the two.  The fiber comes directly into LX transceivers on a 6248p PowerConnect switch at each building.  The switch at building 1 has an up-link port to a cisco switch which serves as the core for our VoIP system.  The up-link port is configured as noted above..

    Interface Ethernet 1/g45
    Switchport mode general
    Switchport general allowed vlan add 2

    This is working perfectly and devices on the 6248p at building 1 are having no issues.  The answer in this thread yesterday solved that problem.

    However at building 2 and the second 6248p I cannot get any traffic to pass through on VLAN 2.  I can pass traffic on VLAN 1 without issue between the buildings using basically the same config on both ends of the as I used for the up-link port at building 1.  Since I could not get any connectivity on VLAN 2, I changed the the port config connected via fiber to this:

    Switchport mode trunk
    Switchport trunk allowed vlan add 1,2

    However this did not work either.  Any suggestions?

    Thanks in advance. 

  • Got this solved.