Power Connect 6248 LAG setup

Network Switches

Network Switches
Information and ideas on Dell PowerConnect network switch solutions.

Power Connect 6248 LAG setup

  • Hi there, I have 2 stacks of 4 switches to link . In order to link those 2 stacks I would like to use 2 Ethernets cables and do a link aggregation. Based on 62XXUG.PDF I have looked how to setup LAG. Which seems pretty easy. Define LAG name per ports. Questions: -Does someone as experience with LAG setup, if yes can you please provide big steps. -Is STP (spanning tree) needed when using LAG ? -Any Best Practice paper/doc on LAG setup ? Thanks in advance for your help. Best Regards. gmiga76
  • interface ethernet 1/g34
    channel-group 5 mode auto
    exit
    !
    interface ethernet 1/g36
    channel-group 5 mode auto
    exit
    interface port-channel 5
    description 'LAG to Other Switch'
    switchport mode general
    no switchport general acceptable-frame-type tagged-only
    switchport general allowed vlan add 2,4,8 tagged
    exit
  • Thanks for this reply, I am going to have a look at this. Is there a way to do this via web panel ? . Rgds. gmiga76
  • I'm sure there is, but I'm a CLI kinda guy and I never use the web interface on these switches.
  • No prob .-) I am CLI fan too, just harder to explain and to put it in documentation. .-) Rgds. gmiga76
  • Gmiga,
     
    There's no LAG best practices that I'm aware of, so I guess you'd need to give more specific questions. One thing to keep in mind is that the LAG does not assume the properties of the ports it includes-so you'll need to make sure if you have VLANs on the individual ports, you'll need to move them to the port-channel interface.
     
    Also, spanning-tree is important to take into account. Before implementing a LAG, spanning tree will block one of those ports. When port-channel takes over, it effectively shuts down those ports-but it's not uncommon for one to remain blocked by spanning-tree. So, it's usually best to physically disconnect the ports, then set the LAG. Spanning-tree will then pick up the individual LAG connection.
     
    Let me know if you have more specific questions!
     
     
  • Steve,

    Thanks to you and other members for your reply.

    I have setup a LAG 1/g2 1/g4  assigned to channel-group 1 via CLI. I cannot ping my device on the other side.

    No VLANs involved in this setup .


    interface ethernet 1/g2
    channel-group 1 mode on

    interface ethernet 1/g4
    channel-groupe 1 mode on

    show interfaces port-channel returns

    pwc62485#show interfaces port-channel

    Channel   Ports
    -------   ------------------------------------------------------------------------
    ch1       Active: 1/g2, 1/g4


    Any idea why it does not work?.  My device on the other side is an EMC appliance supporting LACP .

    Best Regards.






  • Can you show us the portion of the configuration where you defined port-channel interface 1.  If you haven't done this part:

     

    interface port-channel 5
    description 'LAG to Other Switch'
    switchport mode general
    no switchport general acceptable-frame-type tagged-only
    switchport general allowed vlan add 2,4,8 tagged (You define VLAN's you need)

     

    add this to bind the physical ports to the logical LAG port.

  • Sorry, even with no other vlan but vlan 1, I think you will still need to allow vlan 1 through the virtual LAG port with the vlan allowed statement.

  • Thanks for your answers.

    Just to be sure.

    This means I ll have to allow default vlan which is vlan 1

    interface port-channel 1
    description 'LAG to EMC appliance'
    switchport mode general
    no switchport general acceptable-frame-type tagged-only
    switchport general allowed vlan add 1 tagged

    Does this seems ok for you.

    I have an additional question: How to delete those LAG created.

    Many thanks for you help.