Help with VLANs, LAGs and Trunking on 5324

Network Switches

Network Switches
Information and ideas on Dell PowerConnect network switch solutions.

Help with VLANs, LAGs and Trunking on 5324

  • I have 4 5324 switches that are currently running with the native vlan1. I'm trying to create multiple vlans that get propagated across all switches. I have the three switches connecting back to the main switch each with a LAG. The LAGs are set in Trucking mode. I aslo have GVRP running on all switches.

    1) The LAGs are configured as Trunking ports; but what should the ports that make up the LAGs be configured?

    2) I can create a VLAN on the main switch and on one of the other switches, but the remaining switches dont see the VLAN unles I create it on the switch itself. Why is it not being propagated?

    3) Should all LAGs be tagged with a (T) on all the VLANs?

    4) When configuring the ports that are members of the VALN, should all ports also be tagged (T, G or U)?


    Any help to clarify this setup would be apprecaited. I have a small image of the layout, I thought would be helpful but I dont see a way to include it in this post.

    Thanks!
  • First of all, unless you have VLAN aware devices i.e. devices which tag packets with VLAN IDs connected, then you won't get any use out of GVRP.
     
    1. Configure all of the VLANs on the switches, so if you want a VLAN 10 and VLAN 20 to span the switches, configure VLAN 10 and VLAN 20 on every switch
    2. Configure the link aggregate groups on the switches, then in the VLAN LAG settings configure them as trunks.
    3. Place the LAGs in every VLAN as tagged.
    4. On each switch, place the ports in their respective VLANs as Untagged - once you've done this, check on the VLAN port settings that the ports have a PVID that matches the VLAN you want the port in.
    5. Save the running config to the startup config

    Example CLI...switch has ports 21&22 as one link aggregate, ports 23&24 as a second link aggregate, these aggregates connecting to similar aggregates on other switches. Three VLANs, 10,20&30, with port 1&2 in VLAN10, port 4&5 in VLAN 20 and port 7&8 in VLAN 30, these ports having non VLAN aware devices connected and are members of one VLAN only.

    configure
    interface port-channel 1
    switchport mode trunk
    exit
    interface port-channel 2
    switchport mode trunk
    exit
    vlan database
    vlan 10,20,30
    exit
    interface range ethernet g(1-2)
    switchport access vlan 10
    exit
    interface range port-channel (1-2)
    switchport trunk allowed vlan add 10
    exit
    interface range ethernet g(4-5)
    switchport access vlan 20
    exit
    interface range port-channel (1-2)
    switchport trunk allowed vlan add 20
    exit
    interface range ethernet g(7-8)
    switchport access vlan 30
    exit
    interface range port-channel (1-2)
    switchport trunk allowed vlan add 30
    exit
    interface ethernet g21
    channel-group 2 mode on
    exit
    interface ethernet g22
    channel-group 2 mode on
    exit
    interface ethernet g23
    channel-group 1 mode on
    exit
    interface ethernet g24
    channel-group 1 mode on
    exit

  • Great. Thanks! I guess I misunderstood what GVRP would do. I was thinking it would share the VLAN database with the other swithes. What about the ports that are part of the LAGs? How should those individual ports be set?
  • GVRP does extend the VLAN database across the switches, but it then needs packets to arrive at the switch ports ( as ingress packets to the switch ) tagged for a VLAN; the switch then sees the VLAN ID for the packet, and dynamically extends the VLAN to that port.
     
    Just configure the ports into the appropriate LAGs; all of the VLAN settings are then applied to the LAGs, not to the individual ports.
     
    If you are using the web i/f, then on the VLAN membership page you have the LAGs shown separately, and to set the LAG as a trunk, you use the VLAN LAG settings page rather than the VLAN port settings page; this is reflected in the CLI example in that the port-channel is set as a trunk and then tagged into the VLANs, not the ports that make up the port-channel.
  • Thanks again cerbera, I appreciate you taking the time to reply. I'll complete the setup as you suggested. I did not think the port settings on the ports that make up the LAG would matter but I thought I would ask to be sure.