PowerConnect 5324 -> Summit 4 VLAN/tagging problem

Network Switches

Network Switches
Information and ideas on Dell PowerConnect network switch solutions.

PowerConnect 5324 -> Summit 4 VLAN/tagging problem

  • Hello,

    SETUP.
    [powerconnect port 24]<=======>[summit port 17]
    fiber

    SCENARIO 1
    summit 4 has port 17 in vlan VLAN1 id 13 and tagged into the VLAN1 vlan.

    I have a powerconnect 5324 with vlan VLAN1 id 13 with ports 3,4 untagged and port 24 tagged. fiber from port 24 is connected to port 17.

    host on (PowerConnect)port 3 can't ping the host in VLAN1 on the summit.
    network unreachable

    SCENARIO 2

    summit 4 has port 17 untagged in VLAN1 id 13.

    powerconnect 5324 ports 3,4,24 untagged.
    fiber from port 24 is connected to port 17.

    the network is reachable. ( will this cause any network degradation/issues in the future?)

    Thanks
  • Your statement "VLAN1 id 13" is a bit confusing. I'm assuming this means that you are using the name VLAN1 for VID 13. This is an odd and confusing naming scheme. It would make more sense from an administration perspective to use VLAN1 for VID 1 and VLAN13 for VID 13.

    When using untagged frames between the switches, you are relying on the ingress filter (PVID) to determine what VLAN the traffic will be part of. A port can only have one PVID. This configuration will work for your existing scenario, but it is not scalable.

    The ideal configuration would be to tag the VLANs between the switches. In this case, you would use access mode for ports 3 and 4 (switchport access vlan 13) and trunk mode for port 24 (switchport mode trunk) and add VLAN 13 to the trunk (switchport trunk allowed vlan add 13). The summit switch would then use untagged frames for the client ports and tagged frames for the trunk port. The PVID on the client ports should be 13. The PVID on the trunk port should be 1.

  • Thanks for the reply Greg.

    I fixed the VLAN Name issue but when I set port 24 to be TRUNK I get the following error:

    CLI MODE:
    Acceptable frame type value is only supported in General mode.


    I logged in via http and noticed
    The setting for the frame type is "Admin all" grayed out when Trunk is set for the port.

    On the PC5324 i set port 3,4 untagged VID 13 and port 24 tagged VID 13.


    thanks
  • Acceptable frame type is not something that is configured on a trunk port. When you configure a port for trunk mode, all VLANs added to the trunk are tagged. The only reason for using general mode ports is if you are using port overlapping or need to configure a port to tag some vlans and untag others.
     
    If you are using PVID 13 for the trunk port on the 5324, the trunk port on your other switch must be configured with PVID 13.
  • Greg,
    Let me know if this setup is correct.
    Ok. The network is reachable on both switches.
    Will this config cause any problems in the future?

    Setup:
    Summit port 17 tagged VID 16 and ports 11-16 untagged
    VLAN name = 16

    PC5324
    Ports 2, 3 untagged and port 24 tagged VID 16.
    VLAN name = 16

    VLAN config on PC5324

    console# show vlan

    Vlan Name Ports Type Authorization
    ---- ----------------- --------------------------- ------------ -------------
    1 1 g(1-2,5-23),ch(1-8) other Required
    16 16 g(3-4,24) permanent Required

    console# show running-config
    interface ethernet g24
    switchport mode general
    exit
    vlan database
    vlan 16
    exit
    interface ethernet g24
    switchport general pvid 16
    exit
    interface range ethernet g(3-4)
    switchport access vlan 16
    exit
    interface ethernet g24
    switchport general allowed vlan add 16
    exit
    interface vlan 16
    name pif
    exit
    interface ethernet g24
    switchport general acceptable-frame-type tagged-only
    exit


    ----------------------
    [Kconsole# show interface switchport ethernet g24
    Port : g24
    Port Mode: General
    Gvrp Status: disabled
    Ingress Filtering: true
    Acceptable Frame Type: admitOnlyVlanTagged
    Ingress UnTagged VLAN ( NATIVE ): 16

    Port is member in:


    Vlan Name Egress rule Port Membership Type
    ---- -------------------------------- ----------- --------------------
    16 16 Tagged Static


    Forbidden VLANS:

    Vlan Nam
  • This configuration will work but, unless your management VLAN is VLAN 16, you will not be able to manage the switch across the trunk. I would recommend using the management VLAN (VLAN to which the IP address is bound for managing the switch) as the native VLAN, using a trunk mode port, and tagging all other data VLANs that need to cross the trunk.
     
    Ex. using VLAN 1 for management:
     
    (config)# interface eth g24
    (config-if)# no switchport general acceptable-frame-types tagged-only
    (config-if)# no switchport general pvid
    (config-if)# switchport general allowed vlan remove 16
    (config-if)# switchport mode trunk
    (config-if)# switchport trunk allowed vlan add 16
     
    With this configuration, the native VLAN for the trunk will be VLAN 1. This will trunk VLANs 1 and 16 and allow you to manage the 5324 from across the trunk. However, the PVID on port 17 of the Summit will also need to be changed to VLAN 1 (or whatever VLAN is used for management).
  • Greg,

    I now got the hang of it but do I have to run these commands for a port to become a trunk all the time?


    (config-if)# no switchport general acceptable-frame-types tagged-only
    (config-if)# no switchport general pvid


    Again, thanks for your help.

    Carlos
  • The first command is necessary on a general mode port to prevent the switch from accepting untagged frames. The second command changes the native VLAN of a general mode port.
     
    These commands are not used if you are using trunk mode instead of general mode.