Enabling multiple DHCP replay server to different vlan

Network Switches

Network Switches
Information and ideas on Dell PowerConnect network switch solutions.

Enabling multiple DHCP replay server to different vlan

  • Hi

     

    We just bought Power Connect 6224 for one our sites and now we are looking to use this switch as our core switch for our two separate networks. Here is what we are looking to do

     

    1) Looking to enable inter vlan routing

    2) Looking to connect two separate networks to this switch

    3) Looking to use acl to filter traffic between two networks

    4) Looking to use multiple DHCP servers for different network

         i) We currently have two dhcp servers connected separately in windows 2003 environment

         ii) DNS server for both networks is looking at dhcp server for name resolution.

     

    Problem currently facing

    1) Couldn't find the way to enable different dhcp server for different vlan. Only could find to enable global DHCP server and could only have one IP address entry

     

    Question

     

    Is there any way we can use two dhcp servers for different vlan? say i would like one dhcp server serving vlan 2-5 and another serving vlan 6-10.

     

    Thank you in advance

     



    Message Edited by agurung on 05-17-2007 12:08 AM

    Message Edited by agurung on 05-17-2007 12:10 AM
  • Yes.
     
    Put one DHCP server on a port that is a member of vlan 2-5 and the other on a port that is a member of vlan 6-10.
     
    Post a link to picture of your network if you have more questions.
  • Thank you for your reply
     
    So in dell switches any policy we want to assign will be to the one of the interfaces that belongs to the vlan and that in turn apply that policy to whole vlan?
     
    I was doing some search on acl as well and all examples were assigning acl policies to interface not to vlan. One of the reason we are asking is we just configured HP procurve switches to do exact same thing and there we had to assign to vlan not to interface, i guess this is all because that is them and this is us type of thing.
     
    Thank you again.
     
     
     
  • We are doing the exact same thing, make sure the dhcp server scopes gateway is the vlans exit point on the 6224.We have 4 vlans - each with a different scope. Photo Sharing and Video Hosting at Photobucket

    Message Edited by StarLog on 05-17-2007 10:55 PM
  • Thanks for your diagram

     

    We finally had a chance to test our new setup according to your advice and assigning different DHCP server for different subnet unfortunately didn't work.

     

    here is what we did

     

    We enabled DHCP replay but didn't assign any ip address for dhcp server as we are assigning to individual subnet. we use command like

    -> ip helper-address 172.16.59.1 172.16.32.3

    -> ip helper-address 10.0.26.1 10.0.0.2

     

    We have enabled IP routing, have vlan configured, subnets are assigned to routing interface. Do we also need to enable routing like rip? my understanding is we only enable these routers if we want to connected to second router or so but all we are trying to do is communicate between vlan.

     

    When we connect our test pc to related port pc doesn't get IP address assigned but if we assign static ip address to this pc, it can access other vlan. will appreciate if you could advice me if there is anything i might have missed.

     

    I will post config tomorrow to clarify more as i am posting from my home i am not able to do that now.

     

    Thank you again



    Message Edited by agurung on 05-21-2007 06:53 AM

    Message Edited by agurung on 05-21-2007 06:53 AM
  • agurung,
    I know bh will chime in here with some good pointers to help you.
    One thing is not clear to me. Are you saying your using static ip's on the clients.?
    Our DHCP server had it's scopes like this:

    scope 192.168.111.0
    gateway: 192.168.111.254
    DNS: 192.168.111.37, ALSO add ISP DNS here.

    scope 192.168.115.0
    gateway: 192.168.115.254
    DNS: 192.168.111.37, ALSO add ISP DNS here.

    scope 192.168.116.0
    gateway: 192.168.116.254
    DNS: 192.168.111.37, ALSO add ISP DNS here.

    Message Edited by StarLog on 05-21-2007 08:01 PM
  • Hi Bronze
     
    Thanks for your reply
     
    I am trying to post rough diagram here but i realised that we need to host the images somewhere else which i am trying to find a way
     
    Coming to the point problem i am having is i am not able to get ip address assigned to the client. We have dhcp server setup and working with out any problem when i use hp switch as a core. if i use static ip address for testing propose for the client i can access servers.
     
    we would like our dhcp server assign ip address to the clients.
  • we finally manage to upload some diagram
     
    At the end of the day These two dhcp server only serve its related network, we will use acl to restric the access from student network but admin network will have all the access required. we are trying to find some document with example of enabling dhcp relay, acl etc but not able to find much, we will appreciate if you know any place
     
  • We thought there is some problem with our config so we reset switch to factory default and just for testing propose we created just three vlan and we put one windows 2003 server with dhcp server enable in vlan 100 and try getting ip address from vlan 104 & 105 but both remain unsuccessful.
     
    below is our config file that are testing with we will appreciate if you could put some thought on it
     
    YDMITCore#show running-config
    !Current Configuration:
    !System Description "Dell PowerConnect"
    !System Software Version 1.0.0.27
    !
    configure
    vlan database
    vlan 100,104-105
    vlan association subnet 172.16.56.0 255.255.255.0 100
    vlan association subnet 172.16.59.0 255.255.255.0 104
    vlan association subnet 172.16.60.0 255.255.255.0 105
    exit
    snmp-server location "2-154 Sussex St Sydney"
    snmp-server contact "Sys Admin"
    hostname "SYDMITCore"
    stack
    member 1 1
    exit
    ip address 10.0.120.2 255.255.255.0
    ip default-gateway 10.0.120.1
    interface vlan 100
    routing
    ip address  172.16.56.1  255.255.255.0
    exit
    interface vlan 104
    routing
    ip address  172.16.59.1  255.255.255.0
    exit
    interface vlan 105
    routing
    ip address  172.16.60.1  255.255.255.0
    exit
    ip routing
    bootpdhcprelay enable
    bootpdhcprelay serverip 172.16.56.50
    ip helper-address 172.16.59.1 172.16.56.50 37
    ip helper-address 172.16.59.1 172.16.56.50 42
    ip helper-address 172.16.59.1 172.16.56.50 49
    ip helper-address 172.16.59.1 172.16.56.50 53
    ip helper-address 172.16.59.1 172.16.56.50 137
    ip helper-address 172.16.59.1 172.16.56.50 138
    ip helper-address 172.16.60.1 172.16.56.50 37
    ip helper-address 172.16.60.1 172.16.56.50 42
    ip helper-address 172.16.60.1 172.16.56.50 49
    ip helper-address 172.16.60.1 172.16.56.50 53
    ip helper-address 172.16.60.1 172.16.56.50 137
    ip helper-address 172.16.60.1 172.16.56.50 138
    username "admin" password 26a627dc180db13ff4b4bbe417a58387 level 15 encrypted
    !
    interface ethernet 1/g1
    switchport access vlan 100
    exit
    !
    interface ethernet 1/g2
    switchport access vlan 100
    exit
    !
    interface ethernet 1/g3
    switchport access vlan 100
    exit
    !
    interface ethernet 1/g4
    switchport access vlan 100
    exit
    !
    interface ethernet 1/g5
    switchport access vlan 100
    exit
    !
    interface ethernet 1/g13
    switchport access vlan 104
    exit
    !
    interface ethernet 1/g14
    switchport access vlan 104
    exit
    !
    interface ethernet 1/g15
    switchport access vlan 104
    exit
    !
    interface ethernet 1/g19
    switchport access vlan 105
    exit
    !
    interface ethernet 1/g20
    switchport access vlan 105
    exit
    snmp-server community public rw
    exit
  • Hi Bronze
     
    Just to come back to your point of putting one dhcp server on a port which is the member of multiple vlan and other in another vlan
     
    We tried that didn't work, now server can not even ping the switch which is its default gateway. We try putting one port where DHCP server is connected both with tagged and untaged port both way we can not even ping DHCP server.
     
    Currently we onley have one IP address assigned to the server do we need to assign multiple ip address in DHCP server? if we go by doing this than i guess we also do not need to have DHCP relay enabled and so with BIND IP Subnet to VLAN.
     
    We will appreciate your time and reply.
     
    Thank you
  • Not sure if it  helps or not but I usually have to Untag, Tag, or F(not sure what that means) for each port that you want to associate with that VLAN.
     
    On  my 5324 I may have for VLAN 2, Port 2,3,4 marked U for those ports.
    VLAN3 5,6,7,8
    and so forth.
     
    You will need to put an IP Helper address for that VLAN.
    Ip Helper address 192.168.1.250
    So each VLAN could have its on DHCP server or you could have same ip helper address for all or ever other.
     
    Hope this helps.
    If you have a router doing the inter vlanning you will have to put a T on each VLAN for that port. We have found that untagging the port (U)rather than tagging the port (T)is much less pain. As some older drivers do not like the tagged packets.
     
     
    Jim
  • Hi Jim
     
    Thank you for your replay again
     
    I had to find it in a hard way that IP helper will not help you to relay DHCP traffic, it just allow you to broadcast other traffic. Only way i found DHCP relay works via globle command "bootpdhcprelay " and DHCP server is for all vlan that exist in the switch.
     
    I was interested in the solution you had first suggested me which as below
     
    >>Yes.
    >>Put one DHCP server on a port that is a member of vlan 2-5 and the other on a port that is a >>member of vlan 6-10."
     
    I think this may work but i have having deficullty here so wondering if you have any suggestion
     
    Thank you
  • Hi

     

    We thought we should close this threat here by saying few words

     

    We had decided to buy dell switches because of budget constraint but now in order to work in our environment we need to use three dell switches(at least 2 L3 switches) where as other switches like HP we would had to  just buy 1 switch which would have done job what we wanted with much more flexibilities.  

     

    Conclusion this time we made a decision based on assumption that Dell L3 switches will be able to what we wanted to do and ended up costing more than what one L3 HP switch would have cost us.

     

    Thank you again



    Message Edited by agurung on 05-30-2007 07:07 AM

    Message Edited by agurung on 05-30-2007 07:07 AM