I have a Windows Server group policy applied to all clients (PCs) that is successfully tagging packets from a Skype for Business port range with corresponding DSCP values of 46 (voice port range 5000-50019), 34 (video port range 50020 - 50039), and 24 (app sharing port range 50040 - 50059).  I've confirmed the packets coming from my own PC are being tagged with correct DSCP values when in those port ranges using a packet sniffer provided by Microsoft (MS Message Analyzer).  I'm trying to assign those three DSCP values to corresponding CoS levels with voice taking highest priority (CoS 1), video taking the second highest priority (CoS 2), and app sharing taking the third highest (CoS 3), with all other traffic being passed through normally.  

My configuration on the switch then tells me I need to automatically assign packets to those CoS levels using the DSCP tags that exist on ingress.  Here is the part of my configuration that is applicable to this question:

class-map match-all SkypeVoice ipv4
!match ip dscp 46(ef)
match ip dscp 46
exit


class-map match-all SkypeVideo ipv4
!match ip dscp 34(af41)
match ip dscp 34
exit


class-map match-all SkypeAppSharing ipv4
!match ip dscp 24(cs3)
match ip dscp 24
exit


policy-map Skype in
class SkypeVoice
assign-queue 1
mark cos 1
exit


class SkypeVideo
assign-queue 2
mark cos 2
exit


class SkypeAppSharing
assign-queue 3
mark cos 3

I've applied this policy to all interfaces on ingress:

interface Gi1/0/1
service-policy in Skype
switchport access vlan 104
exit
!
interface Gi1/0/2
service-policy in Skype
switchport access vlan 104
exit
!
interface Gi1/0/3
service-policy in Skype
switchport access vlan 104
exit

This is my access layer switch stack (5 stacked N2048s).  Does this look correct?  Anything that doesn't need to be there?  Do I also need to configure my core switch with anything besides the classofservice trust dot1p-mapping command?  Is there a way to determine that these packets are in fact being prioritized at the core switch (a show command, perhaps)?  I ask because this isn't working, which is why I'm here.  I would truly appreciate any help or insight I can get!