Dell XPS 13 9360 Wifi disconnection and router AP crash Issues - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

Dell XPS 13 9360 Wifi disconnection and router AP crash Issues

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Dell XPS 13 9360 Wifi disconnection and router AP crash Issues

This question has been answered by bobmayo

Hi All,

I received my brand new Kaby Lake powered Dell XPS 13 9360 a couple of weeks back and I have been suffering from wifi disconnect issues since then. The USB LAN connection works perfectly using the Dell USB C adapter.

I have tried all the standard troubleshooting steps:

1. BIOS and Killer 1535 Wireless Adapter Driver updated to latest version  (including uninstalling and reinstalling the wireless drivers)

2. Updated Windows 10 to the latest anniversary edition

3. Changed Power Saving settings on the Wireless Adapter using Powershell commands as there are no Power management options for the Killer Wireless adapter in Device Manager 

(Disable-NetAdapterPowerManagement -Name "Wi-Fi" -NoRestart)

After running the above command I get the status of the relevant power mgmt parameters as below (though not sure if its really effective)

DeviceSleepOnDisconnect : Inactive
WakeOnMagicPacket : Disabled

 4. Installed the latest Intel PROSet/Wireless Software and Drivers for Windows 10

Even after running step 1 and then later step,2 the wifi connection used to disconnect after some time (especially when a large file was being downloaded or any high network usage activity). Running a speed test of my broadband connection is a sure way to disconnect from wifi. More importantly this disconnection used to crash the Access Point on my TP-Link WR841N router which caused all my other devices to lose network connection as well and required a Router restart.

After steps 3 and 4 I have noticed the Wifi disconnections are not happening any more (atleast for now), but the Access Point crashes continue as it is, so effectively the wifi does not disconnect but the router AP crashes and needs a Router restart.

So my question to you all is do I need to change any config on the Wireless setup of my router to ensure the AP does not crash, or the should I change my router and get an AC router. If the router might not be the issue then it might be due to Windows 10 and the known issues with the Killer 1535 Wifi adapter itself.

I tried changing the Channel Width to 20 MHz but it reduced the network bandwidth and gave me 1/3rd of the available speed. 

Any help and pointers especially keeping my specific router issue in mind would be much appreciated.

Thanks

Verified Answer
  • I received my new Dell XPS 13 9560 PC, powered it up, and immediately it began crashing my wifi network. This happened repeatedly and would occur anywhere between five minutes and one hour after powering up. Every time this happened, I would have to go to my loft, where my router is, turn the power off and on and wait for the network to come up again. Given I live in a rural area, and use the wifi network for my phone, not only did I lose internet service when this happened, but phone service as well.  

    I was confident the new PC was the cause of the problem, since I’ve had my TP-LINK Archer C7 AC1750 Wireless Router for two years and never experienced this issue using our household’s other two computers: a high-end Mac Pro and a $200 HP Stream 11.  Plus, many friends and family have visited me and used their devices with no problem. So, I reported the problem to Dell Support. For four days, they had me installing various drivers and BIOS upgrades. They even had me upgrade the firmware in my router.

    Meanwhile, I’d been researching the issue, Googling “Dell XPS 13 9560 wifi issues” brought up an article from Windows Central, “Having Wi-Fi issues with your Dell XPS 13? Here’s how to fix the problem.” The article went on to state “One small complaint about the stellar Dell XPS 13: The stock wireless card ***.” Their recommended solution: replace the stock Rivet Network’s “Killer” wifi card with the Intel 8265NGWMG wireless card.  For those of you out of warranty, it’s available for about $30 from Amazon. The article takes you step-by-step through the replacement process. Quite easy if you’re careful.

    In my case, with my new PC, I didn’t want to risk voiding the warranty. On Day Four of my email and phone interactions with Dell Support, I brought up the fact that I had done some research and had found this article, plus many forum comments pointing to the Killer wireless card as being the culprit. Immediately, they agreed to have a technician drive to my house and replace the stock Killer wireless card with the Intel 8265NGW.

    It took the technician only a short amount of time to replace the card, install the driver for that card and hand me – at last – a working Dell XPS 13. Now, several days of usage later, the network has yet to fail.

All Replies
  • I have a similar problem.

  • Changing the channel width in the Router Wireless settings to 20Mhz worked for sometime, now the router crash is back again. As mentioned in my earlier post the wifi connection on my laptop isn't crashing anymore though.

    Should I change my router and if yes please suggest router models which work with Windows 10 / Killer 1535 / XPS 13 9360

    Thnx 

  • I have the same problem. 

    XPS 13 9360 with the Killer wifi card.  Router is a TP-Link Archer C7.  The router crashes about 30-60 min after the XPS laptop connects.  None of the other devices on the network have done this, and none of the other devices have internet access until I power cycle the router. 

    I've got updated drivers from October from the Killer networking site.  

    A bunch of people on reddit have posted about the same issue:

    www.reddit.com/.../

  • I've had the same problem after receiving my XPS as well. I'm using a TP-Link Archer D7, so not sure if it is just a router issue.

    Similar issues, in that my router will drop the AP, but also all wired PCs connected to it will no longer be able to access internet either.

    Hoping a Dell tech might have some answers.

  • I have a same problem with brand new Alienware 17 laptop r4. it uses the killer wireless too. Dell do you have a solution??? using TP-link c7 router and verified the newest driver on the router. I also updated the wireless and Ethernet driver for the laptop too. I even tried a different router linksys still the Alienware is bringing the whole network down requiring a network reboot. all other laptops are functioning just fine including streaming video until the Alienware is hooked up. Interestingly, even if I turn the Alienware wifi off and hook it up by Ethernet cable I get the same problem. Need solution pls.

  • Like everyone else in this thread, I have the same issue. I have updated my Archer C7 (V2) to the latest firmware. I have tried the Wifi driver that Dell has provided on their website. Even wiped my system and then tried the driver that Killer Wireless has provided. The XPS 13 9360 still seemed to cause my router to crash.

    I then decided to put Ubuntu 16.04.1 onto the laptop, and have not seen my router crash using either the 2.6Ghz or 5Ghz frequencies.

    My guess is that something is up with the Windows 10 driver for this wireless card. I'm going to roll with Ubuntu for now.

  • I wish I had that luxury but am stuck with Windows.

    I jsut tried to scroll back up adn see if anyone has tried this new driver from Nov 2016. I wish I'd read more teh post more carefully to see if this had been tried by anyone.

  • Me too.

  • After the Wifi disconnections stopped, I realized the issue was with my Router and Windows 10. So I switched to my old Dlink N150 router and post that I havent noticed any router crashes. So now I use 2 routers, the TPLINK for my other devices and the old Dlink for my brand new laptop. I notice slower browsing speeds on my new laptop but thats to do with my slower old router I guess.

    Will upgrade to a dual band AC router soon and hope it will resolve my wifi issues.

    I must admit, I spent too much time on this issue and it more or less killed any excitement I had for buying the "best laptop of 2016". I wish I had simply gone for the 2015 Macbook Pro and saved myself a lot of time..

     

  • I had the same issue as everyone else: Dell XPS 9360 crashing the TP Link Archer C7 (AC1750) router. I wrote on TP Link forum, and they recommended that I install a beta firmware that they developed to solve this issue. 

    Link to the beta firmware: http://static.tp-link.com/resources/software/ArcherC7v2_en_us_3_15_1_up(160511).zip

    I have just installed it so I can't tell yet if it will work, but probably worth trying!

  • Same problem for me , but with TP-LINK 841N . My new XPS 9360 causes the router to crash. Need a solution asap

  • I have the same problem with XPS 15 and TP-Link Archer 7 v2. I'm temporarily using an old router to avoid the problem, but need a solution ASAP.

    Has anyone been able to resolve this problem so far?

  • Had  the same problem, disabling WMM on the router solved my connection. (Although  it cripples the connection speed )

  • gerardon2017
    Had  the same problem, disabling WMM on the router solved my connection. (Although  it cripples the connection speed )

    I tried this. I believe the problem occurs when you stress the WIFI out to the max of the connection. Disabling WMM did indeed stop the router crash, but I think only cuz the WIFI speed can't be maxed out. It reduces my network speed to around 1.5MB/s. I transfer files over LAN all the time, and this changes my 4min transfer to 60mins+. Which isn't a viable solution for me.

    I have an Archer C7, with a Dell XPS 13 9360, Killer Wifi 1535. I can reproduce the problem very easily by just transferring a large 1GB file from 1 LAN computer to another LAN computer (from my Dell XPS via WIFI). Then as that transfers, if it doesn't cause the crash yet, you can just go to beta.speedtest.net, run a speed test, and it crashes almost 100% during the upload test. You can set the Killer Wifi to be on AC or N, doesn't matter with the 5GHz.

    I can repeat the test on my old Acer, which has an Intel Wifi, running N on 5GHz (same everything just different WIFI card), and this machine can transfer the file just fine multiple times with no crash.

    I'm on the latest BIOS, tried with the latest Dell Drivers. Tried with the latest Killer Drivers off their site. Nothing has fixed the problem. Tried with changing to N only on the killer. Tried changing to 80Mhz/40Mhz ac. Nothing.

    The Killer Wifi is 100% to blame, but the router shouldn't crash just cuz one of the clients is being naughty. Dell (Killer) needs to release an updated Windows Network Driver ASAP which make it so their WIFI Card isn't CRASHING AP's randomly when you stress the network speed out. Also TP-LINK (QCA chipset really) needs to release an updated firmware that doesn't crash their router when a client is being naughty.

    TP-Link is working with QCA as we speak to handle the bad client without crashing. Some patches have been made, but no official stable firmware has been released yet.

    Is Dell working with Killer to fix their Driver to not act incorrectly causing malformed wifi packets and crashing the AP's? I hope so? I know Killer has had a BAD reputation with bad Drivers in the past. You know it's 100% a driver issue, cuz the Killer 1535 works just fine with the Ubuntu Driver on an Archer C7. It's only the Killer Windows Driver which is causing the issue. Same machine, differnt OS.

    I got this Dell XPS 9360 for Christmas, and it's been nothing but headaches for the last few weeks. This Wifi Problem crashing my Router. The Sound drivers preventing playback of streaming videos (Netflix and such) within chrome. The Sound Service jumping to 30% CPU usage when in "conversations". Sound being very delayed at times. A small "Crackling" sound when no music is playing. The Precision Touchpad drivers with 2-finger scrolling act very laggy sometimes. My touchpad bottom right corner is recessed a bit, and not flushed with the palm rest. Bluetooth mouse discconects from the killer bluetooth about once an hour. And the BIOS Fn Lock Setting options are switched (wrong descriptions). Seems like A LOT OF DRIVER ISSUES DELL... 

    I feel like I may have to return my Dell XPS 9360. Or have Dell replace the Killer 1535 with an Intel 8265 for now... as I need to transfer larger files over to my other LAN computers often. Having to reboot my router every hour is wasting too much of my time.

  • I am also having the same issue