Forums

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Inspiron 3521 wireless problem

This question is not answered

Hi,

I've tried to install wireless+Bluetooth driver, but it does not start install shield wizard, but vanishes. I've tried older versions too, with the same problem, I can't install wireless on the laptop - my operating system is win8 64 bit

device identifiers:

PCI\VEN_14E4&DEV_4365&SUBSYS_00161028&REV_01
PCI\VEN_14E4&DEV_4365&SUBSYS_00161028
PCI\VEN_14E4&DEV_4365&CC_028000
PCI\VEN_14E4&DEV_4365&CC_0280

It says I have a network control, but I can not make it work.
Could you please help?

Thanks
Gábor
All Replies
  • Hi Gábor,

    May I know did you install the drivers from the Dell Support site?

    Lets try uninstalling and reinstalling the wireless drivers.

    Uninstall:

    • From the Start screen, swipe up and tap the All apps icon.
    • If you have a mouse, right-click on the Start screen and then click All apps.
    • Once on the Apps screen, scroll or swipe to the right until you see the Windows System heading.
    • Tap or click on Control Panel, located under Windows System.
    • Windows 8 will bring up the Desktop and automatically open the Control Panel.
    • Tap or click on the Hardware and Sound link.
    • In the Hardware and Sound window, click or tap Device Manager, located under the Devices and Printers heading.
    • Under “Network Adapters”, right click “Dell Wireless 1704”, click “Uninstall”.
    • Check the box “Delete driver software for this device”, click ok and follow the on-screen instructions to uninstall.
    • Restart the computer.

    Install:

    http://dell.to/14qpZjU

    Refer the following link for more troubleshooting:

    http://dell.to/105mWOZ

    Let me know how it goes.

    Thanks & Regards
    Rajesh R
    #iworkfordell
    To know  more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US ; UK; India. For Dell support videos click Here.
    If a post answers your question, please click "
    Yes".

  • Hi Rajesh,

     

    sorry, it did not work out. I don't have it under network adapters, i have it under unknown adapters. The problem remained, though I downloaded the driver again. It starts with choose language,then it sais that it will prepare install shield wizard, the green line fills 100%,  then it vanishes, and install shield wizard never starts.

    Of course I downloaded all drivers from the official dell site. I disabled comodo internet security fully, so it can not be the problem.

     

    Thanks anyway, I's thinking about reinstalling the computer...

     

    Gábor

  • Hi Gábor,

    You may create a new user account and try installing the drivers.

    Refer the following link to create a new user account:

    http://dell.to/13azQ0o

    Awaiting your response!

    Thanks & Regards
    Rajesh R
    #iworkfordell
    To know  more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US ; UK; India. For Dell support videos click Here.
    If a post answers your question, please click "
    Yes".

  • Hi,

    sorry, it did not work, even with different windows versions and special order kept...

    it simply does not start install package...

    Thanks anyway, service will start working with it.

    Gábor

  • Hi Gábor,

    Is the issue fixed?

    If the issue persists, you may try a clean reinstallation of Operating system on the computer.

    http://dell.to/15WpxvB

    Awaiting your response!

    Thanks & Regards
    Rajesh R
    #iworkfordell
    To know  more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US ; UK; India. For Dell support videos click Here.
    If a post answers your question, please click "
    Yes".