Forums

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

inspiron 1520 network wireless not working

This question has suggested answer(s)

I have a Dell Inspiron that came with Windows XP. After getting viruses and Malware I wiped the drive. I replaced XP with Vista because that is the only OS I had available. Now everything on My Inspiron works beautifully except for the Wireless card.  I have downloaded the driver but it still does not work. The blue light does not come on on My wireless switch. Under Device Manager tab the other devices tab had a YELLOW ! on the Network Controller ...when I open that tab it is empty ....Please help...My warranty is expired and Dell wants $83.00 to tell me how to fix it over the phone .

All Replies
  • Hi okcmedic82,

    I would suggest you to uninstall and re-install the wireless card driver on the system. Please follow the steps mentioned below to uninstall the video card.

    1. Click on Start button.
    2. In the search box type devmgmt.msc and then press enter.
    3. Select the wireless card device and right click on it
    4. Now select properties.
    5. In the properties window, under Driver tab, click on Uninstall button.
    6. Check “Delete the driver software for this device.”
    7. You want to delete the driver click OK.

    After the uninstall finishes restart the system. Then re-install the wireless card driver on the system for issue resolution. Please enter your service tag # on the link below, select the OS, then download the wireless card driver from Network section onto the system and install it.

    http://dell.to/ZaQuel

    Please let me know if this helps.



    #iwork4Dell
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • Did not work. This is the message that I get.

    Compatibility issue between wireless network card and Windows

    Your wireless network card has stopped working properly because a compatible driver isn't available for this version of Windows.

    Because this device isn't compatible with this version of Windows, and there are no solutions available for this problem, we recommend that you contact the manufacturer of Dell Wireless 1395 WLAN MiniCard.

  • My question is can I purchase a card or driver to fix this problem ?

  • Hi okcmedic82,

    I would like to know did you use Dell OEM Windows Vista reinstallation disc to install the operating system on the computer. Also, did you install 32 bit or 64 bit version of Windows Vista?

    Please send me a private message with the system service tag of the system so that I can check for the Wireless card driver and provide you the correct driver. Please click on my name and click Start Conversation to send me a private message.



    #iwork4Dell
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • I messaged you my service tag. I installed a Vista Home Premium. I bought this from Best Buy. It was not a Dell disc.

  • Hi, I believe this is still unresolved.

    My laptop is an Inspiron 1520, Vista HomePm 32-bit. It also came with a 'drivers and software' disc. Bought in '08, wireless died '10.

    When my wireless died (4yrs ago), I did everything to try to restore it; re-install windows, re-install device drivers, update device drivers, looked for answers in the BIOS settings, etc. Nothing worked and I've been using a hard connection since (which is annoying). Today I decided to try again, but had no intent on anything serious, as I believed it was the WLAN PCB that needed replacement.

    So, I tried updating the driver, deleting and re-installing, but nothing found/worked. I went onto Google and searched 'WLAN 1390 driver'. The first page is this one - http://www.dell.com/support/drivers/us/en/19/driverdetails?driverid=R286815 . I'm sure I'd used this download before, but downloaded the software anyway - it's a set of drivers that is intended for 'Latitude' and 'Precision' systems, but it mentions the WLAN 1390 driver. Installed that, looked into the device manager, and I now have a 'Dell wireless 1395 WLAN Mini-card' in the 'Network adapters' section, and no 'YELLOW !'.

    Problem solved? No. Still no reaction from switching my laptops' wireless switch on the side of the chassis. Now I'm 99.9% sure it's the hardware.

    So I aimlessly right-clicked on the adapter and selected 'properties', to see if there was a miracle button somewhere, but nothing. Nothing except for a tab that I'd never seen, or maybe never paid attention to - 'Advanced'. In here is a list of around twenty different settings for the chip itself, most of which I don't understand. So I started with the top setting 'Afterburner', switched it's value to 'Enabled', clicked 'OK', let Device Manager refesh itself, and nothing. Went back into 'Advanced' tab, set 'Afterburner' to 'Disabled', set 'Antenna Diversity' to 'Aux', clicked 'OK', let Device Manager refresh itself. I worked down the list in this way. I'd almost given up, until I saw my Network tray icon flicker to the 'wireless networks available' icon.

    Here are my 'Advanced' tab settings:

    Afterburner - Disabled | Antenna Diversity - Auto | AP Compatibility Mode - Higher Performance | Bluetooth Collaboration - 0 | BSS Mode - Default | Disable Upon Wired Connect - Disabled | Fragmentation Threshold - 2346 | IBSS 54g(tm) Protection Mode - Auto | IBSS Allowed - Enabled | IBSS Mode - 802.11b/g Auto | Locally Administered MAC Address - Not present | Location - Japan | Lock Wireless Settings - Disabled | Manage Wireless Settings - Enabled | Minimum Power Consumption - Enabled | PLCP Header - Auto (short/Long) | Power Save Mode - Disabled | Radio Enable/Disable - Enabled | Rate - Best Rate | Roam Tendency - Moderate | Roaming Decision - Default | RTS Threshold - 2347 | SSID Autopromote - Disabled | VLAN Priority Support - Disabled | Wake-up Mode - All | WMM - Auto | WZC IBSS Channel Number - 11 | WZC Managed Ethernet - Disabled | XPress (TM) Technology - Enabled .

    I believe that my wireless responded after changing the XPress setting, and then the IBSS Mode setting.

    I hope this works for you. Note that the wireless LED on the side of the chassis still won't light up, however the universal wireless symbol (on the right, with the Power, Bluetooth etc) is now lit up. I've restarted my PC, turned the wireless switch (on the chassis) off and on, and it still works.

    Good luck.