Random Internet Lag Spikes - M14xR1

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Random Internet Lag Spikes - M14xR1

This question has been answered by Slate001

Since last night 10/26/12 I have been experiencing random lag spikes on all games (Hawken Beta(installed yesterstay), Mechwarrior beta, MW3, and BF3).
* Framerates do NOT drop when the lag occurs
* Lag last for 1-3 seconds
* Lag occurs on both wireless and wired connections
* Lag occurs when no one but myself is on the network and while others are on it as well
* Only occurs while gaming as far as I can tell
* Unsure if other computers on network are lagging because none of them are gaming computers
* I have performed tests using SpeedTest and the ping/DL/UL speeds are normal
* Tried turning off Anti-virus (Kaspersky). No Change
* Ran virus and malware scans using Kaspersky and malwarebytes. Both negative results 

Any suggestion or test that I am able to run to see if it is a laptop hardware problem or a router/modem issue/ISP issue?
Cable ISP
Cisco Modem (with phone)
Netgear gigabit router

Intel I5-2430M
Geforce 555m 3GB
Killer Wireless-N 1103

Verified Answer
  • It has been nearly 2 weeks now and the problem has not returned since I saw a bucket truck at the end of the street working on the node. Fun enough I never even got a call back from the supervisor telling me he had dispatched someone to the node. Guess he finally realized I was right.

All Replies
  • Slate001,

    Are you saying you did NOT have these issues prior to 10/26? If yes, some driver you loaded on 10/26 is the possible culprit. Did you allow Windows Update to automatically install some drivers?

  • Prior to 10/26 the issue was NOT present. I did not load any drivers on that day prior to the issue starting. I also rolled the entire system back to before the problem to eliminate any program that was loaded (Hawken in this case)I believe I have eliminated my M14x from being the problem. I was able to bring another computer up to par to test if the internet lag spikes was present while gaming on that PC as well. the lag was still present.

    I also attached my M14x directly to the modem to eliminate the router from being the issue. The lag was still present.

    Lastly I was also was receiving lag and drop outs when trying to video chat using my iPhone when connected wirelessly to the network.  

    The problem seems to be a ISP issue. The Cable company will be coming soon to check their lines and equipment today. Hopefully this will be resolved within the next few hours

    Thank you for responding. I hope you or others can help if my ISP does not find a solution

  • Cable company came out changed a few lines that they said may be causing the problem. Lag continues to be a problem.

    They are claiming that my network and modem output is now optimized.

    I tried connecting directly to the modem after they left and the lag is still there as well.  Called them back. They are claiming that there is some issue on my side. I just can not see how this is true when the lag is on more than one device that is connected to the network.

    Any suggestions? I am baffled.

  • Moving this to the Networking board to see if they can help.

  • Slate001,


    Whe you said the iPhone is also lagging, it almost points to your ISP. Did you power cycle the modem/routers?

    Power off your ISP modem/router and your wireless router(if any) for 30 seconds. Then power on the ISP modem/router. Wait 15 seconds, then power on the wireless router(if any)

    Restart the computer and try to connect.

    What happens?


    I think you said you're using Kasperly. Not sure is Kasperly uses a lot of resources.


    Can you run Finding System Information REMOVE YOUR PRODUCT ID and REGISTERED OWNER and also run an ipconfig /all log and post it back here.


    Have you scanned for Malware? Download Malwarebytes Anti-Malware update it and do a quick scan remove anything it finds.

    A good article to read...

    Windows startup programs. What are they? Are they required? How can I disable them?





    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • I have power cycled both modem and router multiple times followed by a computer restart and the problem always persists.

    Kaspersky uses minimal resources as far as I can tell. It does not scan unless I ask it too and keeps an eye out for possible threats from places that are known to include viruses.

    As stated the lag  is present even when kaspersky is turned off completely.

    Also I have ran the Malewarebytes as I stated and no Maleware was found on my system.

    I already have my computer optimized at startup and only a few programs are allowed to start automatically.

    I went ahead and notified my ISP yet again that the lag persists and gets worse during prime time, this time they finally are ammiting that I am losing some packets. They will be coming back out later this weak to mostlikly replace the modem.

    I did some other research and found that if the modem is not the issue (it's only 2months old) then my ISp could have a node issue which will require the the top tier techs to look into it. Thoughts or possibilities of this?

    (FYI I will upload the two logs you requested when I get home from work later tonight.)

  • OS Name:                   Microsoft Windows 7 Home Premium

    OS Version:                6.1.7601 Service Pack 1 Build 7601

    OS Manufacturer:           Microsoft Corporation

    OS Configuration:          Standalone Workstation

    OS Build Type:             Multiprocessor Free        

    Original Install Date:     4/16/2012, 2:40:04 AM

    System Boot Time:          10/30/2012, 11:09:52 PM

    System Manufacturer:       Alienware

    System Model:              M14xR1

    System Type:               x64-based PC

    Processor(s):              1 Processor(s) Installed.

                              [01]: Intel64 Family 6 Model 42 Stepping 7 GenuineIntel ~2401 Mhz

    BIOS Version:              Alienware A08, 12/24/2011

    Windows Directory:         C:\Windows

    System Directory:          C:\Windows\system32

    Boot Device:               \Device\HarddiskVolume1

    System Locale:             en-us;English (United States)

    Input Locale:              en-us;English (United States)

    Time Zone:                 (UTC-06:00) Central Time (US & Canada)

    Total Physical Memory:     8,140 MB

    Available Physical Memory: 5,632 MB

    Virtual Memory: Max Size:  16,278 MB

    Virtual Memory: Available: 13,460 MB

    Virtual Memory: In Use:    2,818 MB

    Page File Location(s):     C:\pagefile.sys

    Domain:                    WORKGROUP

    Logon Server:              \\AW

    Hotfix(s):                 114 Hotfix(s) Installed.

                              [01]: 982861

                              [02]: KB971033

                              [03]: KB2425227

                              [04]: KB2479943

                              [05]: KB2484033

                              [06]: KB2488113

                              [07]: KB2491683

                              [08]: KB2492386

                              [09]: KB2505438

                              [10]: KB2506014

                              [11]: KB2506212

                              [12]: KB2506928

                              [13]: KB2507618

                              [14]: KB2509553

                              [15]: KB2510531

                              [16]: KB2511250

                              [17]: KB2511455

                              [18]: KB2515325

                              [19]: KB2518869

                              [20]: KB2522422

                              [21]: KB2529073

                              [22]: KB2532531

                              [23]: KB2533552

                              [24]: KB2536275

                              [25]: KB2536276

                              [26]: KB2541014

                              [27]: KB2544893

                              [28]: KB2545698

                              [29]: KB2547666

                              [30]: KB2552343

                              [31]: KB2556532

                              [32]: KB2560656

                              [33]: KB2563227

                              [34]: KB2564958

                              [35]: KB2567680

                              [36]: KB2570947

                              [37]: KB2572077

                              [38]: KB2579686

                              [39]: KB2584146

                              [40]: KB2585542

                              [41]: KB2588516

                              [42]: KB2603229

                              [43]: KB2604115

                              [44]: KB2618451

                              [45]: KB2619339

                              [46]: KB2620704

                              [47]: KB2620712

                              [48]: KB2621440

                              [49]: KB2631813

                              [50]: KB2633873

                              [51]: KB2633952

                              [52]: KB2640148

                              [53]: KB2641653

                              [54]: KB2641690

                              [55]: KB2644615

                              [56]: KB2645640

                              [57]: KB2647518

                              [58]: KB2647753

                              [59]: KB2653956

                              [60]: KB2654428

                              [61]: KB2655992

                              [62]: KB2656356

                              [63]: KB2656373

                              [64]: KB2656411

                              [65]: KB2658846

                              [66]: KB2659262

                              [67]: KB2660075

                              [68]: KB2660649

                              [69]: KB2661254

                              [70]: KB2665364

                              [71]: KB2667402

                              [72]: KB2675157

                              [73]: KB2676562

                              [74]: KB2677070

                              [75]: KB2679255

                              [76]: KB2685939

                              [77]: KB2686831

                              [78]: KB2688338

                              [79]: KB2690533

                              [80]: KB2691442

                              [81]: KB2695962

                              [82]: KB2698365

                              [83]: KB2699779

                              [84]: KB2699988

                              [85]: KB2705219

                              [86]: KB2709162

                              [87]: KB2709630

                              [88]: KB2709715

                              [89]: KB2709981

                              [90]: KB2712808

                              [91]: KB2718523

                              [92]: KB2718704

                              [93]: KB2719177

                              [94]: KB2719857

                              [95]: KB2719985

                              [96]: KB2722913

                              [97]: KB2724197

                              [98]: KB2729094

                              [99]: KB2731771

                              [100]: KB2731847

                              [101]: KB2732059

                              [102]: KB2732487

                              [103]: KB2732500

                              [104]: KB2735855

                              [105]: KB2736233

                              [106]: KB2739159

                              [107]: KB2741355

                              [108]: KB2743555

                              [109]: KB2744842

                              [110]: KB2749655

                              [111]: KB2756822

                              [112]: KB958488

                              [113]: KB976902

                              [114]: KB982018

    Network Card(s):           2 NIC(s) Installed.

                              [01]: Killer Wireless-N 1103 Network Adapter

                                    Connection Name: Wireless Network Connection

                                    Status:          Hardware not present

                              [02]: Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)

                                    Connection Name: Local Area Connection

                                    DHCP Enabled:    Yes

                                    DHCP Server:

                                    IP address(es)


                                    [02]: fe80::751a:1bff:6ee5:4bd9

    Windows IP Configuration

      Host Name . . . . . . . . . . . . : AW

      Primary Dns Suffix  . . . . . . . :

      Node Type . . . . . . . . . . . . : Hybrid

      IP Routing Enabled. . . . . . . . : No

      WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

      Connection-specific DNS Suffix  . :

      Description . . . . . . . . . . . : Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)

      Physical Address. . . . . . . . . : D4-BE-D9-10-CD-4E

      DHCP Enabled. . . . . . . . . . . : Yes

      Autoconfiguration Enabled . . . . : Yes

      Link-local IPv6 Address . . . . . : fe80::751a:1bff:6ee5:4bd9%15(Preferred)

      IPv4 Address. . . . . . . . . . . :

      Subnet Mask . . . . . . . . . . . :

      Lease Obtained. . . . . . . . . . : Tuesday, October 30, 2012 11:10:14 PM

      Lease Expires . . . . . . . . . . : Wednesday, October 31, 2012 11:10:14 PM

      Default Gateway . . . . . . . . . :

      DHCP Server . . . . . . . . . . . :

      DHCPv6 IAID . . . . . . . . . . . : 416595673

      DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-1D-8B-4E-E4-D5-3D-38-28-AB

      DNS Servers . . . . . . . . . . . :


      NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{60E37F50-D850-4CBF-940A-18185BAF33F1}:

      Media State . . . . . . . . . . . : Media disconnected

      Connection-specific DNS Suffix  . :

      Description . . . . . . . . . . . : Microsoft ISATAP Adapter

      Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

      DHCP Enabled. . . . . . . . . . . : No

      Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

      Media State . . . . . . . . . . . : Media disconnected

      Connection-specific DNS Suffix  . :

      Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

      Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

      DHCP Enabled. . . . . . . . . . . : No

      Autoconfiguration Enabled . . . . : Yes

  • Slate001,


    Start, all programs, accessories, command prompt. Type

    ping google.com

    Hit enter you should be able to see the results with no packets lost. You can also ping any website you want, as long as they don't have it setup for no ping.


    A wired connection is always faster than a wired connection.


    I see you have the...

    Killer Wireless-N 1103 Network Adapter

    Connection Name: Wireless Network Connection

    Status:          Hardware not present


    Not sure what the hardware not present means. When you installed the operating system on 4/16/2012, 2:40:04 AM, was this when you first started the computer or reinstalled the operating system?

    Did you check these places to see if your Connection is enabled?


    Go to Drivers & Downloads enter your service tag number, then select your operating system. Under Network, download and install the latest drivers.

    Try these tweaks....

    Start, control panel, device manager. Click on Network and then right click on your wireless adapter, left click properties, power management. Uncheck the box, allow computer to turn off this device to save power. I would also do this for your Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)


    Go to the power options, and changed the Wireless Adapter Setting, from Maximum Power Setting to Maximum Performance.





    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • "Hardware not present" means its disabled because my laptops has two NICs  there no need for me to have the wireless card on while I'm plugged into Ethernet so I disable it manuelly.

    Pinging a site comes back normal. A few pings will not show what I'm experencing while playing games or the iPhone video chat lag. This problem does not happen continuously, it's intermediate. Sometimes it's every 2-5mins sometimes longer.

    When pinging google infinitely the majority of pings come back at a normal latency. Occasitionally the ping fails but the next ping is successful again.

    When the test was ran my power settings was already on everything max performance because this is how I always game.

  • Slate001,


    You can also try...


    ping google.com -t -l 5000


    Change the value to 1000, 15000 or any hight quality. This puts a request for more load and you'll see more timeouts.


    I was helping a manufacturer and I used 1000 as the value while playing a video.


    The clue is it's happening with different systems. Take your iPhone to another location and see if get the lag. I still suspect your ISP. In your router, look at my Recommended Wireless Router SettingsI use channel 11, these items may help.

    Please turn off the firewall in the wireless router.

    Some adapters do not like WPS and may need to be turned off.





    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • So i tried to ping Google with 1000 bytes and it went through, I tried pinging with 1500 bytes and it failed every time.

    I was curious so I pinged with different amount of bytes until I found where it was failing. Turns out, anything higher than 1442 will always time out. I also tried this on 2 other PCs

    I also optimized my router with the settings on the sticky and what you recommended. Problem persists as expected.

    What does only being able to ping with less than 1443 bytes mean exactly? Obviously a ISP issue.

    Later tonight when the network is not being used by anyone else but myself Im going to connect directly to the modem and ping again just to prove again that the router is not bottle-necking the connections.

  • Slate001,


    There are times I can ping google without time outs and sometimes the same will time out. I have tried 2200 bytes and no time outs.


    If you get timeouts, then there is usually some type of packet loss.




    C:\Users\PudgyOne\Desktop>ping google.com -t -l 2200

    Pinging google.com [] with 2200 bytes of data:
    Reply from bytes=2200 time=62ms TTL=51
    Reply from bytes=2200 time=73ms TTL=51
    Reply from bytes=2200 time=98ms TTL=51
    Reply from bytes=2200 time=124ms TTL=51
    Reply from bytes=2200 time=135ms TTL=51
    Reply from bytes=2200 time=59ms TTL=51
    Reply from bytes=2200 time=83ms TTL=51
    Reply from bytes=2200 time=109ms TTL=51
    Reply from bytes=2200 time=119ms TTL=51
    Reply from bytes=2200 time=42ms TTL=51
    Reply from bytes=2200 time=68ms TTL=51
    Reply from bytes=2200 time=93ms TTL=51
    Reply from bytes=2200 time=32ms TTL=51
    Reply from bytes=2200 time=114ms TTL=51
    Reply from bytes=2200 time=37ms TTL=51
    Reply from bytes=2200 time=63ms TTL=51
    Reply from bytes=2200 time=74ms TTL=51
    Reply from bytes=2200 time=52ms TTL=51
    Reply from bytes=2200 time=124ms TTL=51
    Reply from bytes=2200 time=133ms TTL=51
    Reply from bytes=2200 time=159ms TTL=51
    Reply from bytes=2200 time=82ms TTL=51
    Reply from bytes=2200 time=110ms TTL=51
    Reply from bytes=2200 time=120ms TTL=51
    Reply from bytes=2200 time=41ms TTL=51
    Reply from bytes=2200 time=67ms TTL=51
    Reply from bytes=2200 time=93ms TTL=51
    Reply from bytes=2200 time=103ms TTL=51
    Reply from bytes=2200 time=128ms TTL=51
    Reply from bytes=2200 time=52ms TTL=51
    Reply from bytes=2200 time=77ms TTL=51
    Reply from bytes=2200 time=86ms TTL=51


    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • So on a normal basis I'm getting packet lost mostly anything over 1500 bytes the request times out every time.

    EARLY morning hours (at least for the last two days)  

    I can ping anywhere with insane amount of bytes and have no packet lost whatsoever.

    Tomorrow the tech from my cable company is suppose to come out and replace the modem. I will mention this to him. If the new modem does not fix the issue. I am assuming something is wrong with the node or maybe a bad line going to someones modem who turns off their modem late at night?

    Hopefully I will get an answer and solution tomorrow.

    Something to note. My sister was over and playing a MMO on her computer at the same time tonight (both of us connected to Ethernet, playing different games tho) When a lag spike happened it happened on BOTH machines. This is solid proof that either the router (doubtful) or the modem/ISP is the issue.

    Thanks for all your help Rick.


    PS I will post tonight after the tech has come and let everyone interested in my case know what he believes is the verdict.

  • Slate,


    Please keep me posted. I had issues at my old residence and it was a bad wire coming in to thye home. The squirrels had the wire worn through.





    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • WELL after a hour long of insisting to the on site tech that there was packet lose problem he finally got a supervisor to approve the node being checked for over saturation.

    The tech wanted to leave and keep claiming there was NO issue even after I pinged google with only 5000 bytes for him to show the packet lost.

    He had to call his supervisor, who according to him "had never seen this problem before and didnt know what to do."

    These are suppose to be professionals. This is ridiculous.

    He didnt even change the modem which I had expected him to at least try, but instead kept claiming that the modem was not the problem (which may be true.)

    Hopefully they find and fix something at the node. If the problem is not fixed by Monday I guess will have to call the supervisor myself and check on the workorder.