Dell Inspiron 5520 laptop unable to connect to internet via Wifi

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Dell Inspiron 5520 laptop unable to connect to internet via Wifi

This question is answered

I bought Dell Inspiron 5520 two weeks ago in Dubai, UAE. 

My Internet was working fine first couple of days but since past 4 days I am not able to connect to internet via Wifi (however there are other laptops i.e. HP and Dell) that are able to use the same Wifi to connect to internet but my brand new Dell us not able. 

Can anyone please help me? I am not quite techie, only understand very basics of this whole laptop (hardware and softwares etc) 

I have Windows 7 and McAfee pre-installed. 

Verified Answer
  • Hi OptimisticSimplicity,

    This could be because of a security update; the DNS (Domain Name System) settings may be corrupted. As the system was able to connect to the internet 4 days ago, you can try to run a ‘System restore’ to a known good date when the internet was last working and then perform the Windows update and the MacAfee update. Please use the link below, which explains how to perform a system restore in Windows 7.

    http://windows.microsoft.com/en-CA/windows7/products/features/system-restore

    For your information, System restore will not delete any personal data; however it will delete any programs, windows updates or any other updates that took place recently. For example, if you are selecting the restore point to be the 15th of August, any programs installed to date after the 15th will be removed.

    • Once the system restore is complete, please check the internet connectivity.
    • Please do run Windows 7 updates and MacAfee updates.
    • To update McAfee please right click on the icon and select ‘Update’ option.
    • In case you would like to update the Windows 7 as well please use the link provided below.

    http://windows.microsoft.com/is-IS/windows7/Install-Windows-updates

    I hope this helps. Please do write back in case you need any further assistance on the same.

    Thanks & Regards

    Swapnajan MC

    #iworkfordell

    Thanks and regards,
    Swapnajan MC
    #iworkfordell

All Replies
  • OMG I am having the exact same issue, I only bought my laptop 2 weeks ago (around 5th August 2012 in Dubai, UAE) and I was able to connect to wifi and use internet until few only 4 or 5 days back it stopped working.  It is connected with the wireless router, but not to the internet.  There are other computers in the wireless network that have no problem connecting to the internet, so I know my router and DSL modem are functioning properly.  When I run diagnostic (troubleshoot) it says Problem Found: "The DNS server isn't responding" I dont know what it means?

    In "Network and Sharing Center" at the left bottom there are few options, I clicked on "Intel PROSet/Wireless Tools, a pop up windows opens and it has a "Diagnostics" section, there are few options, I clicked on Diagnostic and there is another pop window opens "Manual Diagnostic Tool" and it says "run tests" which i clicked and here are the results:

    Hardware Test                Pass    Wireless Hardware is enabled

    Driver Test                       Pass     Driver is loaded. Net wNs64 Version 15.0.0.75

    Radio Test                       Pass     Radio is ON

    Scan Test                        Pass      There are 5 networks available to connect

    Association Test            Pass       Associated

    Authentication Test        Pass       Authenticated

    Signal Test                      Pass       Signal Quality: Excellent

    Ping Test                         Failed       No Response: default gateway, DHCP server

    I have windows 7 and McAfee pre-Installed.  please can you help me?

  • Hi OptimisticSimplicity,

    This could be because of a security update; the DNS (Domain Name System) settings may be corrupted. As the system was able to connect to the internet 4 days ago, you can try to run a ‘System restore’ to a known good date when the internet was last working and then perform the Windows update and the MacAfee update. Please use the link below, which explains how to perform a system restore in Windows 7.

    http://windows.microsoft.com/en-CA/windows7/products/features/system-restore

    For your information, System restore will not delete any personal data; however it will delete any programs, windows updates or any other updates that took place recently. For example, if you are selecting the restore point to be the 15th of August, any programs installed to date after the 15th will be removed.

    • Once the system restore is complete, please check the internet connectivity.
    • Please do run Windows 7 updates and MacAfee updates.
    • To update McAfee please right click on the icon and select ‘Update’ option.
    • In case you would like to update the Windows 7 as well please use the link provided below.

    http://windows.microsoft.com/is-IS/windows7/Install-Windows-updates

    I hope this helps. Please do write back in case you need any further assistance on the same.

    Thanks & Regards

    Swapnajan MC

    #iworkfordell

    Thanks and regards,
    Swapnajan MC
    #iworkfordell

  • Hi Swapnajan MC!

    Thanks for the valued information and feed back. I did try the step you told me i.e. system restore. to a automatic restore point something and a  recommended date (recommended in that box that appeared in system restore) it was August 19, 2012. and after restarting my laptop the internet has started to work (via wifi since i only tried wifi so far) and I am really happy about it. And really really appreciate your help.

    I now just have updated McAfee as you mentioned and now will be updating windows 7 too in a minute. and I hope after these updates my internet will continue to work :)

    Thanks again

  • Hi OptimisticSimplicity,


    Thank you for your reply and the update. I am glad that you were able to follow the steps and fix the issue. Please feel free to reply in case you have any further questions.



    Thanks & Regards
    Swapnajan MC
    #iworkfordell

    Thanks and regards,
    Swapnajan MC
    #iworkfordell

  • Hi,

    (From Qatar My laptop is inspiron 5520 new one just one month old)

    Please I have similar problem like that ( my wireless is working but in very closed distance to the connection point, if I change the site to about 5 or 6 metter from

    the connection site, the Internet become interrupted, can you help me please !

    note: I did system restore and update for MecAFee

    Thank you

  • Hi alboss2005,

    Updating the latest drivers may fix this issue. Please update the wireless card drivers by visiting the following link:

    http://dell.to/TvHqK6

    On the website, click on “Network.” Select the appropriate network card, download and install the driver.  If you face the same issue again, please follow the steps provided below.

    Click ‘Start’>> Type ‘Device Manager’ in the ‘Start Search’ >> Expand the ‘Network Adapters’ in the ‘Device Manager’ >> Right click on the ‘Wireless Network Adapter’ >> Click on ‘Properties’>>’Advanced’ >> ‘Roaming Aggressiveness’ and select the value to "Highest." Click “OK.”

    If you need further assistance, please reply to this message.

    Thanks and Regards,
    Rajath N
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • Exact same problem ! I need to be no further than 6m away from access point to connect .. meanwhile even older laptops have no issues ! help please ??

  • Thank you Rajath,

    I did as you mention and also I removed Meccaf. from the system at all, it become more better but still not like any other laptop even my very old laptop !

    any thing else  I can do ?? thanks again

  • Hi guys. sounds like we're all having the same issue.

    Have only DELL machines in the office and only having trouble finding decent wireless connectivity with the two 5520s I purchased recently. The rest work fine.

    I virtually have to be on top of a wireless AP to connect with them.

    here is an image of DELL inspiron 5520 (left) running next to older DELL inspiron 5110 (right). both machines running the same version of Metageek inssider to monitor wireless strength at the same location. (approx. 12m from wireless AP).

    5110 (right) shows full signal on wireless icon and -50dBm on inssider while 5520 shows one or two bars on the wireless icon and -80dBm on inssider (and does not pick up the second wireless AP at all).

    .

    Have tried all suggestions above and contacted DELL support. they will be sending out an engineer to investigate.

    will keep all posted.

  • Thanks for the updates globalgroups, hoping for good news !

  • dear gent's

     

    i have new laptop dell 5520 the wifi for network is cutting after 10 menutes and give me massege the access limited and i  returned back to conecting and after 10 menutes the wifi cutting but when conecting the modem cable the internet working probably

     

    please help to desolve this problem

     

  • I got a dell 5520 with Windows 8 preloaded on it and I have the exact same problem.  I can fix it by right clicking the WiFi icon in the lower right hand part of the screen, can clicking "Troubleshoot Problems" and it fixes it for another 10 minutes, but then it just happens again...this is getting annoying, I bet it's Windows 8 driver incompatibility issues.

    Anyone find a fix for this that works permanently?

  • Update on the ongoing problem with 5520:

    It sounds like I am experiencing a slightly different problem than perfect_prognosis - just permanently poor signal despite updates/ driver changes /dell helpdesk fiddling etc.

    DELL sent out an engineer (after taking 2 weeks to source replacement wireless cards). The DELL wireless cards were replaced with intel cards (according to engineer the same card running on the 5110 in the picture above) - with no improvement.

    Engineer suspected that the 5520 wireless aerial (located behind the screen) is poor/defective. unfortunately, there are no spare parts in my part of the world to fix this within the next month or so...

    I am now making arrangements with DELL to send the machines back for a refund.

  • I have the same problem bro. The first day i bought this computer i couldnt connect to the internet through wifi, Contacted dell support, i hope they will solve this problem

  • I am also having the same problem but it didn't work for me, now i have completely erased windows 7 and installed windows 8 but the problem still persists.

    thanks