Dell / Atheros DW1525 network card - intermittent connection with wireless router

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Dell / Atheros DW1525 network card - intermittent connection with wireless router

This question is not answered

Brief synopsis - don't set your wireless router to not broadcast your network name, the DW1525 router or its software will not connect reliably to your network, even though your network, with its hidden name,  appears in the list of available networks.

For the benefit of others who might encounter similar problems, I want to share my learning from many hours over the past 2 weeks on the phone to Dell support, and on my own,  trying to figure out why my 10-month new Inspiron 580S compact desktop, equiped with the DW1525  PCle wirlesss network card, has recently been making a wireless connection only about 50% of the time after booting up the computer ( 580S  - Intel Core i3-550 CPU with Windows 7 Home Premium  64-bit and ordinary software; MS Office suite, Adobe Photoshop and Illustrator ).

My home wireless network is broadcasted from a Netgear  WNDR 3700 dual band ( 2.4 GHz - 802.11 b/g/n compliant &  5 GHz 802.11 a/n compliant ) router / wireless hub. This unit is rock solid, strong  signal throughout the house,  and no connectivity problems with many other wireless devices in our home, including a Toshiba laptop, a  Dell Inspiron 1525 laptop that I bring home frequently from work, relatives' Apple computers, etc.... The router is set up to broadcast its 2.4 GHz signal with WPA2 - PSK encryption, and as an added security feature, was set to not broadcasting my network name. Also of note, the router is too far away ( ~ 25 ft & downstairs ) from the Inspiron 580 to run a wired Ethernet connection.

I've had this Dell Inspiron 580 for about 10 months now, and for about the first 8 months it connected to our wireless network without any problems. However, in the past 2 months when booting up the computer, which has our network name and WPA2 - PSK  encryption password set up as the default automatic wireless network connection, it  frequently failed to make a connection to our network, even though the our home network appears both available and has a strong signal in the  available networks list on the pop-up from the wireless signal icon on the  right side of the Win 7 bottom tray.

With our home network set as default for automatic connection, the computer would continue to try to connect about every 2 minutes, sometimes it would connect in 15 minutes, sometimes in an hour, sometimes not at all.  Once a connection was made, it would perform well, good data transmission,  not dropping the connection. Turn the computer off, and re-boot, and it was a gamble if it would connect.

I started out troubleshooting this by downloading the latest driver for the network card, no improvement. I called Dell Support and explained the problem, answered a lot of questions pointing the problem towards the Netgear wireless router, signal interference from the cordless phones, or microwave, and eventually got Dell Hardware Tech support to make a remote connection ( when the wireless was connected ), reloaded the latest driver, re-booted and no connection, and was passed to the Software Support department, under the pronouncement that the hardware ( the wirless card ) was fully functional, and that the inability to connect was a software problem.

Once connected to  Software tech support, I was informed that my warranty did not cover any software trouble-shooting, I would need to pay a $129 charge, and my problems would be fixed. Being a little computer-savvy, I said no thank you and good-bye to Dell Support, and turned to a Google search of wireless connectivity problems, which led to resetting the  Winsock catalogue in Win 7, a group of files used for network control - did that, but no improvement.

Next I tried connecting to an unsecured wireless network available from the surrounding neighbourhood - the connection was made without problems. Not wanting any security risks on an unknown network, I quickly disconnected, but realized I had the clue to the problem. I went to computer hard-wired to the router, and changed its setting, allowing it to broadcast my network name.

Back to the Inspiron 580, re-booted it, and bingo, it connected to my wirless network flawlessly. After 4 additional re-boots, it's re-connected every time, making me confident I've found the problem :

   The DW1525 doesn't manage "un-named" networks very well.I had 8 months of no problems likely because there was no other un-named network broadcasting in my area. But now there are two "un-named" networks in the list, and with my previously un-named network making a total of three, the DW1525 wasn't able to find the correct anonymous network.

Hope this helps someone else out there having intermittent wirless network connection issues...

 

All Replies
  • I should have made it clear - it was only the DW1525 or its driver that had problems with my network not broadcasting its name, all the other computers ( Toshiba laptop / Dell laptop / Macs )  in my home had no problems with this - so Dell or Atheros need to correct this and update the driver.

    BTW, now that my network is broadcasting its name, the DW1525 is connecting 100% - problem solved !