Intel® Centrino® Wireless-N 1030 and slow internet connection - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

Intel® Centrino® Wireless-N 1030 and slow internet connection

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Intel® Centrino® Wireless-N 1030 and slow internet connection

This question has been answered by 1mak


I've just purchased a new Dell laptop from Currys (Dell Insprion Q15R, which has the follwing spec;

The issue I have is regarding wireless connection to my Virgin Media Super Hub. When I hard-wire the laptop into the router, I am getting approx 30mbs down and 3mbs up. When I connect wirelessly however, that drops to about 0.17mbs down and 0.2 up. I have made sure that the wireless adapter drivers are up to date so I rang a local IT company who had to change the 802.11 mode: from 300mbs to 54mbs on the hub before I could get a decent internet connect (about 20mbs down and 2mbs up).

Currys then called me to check I was happy with my purchase and I explained the above, their KnowHow staff member then came on the line to discuss ways of problem fixing the issue. Firstly he uninstalled the driver, downloaded the driver form the Dell support site and installed it. We then went into power management and made sure that the computer wouldn't reduce power to the card when running on battery.This however didn't fix the problem as when I turned my hub back to 300mbs my internet speed crashed back down to the figures above.

The KnowHow staff member suggested that there may be an issue with this particular network adapter and Windows 7 and explained that he couldn't fix the problem.

I know that if I use my laptop in the house only, I could change the hub settings, but I'm obviously concerned that if I take it elsewhere, I would have paid £700 for dial-up internet speed laptop!

If I can get a solution/fix for the issue, that would be beneficial as I would like to keep the laptop but otherwise I'll have to get a refund.

If anyone has any ideas/suggestions, i would appreciate it.

Many thanks in advance,

Verified Answer
All Replies
  • I have exactly the same problem.  I purchased an Inspiron 15R directly from Dell.  It comes with the Intel Centrino 1030 card.  It works fine in Wireless G mode but switch to Wireless N mode though and the download speed is terrible.  Upload seems to be better.  The Dell engineer came out and installed a new 1030 card but the problem persists.

    I too use the Virgin Media Super Hub but this worls flawlessly with 2 other PCs.  I have not yet managed to try the Inspiron with another Wireless N router elsewhere.

    All drivers are the most recent.  I use Windows 7 64-bit.  For the time being I am using the Wireless in G model only and will soon recontact Dell.  I suspect wither an Intel 1030 driver issue or an incompatibility with the Virgin Media router.  The latter can be checked when I can test with another Wireless N router.


  • deleted...

  • Hey I came by this thread because I am experiencing the same issue with the Intel Centrino Wireless-N 1030 Wifi adapter but with a HP DV6-6100 Series laptop and my new BroadBand Cisco Modem/Wireless Router. I Understand that the 2 products are completely different but the symptoms you explain fit my problem exactly for both of these posts.

    Now I havent fully fixed the problem but in my case i have discovered the root of my problem and found some thing that might work for you 2 as well...

    In my last attempt to get it to work before i just gave up, I decided to go into device manager and disable the bluetooth device completely on the Intel Centrino Wireless-N 1030 and volia! More than acceptible speeds right away! Solid 48.6Mbs eveytime. Solid connection and super fast.. I went back to device manager and re enabled the bluetooth and slow slow slow..... Problem came right back! .3 Mbs

    Now I relize that this is definatly not a full fix but if you are not ever going to use bluetooth then this might be all the fix you need. As for me this sucks cause i like using the bluetooth for my razr bluetooth mouse but turning on the Intel Centrino Wireless-N 1030 bluetooth cripples the Wireless N mode to unusable wifi speed of .3Mbs!

    And I Just got off the phone with HP and they have advised me that there is nothing wrong with my Wifi card.

    The rep stated that because the Intel Centrino Wireless-N 1030 is a 2in1 bluetooth/Wireless Card that the speed is limited when using both bluetooth and Wireless N at the same time.

    I asked then why did my bluetooth and older 25 mb connection Wireless N router/modem work together fine? He stated that because i am trying to now use it on a high power broadband 50mb connection Wireless N router/modem and that the little 2in1 isnt powerfull enough to handle the 50 mb speeds and bluetooth together at the same time and is why it is causing problems.

    So thats as far as Ive been able to get.. And have posted a discussion on the intel support forums hoping to get some other in site as to why when bluetooth is enabled in the device manager does it cripple the wifi card on a high bandwith router/modems or is it some setting in the bluetooth i am missing...

    So try and disable Bluetooth in the device manager and see if it fixes your Wireless N speed issues as it did for me. :) You will need to disable bluetooth completely even if you dont have anything connected to it or are not even using the bluetooth. Because if the device is enabled, it causes the problem even if you are not even using it....

    Ne ways please let me know if this fixes you problem as well. Hope it does :)

  • Thanks for the suggestion.  I tried this, disabling the 2 places in Device Manager where Bluetooth appears.  However, in my case the Wireless N problems remain.  I also note from some other searches I did that there have been similar issues reported with the Centrino 6230 card.  My present thinking is that it is an incompatibility of some routers with these cards.

  • My son just recently had a similar problem. When he connected using an ethernet cable, speed was OK. When he connected to the router at school (type??) with wireless (Centrino 1030), his web pages loaded extremely slow. We removed Internet Security software (McAfee) and disabled Bluetooth.... no help. What fixed it for him was to enable his Wi-Fi devices (which are virtual devices derived from the wireless 1030 card).

  • I was also having issues with my wireless connections. Only thing that worked for me was going in to the advanced power saving options and selecting maximum performance for wireless adapter when on battery. Appears to have resolved my problems.

    Hope this helps

  • Hello,

    I have recently purchased a XPS L702x which came with the N 6230 wireless network card and have the same issue connecting to my Virgin Media SuperHub.

    The only solution that is working for me is to disable N mode in the adapter settings and make a few changes in the router which as mentioned above post caps @ 20MB which does not help people like me who have just paid to upgrade to the 30/50MB services.

    None of the suggestions about disabling Bluetooth helped in my case but it may work for you :)

    - Right click my computer and open properties

    - Device Manager

    -  Network Adapters 

    - Right click on the Intel Advanced N 6230

    - Advanced tab

    - Highlight  802 11n Mode and change to disabled and press ok

    - Close to desktop and the wireless connection will reconnect 

    - Open web browser and go to

    - Enter you username and password for the router which if you have not changed is Admin and changeme

    - Click advanced settings link at bottom 

    - Untick Firewall and IP Flood Detection

    - Save and close

    - You should now have a stable connection

    If this is the only device you connect to your Virgin SuperHub via wireless and or all other devices support 5GHZ wireless N then you can get full speed and do not need to disable wireless N in device manager.

    - Open web browser and go to

    - Enter you username and password for the router which if you have not changed is Admin and changeme

    - Click on Wireless settings box

    - Move from 2.4 Ghz to 5 Ghz and save

    - Click advanced settings link at bottom 

    - Untick Firewall and IP Flood Detection

    - Save and close

    - You should now have a stable connection at you full max connection rate.

    Please can anyone post a reply if they can connect to their SuperHub using an Intel N 6230 wireless card with N mode enabled.

    I hope the steps above help for now!

  • bought the exact same laptop as you with the same router and the EXACT same problem

    The disabling the bluetooth devices worked a treat for me, (never use bluetooth so no issue for me)

    Just make sure you disable them all, theres like 6 dotted around device manager

    I like how dell dont seem phased about this issue at all, typical dell for me ha

    just a heads up on what worked for me :) (Dell get your act together! test your products...)

  • All the items discussed in this thread sound exactly what I am experience.  I just bought a XPS 15 with a 6230 Intel card.  Internet speeds seem to be fine with loading pages, but my problem is with streaming videos.  There is excessive buffering when streaming videos.  Have the rest of you experieced this as well.  I have updated all drivers and have set the power settings to maximum performance.  I have disabled 2 of the bluetooth items but it sounds like there may be more that I should locate an disable.  I have not turned of the N mode for my router but will try. 

    Just looking for a sanity check to make sure I'm trying the right things.  Any other recommendations would be greatly appreciated.  Thanks

  • I have a brand new Vostro V131 with the same card.  Nothing here is working for me.  Wishing i opted for the dell card.  I am def looking to get this card swapped out.

  • Hi guys,

    I have a Dell Inspiron N5110 with the Intel 1030 wireless card, and exactly the same issue. I also disabled Bluetooth and changed the power settings of the wireless card in the Power Options. Worked like a charm, and resolved my problem.

    Of course Dell needs to come up with a proper solution, but for now this is a valid workaround for me, as I don't use Bluetooth on that notebook.

  • I am going to recap my experience with this slow wireless access problem.  I recently purchased 3 Vostro 3550 laptops.  Two units had the Intel Centrino N-1030 wireless N plus Bluetooth (BT) adapter while the third unit had the Dell 1510 wireless N adapter with no BT.  I experienced slow access with the N-1030 units on battery power and with Balanced Power saving mode.  This problem does not occur on AC power or with direct Ethernet connection.  Changing the power mode to High Performance solved the problem but sacrificed battery run time.  Disabling BT did not solve the slow access for me.  I could also disable wireless N and run on G with no problems.  Even my old USB wireless G adapter ran well after disabling the N-1030. 

    Meanwhile, the laptop with the Dell 1510 had no such Internet access problems.  So I called Dell Tech Support and it was decided to replace the N-1030 with a Dell 1702.  A service tech replaced the wireless card and after loading the Dell device drivers "R312222", the slow access problem went away.  FYI, when I ran the test at with the 1702 versus the 1510 side-by-side, the 1702 had 15ms Ping, 18.09mbps Download speed and 1.03mbps Upload speed while the 1510 tested 25ms Ping, 27.83 Down and 1.03 Up speeds. 

    So I solved my problem by swapping to the 1702 card.  However, while researching this problem I came across a post in a Dell Forum directing me to an article on the Intel website about problems with the Centrino N-1030 adapter with routers that improperly implemented Power Saving Polling (PSP).  This seems to make sense since not all N-1030 users appear to be affected.  I have the D-Link Xtreme N Gigabit Router (DIR-655, hardware version B1).  I called to ask D-Link if they supported PSP.  D-Link had me upgrade my firmware to the latest Version 2.3 and make manual changes to the router settings but with no success.  They finally admitted that PSP was not in the specs for the DIR-655.  

    I'm guessing here that the slow Internet access is router specific.  I called Intel Tech Support.  They are obviously aware of the problem but do not have a list of routers that have this conflict with their N-1030 wireless adapter.  (This might have implications for similar problems with the Centrino 6230 card.)   I managed to test one of my Vostro units with the N-1030 card with a Actiontec MI424WR router with no problems using the N band.  So I'm not sure if Dell or the router manufacturer is to blame for this problem.  I should not have to buy a new "working" router and while there are workarounds, it does not solve the problem.  Intel even states an optional workaround is to manually put the Wi-Fi adapter into continuously aware mode (CAM).  This disables the PSP feature.  Kind of a "sneaky" way to solve the slow access but at the expense of your battery life.  I'm guessing again here that there should be a driver fix for this. 

    Anyway, I hope this helps.  Dell Tech Support has actually been pretty good about replacing the parts under warranty.  However, the process is time consuming.

  • I had the same issue and had 2 card replacements under warranty as well as the LCD cover replaced (antennas). Nothing helped... UNTIL

    -- I totally removed the drivers and Intel software using an uninstall program that scanend for left over pieces

    -- installed the software for the next card up (6200 I think)

    -- went into the newly available Frequency dropdown under device properties > Configure > Advanced

    -- I selected auto  under Frequency (first setting) and It would begin to connect @ 300 where prior connections were starting at around 65 mbps.

    It unfortunately didn't stay at 300 and predictably dropped to 130/145 only 20' line-of-sight from the router (A DIR-655). I finally gave up and ordered an Ultimate N 6300 which doesn't have Bluetooth, but I'm SOLIDLY locked in @ 300 and it now meets my wireless needs.

    I have to say that Dell did a pretty good job of trying to fix the problem by calling for follow ups, sending techs and replacement cards next day to replace hardware. Unfortunately the 1030 is *not good hardware* in my opinion. Just be patient and polite with the first attempts while they remote in and switch your settings back & forth for 2 hours. After that fails you can hopefully move on to replacement parts :)

  • I don't have a Dell computer, well not any more, and I wasn't a member of this community, but I had to join in order to report that there really is a very simply solution (well it worked in my case) to the issues with slow wireless connection speeds for computers with the N 1030 wireless router built in.

    I recently bought a Fujitsu AH531 i3 laptop hoping that it would be faster than my 5 year old dual core HP seeing as we've just got 30mbs broadband at home. I was very disappointed to find that although the laptop purported to have a n-router (which my old HP didn't have so I had to use an external dongle in order to get a good connection speed) it was only getting 1-4mbs speeds and would often freeze when I was speed testing it suggesting that the signal was dropping out regularly. I read on numerous forums about people taking their laptops back to have the routers changed, updating or backdating or uninstalling and reinstalling drivers, but what I read on this forum about disabling the bluetooth worked instantly and it was quick and easy to do. I now get full speed broadband with far less fluctuation in the signal.

    So, before going down the more fiddly or invasive process of sending your laptop back, getting the support chaps in or playing with drivers, just go to your Control Panel, look up your Device Manager, then switch off your bluetooth and see if that works first. Good luck.

  • Hi, I'm also having similar trouble with wirelesses connectivity, I've tried every suggestion in the forum from disabling with bluetooth/changing the power plan to maximum and disabling the 'N-Mode', whatever that does. Mine's the Intel 1030 N card and my speed right now is a measly 36mbps. I've also tried updating the drivers but I have a feeling that if I did a complete wipe of all the driver updates and  then started from fresh it could solve the problem, can anyone guide me through how to try that first? Thanks.