Cant connect to internet via Ethernet!!! Please help. 1420 inspiron - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

Cant connect to internet via Ethernet!!! Please help. 1420 inspiron

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Cant connect to internet via Ethernet!!! Please help. 1420 inspiron

This question is not answered

So i just moved to japan and am desperate for the internet. My computer gets wifi perfectly and the internet works fine with a wifi connection.However, at school where I teach, they only have ethernet cables (land lines) and for some reason my computer wont pick up the internet with it! Heres the situation:

dell inspiron 1420

ethernet jack when plugged in shows red and blinking orange light

the device manager says, network adapters: broadcom 802.11 g network adapter  and  broadcom netlink (TM) fast ethernet

the little internet icon at the bottom right corner of my computer has a blue internet connection, but no little blue "world" (or sphere) that usually appears when i actually have internet connection. so its connected to the internet, it has the network that im connected to at school..its just not working properly.. somethings blocking it from actually working.

when i click the internet page, the webpage that shows up says: the server cant be found because the DNS lookup failed. This error is most often caused by having no connection to the internet or a misconfigured network. it can also be caused by an unresponsive DNS server or a firewall preventing google chrome from accessing the network.

please help! while i can get wifi at home, i need the internet at school to make lesson plans and such.. and it wont work with the cables they have! im not really sure if its due to that DNS problem or if theres something wrong with my ethernet jack.. and i dont know if i need to download any drivers or anything to get it working. let me know if anyone can think of a solution! i would totally call dell and have them help, but i dont have a phone yet to ask them! so please help me here! thanks in advance

All Replies
  • Hi Use the universal DNS The universal DNS has to be forced in LAN

    DNS Address


  • Hi so I changed the DNS to the one you gave me... the internet still isnt working.

    Im physically connected to the network, but im just not getting the internet.. so when i pull up the network and connections bar, its a green line from my computer to the network (a bunch of little computers icon), but a red X from the network to the physical internet.

    i clicked on the red X , and it diagnosed the problem to be: cannot communication with primary DNS server ( network diagnostics pinged the remote host but did not receive a response.

    Theres an option to reset the network adapter, LAN, and i tried that and it still isnt working.

    Anyone have any other suggestions??? would really appreciate it! anything helps. thanks!

  • jjoyw,


    Since you're in another Country, try going to start, control panel, regional settings and chage it to the Country you're in. I think I read somewhere that it might help with connecting in that Country.





    What is a Dell Service Tag and how do I locate it? 

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

    #DellWorld 2012

    #DellWorld 2015

    #DellEMCWorld 2016

    #MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

  • Hi Rick

    So I changed the country I'm in.... still no luck :( any other ideas?

  • hi

    try to change the link & duplex settings where you can find in LAN properties change value auto to 100 bit half duplex

  • still not working!