OptiPlex 360 WDS network card driver

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

OptiPlex 360 WDS network card driver

This question is not answered

Hello,

 

I have a problem using Windows Deployment Services (WDS) with DELL OptiPlex 360. Here what happens:

 

PROBLEM

 

·         I enter the BIOS and activate PXE-boot

·         I boot via PXE (F12)

·         Windows Boot Manager starts

·         Microsoft Windows Deployment Services chosen

·         Windows is loading files… (from the correct Server, Server-IP is shown)

·         Windows installer starts, instead of showing the images available it sais:

„WDS Client: An error occurred while starting networking. There was a failure while installing the network card driver for your machine…“

 

Windows Deployment Services are working with other images, so there is no problem with the service itself.

 

WDS-IMAGE FOLDERS

 

DELLOPTIPLEX360.WIM was created without error. I also created the folder DELLOPTIPLEX360 with the subfolders

·         $OEM$\$\Inf – Containing all the INF-Files (eg. k57win32.inf)

·         $OEM$\$1\sysprep – Containing the sysprep.inf and the subfolder DRIVERS

·         $OEM$\$1\sysprep\DRIVERS – Containing INF, CAT and SYS files of the Audio-, Chipset-, LAN-, Modem- and VGA-drivers (in subfolders)

 

WDS-IMAGE SYSPREP

 

Sysprep.inf contains the following information:

[Unattended]

    OemSkipEula=Yes

    InstallFilesPath = "\\<servername>\reminst\Images\Windows XP\DELLOPTIPLEX360\"

    DriverSigningPolicy=Ignore

    OemPnPDriversPath = "\DRIVERS;\DRIVERS\AUDIO;DRIVERS\CHIPSET;DRIVERS\LAN;DRIVERS\MODEM;DRIVERS\VGA"

    AutoActivate = "yes"

    TargetPath = \WINDOWS

    UnattendSwitch = "yes"

    WaitForReboot = "No"

    Repartition=Yes

    FileSystem=ConvertNTFS

    ;FileSystem = LeaveAlone

    ExtendOEMPartition = 0

 

WDS-IMAGE DRIVERS

 

As network-drivers, I use the following files:

k57win32.inf, k57win32.cat, k57xp32.sys

 

k57xp32.sys:

Description:           Broadcom NetLink (TM) Gigabit Ethernet NDIS5.1 Driver.

Version:  12.2.2.1 (cbuild.08042009-018,b57nd5x-main-lhdepot1106.CL-83027)

Company:               Broadcom Corporation

Product:  Broadcom NetLink (TM) Gigabit Ethernet Driver

 

K57win32.inf starts with:

;*******************************************************************************

; Copyright 2001-2009 Broadcom Corporation.

;

; INF for 32-bit Windows 2K, Windows XP and Windows server 2003.

;

; InfVersion   12.2.2.1

;

;*******************************************************************************

 

[Version]

Signature   = "$Windows NT$"

Class       = Net

ClassGUID   = {4d36e972-e325-11ce-bfc1-08002be10318}

CatalogFile = k57win32.cat

Compatible  = 1

Provider    = %BRCM%

DriverVer   = 08/04/2009,12.2.2.1

 

[Manufacturer]

%BRCM% = Broadcom, NTx86.5.1

 

 

Can someone help me with that? As I said, WDS is working with other hardware, so I just guess it has got to do with the driver. I tried the one from the DELL-support-website before (the site you reach by entering the service-tag), now I use the driver from the network-chip-manufacturer (broadcom). I really have no idea about how to solve this problem. So help would be appreciated.

 

A nice weekend to all of you,

Kaffeepause (means coffee break)

be nice

All Replies
  • Hi,

    OPTIPLEX 360 hardware doesn't support WINDOWS 2003 you may get error code 7 while start up of installation.

    if you manually try to install as well