Dell Mobile Broadband Card Utility & Windows 7 - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

Dell Mobile Broadband Card Utility & Windows 7

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Dell Mobile Broadband Card Utility & Windows 7

This question is not answered

Hi all,


I have a Dell Lattitude D630 and a built in 3G card. I have recently upgraded to Windows 7 Ultimate and the Mobile Card Utility refuses to start now. The spash screen pops up for about 20 seconds and then dissappears. The following is logged in the Event Viewer below.  Anyone have any wayto sort this?  I've also upgraded to the latest utility without any joy.  I have previously had the same issue with this utility with Vista Ultimate and the "Office Live Plug-in".

Log Name:      Application
Source:        Application Error
Date:          07/10/2009 12:52:47
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      laptop01.interfusion.local
Faulting application name: DMBCU.exe, version:, time stamp: 0x44733a1f
Faulting module name: DMBCU.exe, version:, time stamp: 0x44733a1f
Exception code: 0xc0000005
Fault offset: 0x00001bbe
Faulting process id: 0x12d0
Faulting application start time: 0x01ca4744aed1819b
Faulting application path: C:\Program Files\Dell\Dell Mobile Broadband\DMBCU.exe
Faulting module path: C:\Program Files\Dell\Dell Mobile Broadband\DMBCU.exe
Report Id: edcdae82-b337-11de-b154-001c2330ca87
Event Xml:
<Event xmlns="">
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <TimeCreated SystemTime="2009-10-07T11:52:47.000000000Z" />
    <Security />
    <Data>C:\Program Files\Dell\Dell Mobile Broadband\DMBCU.exe</Data>
    <Data>C:\Program Files\Dell\Dell Mobile Broadband\DMBCU.exe</Data>




All Replies
  • I am having the exact same issue on my Lattitude D820 with the Sprint Broadband minicard.  My error message is the same.  I have also already installed the latest utility drivers (5/09) to no avail.

    Dell needs to help on this one.

  • Yep, same thing here.  I have a Verizon wireless 5720 card installed in an xps 1330 and installed windows 7 and now the dell mobile broadband utility does not launch, just as in the first post.  Dell, where are you?

  • I had the same issue also. The splash screen would appear, the moving box in the splash screen would go back and forth for a long time, then it would disappear and nothing.

    Following the clue in the first post, I uninstalled the Office Live add-in using the usual Control Panel uninstall program feature. I believe this sometimes appears as an update via Microsoft Update. Anyway, I was skeptical but it fixed the problem! I might have need to do a restart.

    So, it appears there is some weird incompatibility between the latest Dell Mobile Broadband Card Utility and the Microsoft Office Live add-in. Hard to explain but uninstalling that add-in definitely fixed the problem for me.

  • Thank you.  This worked for me, but only temporarily.  It is doing the same thing again now though. 

  • I just got it to work finally.  I uninstalled all of Creative media's Soundblaster software and their auto-updater application.  It worked after this.  There must have also been a conflict with Creative Media. 

  • Same issue for me.

  • Anyone tried using the software provided by Sprint, T-mobile or whoever is your ISP? You aren't tied to Dell's software.

    my Dells:
    Optiplex 3020 - Windows 7 Pro 64-bit / Linux Mint
    Optiplex 3020 - Windows 7 Pro 64-bit

    Precision M6300 - Windows 10 Pro 64-bit

    Latitude D620 - XP Pro SP3

  • I removed Vista from my XPS m1730 about a year ago and did a fresh install of Win 7.  Everything worked fine until about a month ago.  Motherboard/video card/hard drive was all replaced.  When they sent me a new HD I had to put my Win7 back on it again (Dell shipped me Vista even though I purchased Win7 through them).


    I asked them to assist me in removing Vista and installing Win7.  The tech said "since this hard drive is brand new and vista doesn't have any errors, an upgrade will suffice".  I've had a time with it so far.  Took forever to install the latest driver for my video card.  Everything seemed to work but my Dell Wireless Card.  I have the 5720 EVDO.  It would go to the load screen for about 20 seconds then go away.  I've called Dell and the first guy fixed it'.  I guess after I later rebooted the system didn't recognize the card.  I called them back.  That tech troubleshot it and told me it wouldn't work with Win7.  I of course advised him it had worked for almost a year prior to my system crashing after almost 2 hours of no help I had to get off the phone.  Then Dell did a follow up call and I was told a senior tech would call me in two days.  It's been 9 days and no call.  


    Thanks to this thread I tried unistalling my World of Warcraft Soundblaster headphones, rebooted, and my card is working again.  I could have sworn I had the same software installed on my previous drive?  Must have been the fresh install to upgrade???? I dunno.  Regardless, thanks for figuring this out.

  • In the end I removed the Dell software and installed software from Verizon (available somewhere on the Verizon Wireless website). Much better in all ways, never have a problem since. This is assuming you use Verizon Wireless, of course.