device ownership password - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

device ownership password

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

device ownership password

  • Hi, there!


    I just moved in to a new place, where there is a wireless network available, but when I tried to join it, it requires me a "device ownership password", which is supposed to be displayed or printed on the device, but I just cannot find it. There's a lot of numbers on many different labels on the computer, but every time I enter one of them, appears a message that says "checksum validation failed for the pin entered". So, which is that number I'm supposed to submit? How can I identify it?


    Thanks a lot for your valuable help.

  • The administrator for the network you want to "join" should be providing you with what information they need and how to establish the password.  As different networks can require different things, there's no way for us to know what that network wants.

    I am not a Dell Employee

    Dell forum member since 2002

    Inspiron 15 - 5577 Laptop

    Home Built Desktop PC with ASUS Z170, i7 6700K CPU,  Windows 10 64 bit Pro. SSD drive.  Sonar Platinum Recordng Studio Software.

    Dell SE2717HR 27" Monitor


    Member of Nashville based R.O.P.E.

  • HI

    I am having a similar problem. Can some one share mote data on the posible solution?

    Please feel free to email me:   



    <Admin Note:Email removed per privacy policy>

  • I have experienced this with so many Dell laptops both in our office and out in the field.  The only solution we have found is to let Windows manage your wireless connection and turn off  Intel-Pro wireless management (remove IMO). We will never give out our device ownership password to our Wi-Fi clients.

    I am not sure if this is the correct fix but on 8 individual laptops it works and so far has been the only option that has.

    Hope this helps.

  • I haven't tried this myself yet, but according to this page the solution is to tweak the Intel wireless software in Add/Remove Programs so that "Unmarked Wifi Protected Setup" is selected.

    Have to say that this is really a ridiculous problem to have. How Intel think that an administrator is ever going to give out his password to a user just to connect to WAN? Bizarre.


  • It would be nice if you had posted a link to a free site. When you say that Wifi protected Setupo should be unmarked, do you mean uninstalled or installed. Because if not installed is has a red X trhoguh it, but if installed there is no X. I am having the same issue, but Wifi protected setup is installed by deault with the Intel Proset driver. I feel the problem is with Intel writing faulty and buggy drivers, and that teh Proset utlity should be disabled, as th eonly thing Intel does well are processors.

  • If you go to Control Panel, select "Remove/Change" on the Intel wireless, then select "Modify" and "Next" you'll then have access to the installed settings.  From here,  uninstall/unselect "Single Sing On" and WiFi Protection.  These will turn off the prompt.


    Hope it works for you.

  • Your solution fixed my problem... THANKS!  -  With my inspiron E1505 it's hard to believe the Intel ProWireless driver installs with Wifi Protected Setup on/configured in a way that causes the "Checksum validation failed for the PIN entered" error when trying to enter the router password.  Unmarking and removing the components easily fixed the issue.  Most of the answers when I googled searched for a solution said to give up on the Pro wireless card and go with the default Intel. Surprisingly it seem this is the only post on the dell forum with the answer.  Thanks Again!

  • Actually the process is like this: in order to join an existing wireless network, you shall first set up a profile and configure it in the Intel? PROSet/Wireless WiFi Connection Utility.

    Steps as below:
    1) click "Profiles..." -> click "Add..." to create WiFi Profile.
    2) input a name as you like in the "Profile Name" box.
    3) input the wireless network name(eg. SSID). click "Next..."
    4) input the password of the network to finish configuring.
    5) Click "Connect..." and it's DONE!!

    Most importantly, this way, you won't need to go through the annoying device ownership password thing. Isn't it fantastic? Somehow, it does confuse people about connecting in WiFi... What on earth is the designer thinking of...

  • Thanks, I had forgotten all about setting up the profile but I guess that's the purpose: set it up once and forget it. At least until you need to set up another one.


  • Thank you so much!

  • I just had this issue. Check the bottom of the router for a security PIN number and use that. It should work from there.
  • I've entered the PIN from the router which is the "device ownership password" my computer is asking for.  I selected the proper security type from the drop down menu which is WPA-(TKIP).  I keyed in the correct network password.  My computer goes through a configuration attempt for a minute or so and then comes the message,"failed to get the wireless settings" and "configuration failed".  Any other bright ideas?

    I also went into the Intel/PRO wireless settings and set up a profile as suggested by another poster here.  I went through the steps, entered the network password, clicked connect and.....nothing happened...except for an hourglass symbol which appeared for one second as if it were actually thinking about doing something and then changed its mind.  So, wasn't "fantastic" at all.  There is nothing wrong with my laptop as I can get online EVERYWHERE else I go that has WiFi.  It's this "device ownership password" rigamarole that now seems insurmountable.   I called Comcast/Xfinity and they are worse than clueless.  Their advice was to call their tech support team and have me pay $100 to have them tell me how to connect a laptop to my own home network!!!! 

  • Yes, this was the solution I needed which eliminates the "device ownership password" prompt.  My "Single sign on" was not checked but my WiFi protection was checked.  I unchecked it and now all I have to do is enter the network password to connect.  However, does this mean my computer is more vulnerable since I might not have WiFi protection?

  • Yes that is what I need to know now not next week please!!!!!!!!!!!!!!! help now. I need to know where and what the Device Ownership Passsword is. This is required for wi -- fi setup wizard.