Wireless Networking on a Dell Inspiron mini 9 (910) under Ubuntu - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

Wireless Networking on a Dell Inspiron mini 9 (910) under Ubuntu

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Wireless Networking on a Dell Inspiron mini 9 (910) under Ubuntu

This question has suggested answer(s)

I'm having a lot of trouble getting the wireless networking to connect to the Internet (I am a total Ubuntu novice, so please bear with me)

My connection does not show up on the wireless connection list, using the network manager icon, when I choose to connect to a different wireless network and enter the SSID and WPA password, it say it connects 100%, the 5 signal bars go blue, but theres no Internet connectivity as far as I can see it.

I opened a Terminal window and used the ifconfig command

it reports the following devices


eth0 and eth1 have two different MAC Addresses, but putting both in my routers access table, doesn't make much difference..

If I try to set up the connection manually (eth1 seems to be the one connected to the manual wireless connection setup), connection settings to Automatic DHCP, I still get no joy with the Internet.

From the ifconfig report eth1 seems to have an ever increasing number of TX packet errors

iwconfig gives me

lo : no wireless extensions
eth0: no wireless extensions
eth1: IEEE 802.11 Nickname "", Access Point: Not-Associated

ip addr gives me

lo <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue
eth0 <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
eth1 <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000

and on odd occasions I seem to get

eth1:avahi showing up, but I have no idea what this is.

Can anyone point me in the right direction when it comes to troubleshooting setting up a wireless connection on an Inspiron Mini 9, I have no idea what version of Ubuntu is on it, but some of the tools don't seem to work properly..

The nm-editor version 0.6.6 won't let me set up Wireless connections, I can type in the connection name, but it won't let me edit the BBSID field or any other field.

The Manual Connection Manager, doesn't seem to have an option to enable or disable roaming - which some forum posts have said to try..

Anyway, any help anyone can give would be most appreciated.

P.S. I'm not sure whether its Gnome or not.. apologies if I've catagorised the problem wrongly.

All Replies
  • Turns out the problem seems to be with the Wireless Channel. US only uses Channel range 1-11, whereas my router was set on Channel 13. So the network-manager app was only finding all my neighours connections and not mine. Switched it back to Channel 11 and it works fine now..

  • How did you get to the where you could change the SSID.

  • so far i cant get this mini to do anything but make me upset and no info on how to make it work or even how to get it to connect to internet or anything else. i must be really stupid. and dell doesnt do anything if you have ubuntu on it. so far am ready to return and bad mouth dell for no support


  • Finally got mine to connect to wireless just fine. After several attempts and cool-off periods (for myself!) The "strength bars icon" appeared at the top in the menubar. I previously could make the Bluetooth icon come and go with <Function><F2> but the wireless "strength bar" icon was no where to be seen! Ever. Last night on attempt 5 it appeared. I did nothing except turn it on as I had several times. I clicked on the "strength bar" icon and was presented with a dialog that showed the wireless could see my neighbor's wireless. I could not see mine as I do not broadcast the SSID. At this point I figured it must be "kinda" working as I could see the neighbor. I chose the manual config and entered my wireless config, SSID which they referred to as bsSSID or something like that, choose "WPA Personal" (I understand WPA but no clue as to what Personal indicates!) and my wireless password. Bam! Connected and it works throughout a VERY large house, even in the basement (decent radio on it I guess).

    The only thing I can think of that I did different on the suuccessful attempt was I had cleared out the network settings the prior attempt. Meaning that I manually bacspaced over everything like I had nothing. Then hours later I rebooted with the "strength bar" icon appearing.

  • I have had a 910 with Ubuntu for about 3 months.  It immediately connected to the home wireless network; worked beautifully for a week.  Then one day I turned it on and not only no connection, but the entire "wireless connection" setup was missing from view.  It only said 'wired' and 'dialup'.  It worked fine on wired, but a tad inconvenient for a portable machine.  I got nowhere trying the above options and found the Ubuntu CD was useless in recreating the ability to set up wireless.  I was joining the cursing crowd.

    However, yesterday when I turned on the computer, it connected to the wireless as if nothing was wrong.  I did nothing different than the twenty times before.  Any ideas if this is a perverse problem likely/unlikely to recur?