Dell Latitude D600 cannot connect to internet, but has a strong wireless signal - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

Dell Latitude D600 cannot connect to internet, but has a strong wireless signal

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Dell Latitude D600 cannot connect to internet, but has a strong wireless signal

  • My Dell Latitude D600 recently stopped accessing the internet, even though I have a strong wireless signal and connection.  I have had the laptop for 3 months now with no problems up to this point.  I have followed some of the troubleshooting suggestions from other posts, but to no avail.  My ipconfig looks like it should be right, and I can post that upon request.  The Intel Pro/wireless LAN 2100 3A Mini PCI Adapter status says it is working properly, and the drivers are up to date.  Any new thoughts or suggestions?


    Thanks in advance-



  • Please post the ipconfig command, as it may tell us what is going on.  Also, try booting to Safe Mode with Network Support and see if  you can connect to the internet.  Let us know the results of that troubleshooting step.



  • C:\Documents and Settings\user>ipconfig/all

    Windows IP Configuration

            Host Name . . . . . . . . . . . . : Home
            Primary Dns Suffix  . . . . . . . :
            Node Type . . . . . . . . . . . . : Unknown
            IP Routing Enabled. . . . . . . . : No
            WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

            Media State . . . . . . . . . . . : Media disconnected
            Description . . . . . . . . . . . : Broadcom 570x Gigabit Integrated Con
    troller #2
            Physical Address. . . . . . . . . : 00-11-43-39-3C-DA

    Ethernet adapter Wireless Network Connection:

            Connection-specific DNS Suffix  . :
            Description . . . . . . . . . . . : Intel(R) PRO/Wireless LAN 2100 3A Mi
    ni PCI Adapter
            Physical Address. . . . . . . . . : 00-0C-F1-59-67-02
            Dhcp Enabled. . . . . . . . . . . : Yes
            Autoconfiguration Enabled . . . . : Yes
            IP Address. . . . . . . . . . . . :
            Subnet Mask . . . . . . . . . . . :
            Default Gateway . . . . . . . . . :
            DHCP Server . . . . . . . . . . . :
            DNS Servers . . . . . . . . . . . :
            Lease Obtained. . . . . . . . . . : Wednesday, August 06, 2008 11:03:32
            Lease Expires . . . . . . . . . . : Thursday, August 07, 2008 11:03:32 A

  • I also tried to access through Safe Mode but it did not work.  Under Network Connections, there were no options.
  • Did you boot to Safe Mode with Network Support as I asked in my last post?



  • Yes, I booted in Safe Mode with Networking, my wireless network status is connected, but still no web access
  • Let's do some troubleshooting.  Go to Start > Run and type cmd to open a command prompt window.  In the command prompt window, type the following:


    ping then hit the Enter key.  What happens?


    then type the following:


    ping then hit the Enter key.  What happens?



  • Do you have Zone Alarm as your firewall ? There was a bulletin not long ago that stated that the new windows update  in XP would cause the zone alarm firewall to block all internet activity...need to turn down the settings to medium in order to connect to the internet...Hope this helps...
  • ping ping request could not find host

    ping destination host unreachable


    I tried turning off my windows firewall as well.

  • Based on the information above your router is using  See if you can ping that address (start > run > cmd[enter] and then ping[enter] at the c prompt).  If you can't ping the router then it is either a firewall, a problem with your network card (doubtful if you are getting a DHCP address assigned as it appears) or a problem with the router.

    You can request replacement reinstallation media for US purchased systems here.
    Dell Drivers & Downloads for all systems.

  • Hi.. I am having this same problem.. I followed the advice already given and pinged my IP address... All 4 packets were cent and received... The link status says I am connected however, every time I try to get on to the Internet.. I get the Internet Explorer cannot display the webpage message.. Also when I try to ping it tells me that it could not find host and to please check the name and try again.. Please help.. I got this computer for my daughter for Christmas and feel horrible that it is not allowing her to connect to the internet.. ALSO it is connecting when I plug it in directly and it will connect to unsecure networks.. just not secured ones.. even with the password.. Wierd... yes.. lol Thank you

  •  DollyDivine,


    Try the Windows key and the R keys at the same time. Type




    hit enter. type




    What happens?


    I wish Steve was here to help you, I miss him.





    What is a Dell Service Tag and how do I locate it? 

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

    #DellWorld 2012

    #DellWorld 2015

    #DellEMCWorld 2016

    #MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

  • Hello, I am in the same situation as you.  Did you ever get this resolved??


  • I too am having a very similar problem. seems to run rampant on dell d600's.  My dell D600's mobo ceased to work for  charge/ connector problem, so replaced mobo. prior to this all worked except running on charger and charging. Now replacement mobo using same wifi card, charges and runs computer and all is well except that no internet connection on cat 5 or wifi. it sees all available wifi connections showing same signal strength as my sons newer gateway, but while the gateway connects to all easily on cat 5 or wifi, Dell d600 will not connect under any circumstances. it says wifi card is working perfectly some ways that i check while other places it claims it isn't installed. installing and or repairing driver no help, even though it says successfully installed or repaired it still wont work. downloaded driver on gateway installed it on D600 using jump drive, stops saying instsallation interrupted each time install, no idea what is interrupting it, and  no change in operation. I didnt want to believe it's the card cause it worked fine with old mobo and sees the wifi connections and good signal strength, and sometimes reports the card is properly installed and working. but i guess new card is my next step. I still have no idea on cat5 not working either. I have 3 routers all same result with network names and passwords. im just as stumped as everyone else here.

  • Hi,


    I have a similar problem with my Dell D600. It used to connect to this router (EA4500) without problem, but one day from nothing it is not connecting anymore. I doesn’t complain about nothing but doesn’t connect.


    I can connect to my other router (E3000) without problem, but cannot do it to this EA4500.


    I have other 3 computers (1 PC and 2 MAC) that can connect to both routers without problems.


    I reboot many times my D600, I checked the Turemobile 1300 driver and it is working well, no complains no “!” on the device manager and as I said it can connect to the other router.


    I can connect with the Ethernet cable to this router without a problem but I cannot with the wireless.


    Do you have any suggestion?


    Thank you a lot,


    Fabio Corbellini Pereira