Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

r78727.exe does not work can't install ethernet driver

  • Hello,
    Dell Dimension 3000
    embedded ethernet adapater
    Here's what I have done so far.
    downladoed R78727.exe from dell support site.
    click run on R78727.exe
    installs drivers to c:\dell\drivers\R78727
    setup start on its' own.
    setupBD screen it says:
    Installing network drivers. Please wait...
    NO progress indicator
    after 15 seconds of so the program end and the setupDB screen disappears.
    I have downloaded the driver serveral times
    I have tried to run the setup.exe from the driver directory serveral times.
    always the same result.
    Anyone have any idea how to fix this.
  • why did you install the driver? did you reinstall the os or did it just stop working?
  • This is a barnd new install of XP home edition.
    unfortuately I lost the drivers disk and downloaed the sound, video and ethernet drivers from the dell support site. The sound and video drivers installed just fine.
    I have no addtional hardware, extra hard drives or any other type of MOD to conflict with. 
    When i click on the r78727.exe  icon it installs the files and then runs setup and then nothing happens. I have done this many time both rebooting and powering off the machine and trying again.
  • Did you install the chipset drivers as the first drivers installed after reinstallation of Windows? Without the chipset drivers, Windows will not be able to recognize or install drivers for many other devices. Did you read the Drivers Installation FAQ at the top of this forum?
  • Please check to see if Windows is installed on c:\.
    Sometimes the driver wizard is looking to extract the drivers to the c:\ drive. If you did your clean install into a partition labeled d:\ by mistake, then the driver will not install automatically.
    It's not likely the problem, but easy enough to overlook.



  • nope no partitions just a single c drive. so that can't be it.
    I'll tell ya this IS a head scratcher.
  • Does the ethernet controller show up as an unknown device in Device Manager? This is XP, right? Is the network controller enabled in BIOS?