Weak wireless signal on laptop

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Weak wireless signal on laptop

  • I have an Inspiron E1705 that gets a very weak and sporatic signal. By the way, I have a year old IBM T40 from work that gets a strong signal in exactly the same place. Is it possible to plug a high power antenna to the built in card, or do I need to buy a USB or PC card wireless adapter so I can use a high power antenna? Hawking makes a few different antennae that seem to fit the bill.
     
    Alternatively, is there some other way to boost the receptivity of the unit without adding an exteral device?
  • If your router has antennas try moving them around........not kidding seen it work. Also some router have adjustments for the signal strength.
     
     
     
  • Thanks, but I tried that. It appears to be a design flaw in the E1705 with the antenna. Perhaps it does not direct enough power it, or there is some kind of signal conflict. I have an old IBM T40 that gets a strong signal. It seems strange that a big pretty new Dell can not hold a candle (connection) to a little old IBM.
  • Is that computer new or did this just crop up... Ive bought a a few dell laptops over the years and typicaly the built in wireless work great with exclent range.
  • BTW the IBM ThinkPads are exceptional mach's
  • what type of wireless card do you have?? if you have an Intel card you can go into the advance properties and change some settings
  • It is the Intel unit that is included with the 1705. I believe the model number is 3945.
  • Right click on my computer
    left click on properites
    click on the hardware tab
    click on device manager
    click the + sign next to network adapters
    right click on your Intel wireless mini-pci card
    left click on properties
    click on advanced
    - depending on the type of card you have you may not have some of these options
    - left click to select:
    Throughput enchancement - uncheck "use default value box", use drop box to select enable

    Power management- uncheck "use default value box", make sure slider is to the highest point

    Preamble mode - uncheck "use default value box", use drop down to select long

    Transmit Power - uncheck "use default value box", make sure slider is to the highest point

    click OK, close device manager
    ----------------------------
    I'd go into the router interface and make sure the router was on channel 6 or 11, these channels have the least amount of interference
    - if you need help call router manufacturer, if ur gonna call em' make sure you have the latest firmware for the router as well !
    - good luck