GX260 LAN Drivers - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

GX260 LAN Drivers

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

GX260 LAN Drivers

  • I have a GX260 with corrupted LAN drivers.  I reloaded the drivers but it gives me a code31 error.  I wanted to verify that I should be using the Intel PRO 1000 MT driver.  Service Tag: 6FPR131
  • clay_strickland,
    Thank you for visiting the Dell Community Forum.
    That looks like the correct driver for the OptiPlex GX260 system. You may want to try downloading the driver from the Dell File Library and see if that helps. The driver is available at the following address:
  • Would it be ok try the drivers direct from Intel, or stick with the Dell drivers?  Will try the additional Dell drivers, and advise.
  • I loaded and tried the RX66787 drivers and they did the same (Code 31) Unknown device for Intel Pro 1000 MT.  I ran the Dell diagnostic cd, and the adapter passed tests.  I also loaded the Intel provided drivers for the NIC, and they had the same effect as the Dell provided drivers.

    Anything else to try...still sounds like a driver issue???


  • Final Resolution
    Looks like spyware got it read below, registry edit fixed problem...
    I have Adaware and Spybot on this machine...
    Posted by: redigit

    Whats up guys? I'm new to the forum, and I have issues.. Today I ran Ad-Aware on my system and found about 100 critical detections(been about a week since i ran last, and im not sure how i got all this) and a removed them all and rebooted my computer. when it came back i couldn't connect to my lan. the device manager shows my network card as an unkown device and won't install drivers for it. well i tried a manual install and it wouldn't show 'Network Adapters" on the hardware types list. I ran AVG and didn't detect any virii. I'm suspecting it had something to do with the adware. I have no idea how to fix this, any ideas?

    my specs:
    Windows XP SP1
    Soyo SYCK8 Dragon Plus Motherboard (Nforce chipset)
    Onboard LAN
    GeforceFX 5900

    Thanks again,

    Posted by: goranpaa

    Try uninstall the driver in control panel / Add remove programs. And the card in device manager and then reboot.

    Reinstall the drivers and see if this helps?

    Also try resetting windows restore point, to a date, when the stuff worked. Reinstall drivers.
    Download a trial of a Registry repair software.

    Posted by: Trilaworks

    I found a fix for this on a machine I was working on. There are Registry entries that hold the values of the Common Device Types. Due to a viruses or adaware one of these got deleted. You can export the key from another XP PC and import it into your PC to fix the problem. The registry key that needs to be imported is found under:


    (Note: Always make a backup of the registry before making any changes)

    The file I exported is off a Dell Dimension 2400. I have not tested it with non-Dell PC's, but I imagine once you replaced the key you could then go into the Device Manager and install the right driver for your card. I am putting a link to the registry key I exported on my web page at:


  • I Have dell gx260.But its  lan card is not working and giving  me NIC FAILURE  ERROR.CAN U GUVE ME SOME SUGGESTION TO RESOLVE THIS PROBLEM