"Limited or no connectivity" when using wireless USB adapter with WEP enabled on Dell Dim 8400 - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community

"Limited or no connectivity" when using wireless USB adapter with WEP enabled on Dell Dim 8400

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

"Limited or no connectivity" when using wireless USB adapter with WEP enabled on Dell Dim 8400

  • I'm having trouble connecting to my network using a wireless USB adapter with WEP enabled.  I'm using a Dell Dimension 8400 with Win XP pro w/ SP2. My wireless router is the Dlink DI-524. I tried using 2 wireless USB adapters, Netgear WG111 and Dlink DWL-G120.
    When I disable WEP, both network adapters can connect to the wireless router and ping the router. The wireless USB adapter gets a IP from router. When I enable the WEP, I get the "Limited or no connectivity" message and I can't ping the router. The wireless USB adapter gets the automatic IP windows assigns when its can't get an IP  from a DHCP server. I know my WEP key is correct. On the router, I can see the wireless usb adapters connect, but it seems as though it does not request a IP from the DHCP server. I can connect to the network through the ethernet lan port on the back of the computer. I've updated the bios on the 8400 and all drivers and firmware for the wireless USB adapters and the router. I have run all the windows updates. I've tried both the windows zero config and the propriety software to handle the encryption.
    I tried both wireless USB adapters on a laptop using WIn XP pro w/ SP2. Using the same drivers, both wireless USB adapters were able to connect to the laptop with WEP enabled using either windows zero config or the propriety software.
    The USB ports do work because I have a USB printer installed. And the network adapters always autodetect the wireless USB network adapters when they are plugged in. Everythings works fine on the computer except for this one problem.
    Solutions I've tried:
    Format the hard drive and Clean install of the OS.
    Updated Chipset Drivers.
    WinsockFixXP.exe in case of TCP\IP corruption.
    Cold Booting the Whole Configuration.
    Using Static DHCP with Manually Configured IPs.
    None of the solutions above allowed the wireless USB adapters to connect to the network with WEP enabled.
    I'm truly stumped. Any help you all can give me would be greatly appreciated.
  • It may seem like a stupid question but why exactly do you need to use WEP encryption? Could you do what you want another way by assigning a unique SSID and other methods of protecting your internet connection with a firewall on your PC and Laptop? Or are you you right in the middle of a building or physical address that prevents you from doing anything other than WEP encryption?

    Man it seems like you have been through a lot of trouble to get this to work so far.

    If I'm understanding you have no actual hardwired connection to your router from your 8400- is that right? If so have you tried connecting by hardwire from the 8400 to the router and enabling WEP? Just to see if it allows you to do the WEP thing with this PC- even if not wirelessly for the moment?

    It also seems clear it is not the 2 USB wireless adapters, since they both work on your laptop with WEP enabled.

    So it would seem logical that the problem rests with your router, possibly, or your 8400 machine. Have you searched the web site of the router mfg. for any clues as to what you have found so far. It seems strange that the USB adapters work on the laptop through the same router but not from your 8400.

    Do you find any yellow exclamation marks in device manager or is anything disable there- or do you show two of the same thing like adapters, etc.

    Let me know re: above questions.





  • I'll give you my take on your problem.  I just bought an Inspiron 1150 laptop with the 1350 Wireless card.  I am getting the same issue as you when I try to use my wireless network with the WEP encryption turned on.  It works fine without the WEP turned on.
    I spoke with Dell support for about 45 minutes one night and eventually the guy said they knew they had problems with encryption and this card and they didn't have a fix.  I have tried emailing Dell a couple of times to no avail.  I'm sick of it.  This is becoming a customer service black eye for them.  They either need to yank this card or tell buyers that it won't work with encrypted networks.
    To answer the other person about the need for WEP or other encryption - if you don't encrypt your network, the data is easily hackable.  Encrypting is not a guarantee, but much better than an unsecured network.  Just changing your SSID won't matter.  If someone is driving through your neighborhood, they can see your wireless network, no matter what SSID you have named it.  The goal is to encrypt the data transmission so it cannot be retrieved by hackers.
  • I was asking the person who posed the original question about why he needed to use WEP encryption on HIS specific system. Since neither he nor you can get the wireless cards to work properly with WEP it is better than nothing to change one's SSID instead of leaving it set on the default. Some protection in this circumstance is better than none and his neighborhood may not be a drive by hacker's paradise as it seems some people's neighborhood's are.

    Forget getting Dell to do anything about bogus functionality on wireless cards. Until enough people scream at them or word gets out about the cra* card they will not resolve it. This happened with Conexant modems with Win ME a few years back.

    So if you want true results dispute the purchase on your credit card bill within 30 days of purchase. Otherwise you're basically spitting into the wind.


  • Sorry Chimney - my post was not intended to sound like a smart @ss - apparently that's the way it was taken.

    My neighborhood is very nice so I don't worry a lot about drive-bys, but it pays to be careful. I think we both agree that encryption is best. My only point was that changing your SSID doesn't really do anything to protect your system - anyone who can see your network can see the SSID, so you've really done nothing to hinder them in that respect.

    Oddly, I emailed Dell again today and they have said they will send me a new wireless card. I need to ensure they aren't sending the same piece of junk again, but maybe I'm making some headway after all.

    We shall see - jr.
  • jr,

    No problem - I was also trying to find some solution for the person who was so frantic about WEP.

    Ask Dell for hardcopy verification of what they are going to send you. Sometimes promises are made and forgotten. Get an e-mail confirmation and description with part number so you can determine what they are sending you.

    From many years of experience with Dell and other companies - paperwork is the only way to get anything done to finality.

    Good luck,  :smileyvery-happy: