Unable to set up wireless connection on Dell Inspiron 600m

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Unable to set up wireless connection on Dell Inspiron 600m

  • I am trying to set up a friend's computer to work with my Netgear Router.

    The computer is a Dell Inspiron 600m. The Netgear Router is WGT624.

     

    I have used the router successfully with other laptops.

     

    On the new Dell Inspiron 600m, there appear to be three software methods to access the built-in wireless:

    1. The Dell Quickset

    2. The Intel PROSet for Wireless

    3. Windows XP Wireless configuration

     

    I have tried to play with all three. In all cases, the laptop recognizes that there is a wireless network present, but will not connect with it. I have tried WPA-PSK security and WEP security modes.

     

    Does anyone have any suggestions?

  • Rahul:

    That is what I posted on "giving up on inspiron 8600 thread .."

    Hope this will solve your problem.

    ==============


    I started this thread - I must provide the answers to others
    so that they don't suffer as much.

    After spending three days reading gazillian links including Intel
    and Microsoft databases, I finally made my machine's wireless
    interface work. It  pushed the limits of my technical knowledge
    - but I finally got this thing to work (sending this mail
    using the same!!).

    1. Router Support

    Most wireless routers, at this time, ship with the latest firmware
    that supports Centrino. However, if you baught  it last year,
    you may want to get the latest firmware. The lack of latest firmware
     is most likely not the problem in most cases. But, you may want to
    make sure as a first step that there is no Centrino specific issue with
    the wireless router that you have (a visit to manufacturer's website will
    be helpful. Netgear 814V2 versions before October 2003 release software
    had a Centrino specific issue – causing links to operate slowly or connection
    being dropped intermittently). If your router works with other Centrino
    notebook, you can totally ignore this step no matter where the advice comes
    from (including from a friend with good intensions on this thread.).

    2. On  XP/Intel issues on Dell Notebooks

    Here is the pack of golden tricks to get Dell (Centrino) systems
    to associate with the wireless link correctly:

    1.  The real culprit, it appears, is the Intel pro Software and Device driver
    for Centrino bundled with Dell, and incorrectly setup before shipping.
    It doesn't seem to support XP's bundled wireless zero configuration.
    Hence, it will most likely not even see your wireless router, and
    if does it will not associate with it or your connection will be intermittent and/or
    Your throughput will be very poor.  To get it to work correctly-, go to services
    menu (through control panel to performance and maintenace, then to
    administrative tools and the to services). i.) Open services and stop the wireless
    Zero service ii) Disable this service so that it doesn't start on the
    next power up. That will fix the conflict between what XP wants
    and what Intel driver does.


    2. Open the wireless networking interface (connect to network
    connection on your startup menu, press right button and open the
    properties for wireless network icon). Look for configure option
    under Intel(R) Pro/Wireless 2200 connection. Where it says power
    setup for transmitter – open the option and select manual instead of auto. Save
    configuration. I am not sure of this step - but I did it any way to ensure that Intel
    Pro software doesn’t apply any un-wanted  power optimization that may conflict
    with what Window XP does. By controlling the power manually – you know that
    you are getting maximum range (one things work for a few days – you may try
    auto setting but I haven’t bothered.)

    3. Make sure your router broadcasts the ssid, and your wireless
    interface is configured with the correct ssid. If you don't broadcast
    ssid - your wireless connection will shift between your and your
    neighbour's AP ( moronic XP design by some dim-witted sophomore
    at Microsoft ignores the profile preferences if your ssid is not broadcast.
    Microsoft says it is by design!). For testing purposes, set no encryption and
    Authentication type to open on both the router and your machine.

    4. Power down the computer using system shut-off menu. Power
    down your router (don't have to, but better).  Restart both one
    after another in any order you like (may be plug in the router
    first so that there is a faster connection). Your wireless link should
    Work now. You should at least see wireless interface saying excellent
    signal from the router.


    5) If for some reason, the system displays excellent signal for
    your ssid but doesn't connect - check if your router is not applying
    any Mac filtering, or if there is any security key mismatch (these are easy
    problems.) If you don't understand what I am saying here - you most likely
    don't have a wep key or mac filtering setup on your router (unless
    your older brother set up the router ;-)).


    6) If the system still can't see your wireless router - go to
    step 1 and verify the configuration in step 1 and 2.


    7) If it still doesn't work - you may have faulty hardware -
    arrange a return to Dell (with a brutally nasty note attached
    to it - ;-)). But if it works, you would hopefully like your
    new toy.

    Hope, above directions minimize your pain.

    ps: Dell support is pathetic - don't expect those telephone operators
    in India to know much about wireless. They can't differentiate
    a cow's tail from a 802.11 antenna given that they don't use
    802.11 there. Besides, you will spend hours trying to connect
    to them. So ignore them but do register your complain with Dell.


    --bk